aboutsummaryrefslogtreecommitdiff
path: root/multimedia/v4l-utils
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-06-25 19:13:25 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-06-25 19:13:25 +0000
commit45ab52dc7687200b9f4833fb9c72f699c50d0559 (patch)
treed8bcb54e7ddc83198fef30230f26d40ffab051e2 /multimedia/v4l-utils
parenta37a080307b4cd0c72feaa3119bd0b5fb3d5a492 (diff)
Notes
Diffstat (limited to 'multimedia/v4l-utils')
-rw-r--r--multimedia/v4l-utils/Makefile48
-rw-r--r--multimedia/v4l-utils/distinfo2
-rw-r--r--multimedia/v4l-utils/files/extra-strnlen45
-rw-r--r--multimedia/v4l-utils/files/patch-Make.rules26
-rw-r--r--multimedia/v4l-utils/files/patch-Makefile25
-rw-r--r--multimedia/v4l-utils/files/patch-decode_tm6000__decode_tm6000.c11
-rw-r--r--multimedia/v4l-utils/files/patch-keytable__Makefile24
-rw-r--r--multimedia/v4l-utils/files/patch-keytable__keytable.c25
-rw-r--r--multimedia/v4l-utils/files/patch-libv4l2util__v4l2_driver.c14
-rw-r--r--multimedia/v4l-utils/files/patch-qv4l2__v4l2-api.h13
-rw-r--r--multimedia/v4l-utils/files/patch-v4l2-ctl__ivtv-ctl.c17
-rw-r--r--multimedia/v4l-utils/files/patch-v4l2-ctl__v4l2-ctl.cpp34
-rw-r--r--multimedia/v4l-utils/files/patch-v4l2-dbg__v4l2-dbg.cpp34
-rw-r--r--multimedia/v4l-utils/pkg-descr5
-rw-r--r--multimedia/v4l-utils/pkg-plist117
15 files changed, 440 insertions, 0 deletions
diff --git a/multimedia/v4l-utils/Makefile b/multimedia/v4l-utils/Makefile
new file mode 100644
index 000000000000..ddaa55fd480f
--- /dev/null
+++ b/multimedia/v4l-utils/Makefile
@@ -0,0 +1,48 @@
+# Ports collection makefile for: v4l-utils
+# Date created: Thu Jun 2 22:22:47 CEST 2011
+# Whom: Juergen Lock <nox@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= v4l-utils
+PORTVERSION= 0.8.4
+CATEGORIES= multimedia
+MASTER_SITES= http://linuxtv.org/downloads/v4l-utils/
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= Video4Linux utilities
+
+BUILD_DEPENDS= v4l_compat>=1.0.20110603:${PORTSDIR}/multimedia/v4l_compat \
+ libv4l>=0.8.4:${PORTSDIR}/multimedia/libv4l
+LIB_DEPENDS= v4l2.0:${PORTSDIR}/multimedia/libv4l \
+ argp.0:${PORTSDIR}/devel/argp-standalone
+
+MAKE_ARGS= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -DPREFIX=\\\"${PREFIX}\\\"" \
+ LIBDIR="${PREFIX}/lib" LDFLAGS="-L${LOCALBASE}/lib -largp"
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/utils
+MAN1= ir-keytable.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800000
+EXTRA_PATCHES= ${FILESDIR}/extra-strnlen
+.endif
+
+post-patch:
+ @${RM} ${WRKSRC}/../include/linux/videodev2.h
+ @${REINPLACE_CMD} -e 's|#include <sys/klog.h>||g' \
+ -e 's|#include <features.h>||g' \
+ -e 's|#include <linux/types.h>||g' \
+ ${WRKSRC}/v4l2-compliance/v4l2-compliance.cpp \
+ ${WRKSRC}/v4l2-compliance/v4l2-test-debug.cpp \
+ ${WRKSRC}/v4l2-ctl/cx18-ctl.c \
+ ${WRKSRC}/v4l2-ctl/ivtv-ctl.c \
+ ${WRKSRC}/../include/linux/ivtv.h
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/v4l-utils/distinfo b/multimedia/v4l-utils/distinfo
new file mode 100644
index 000000000000..e0df94415f6e
--- /dev/null
+++ b/multimedia/v4l-utils/distinfo
@@ -0,0 +1,2 @@
+SHA256 (v4l-utils-0.8.4.tar.bz2) = 20bf73b0c2255dfc6ae82806ec8a663e00ab039df9ee6eadae633466841c0dd7
+SIZE (v4l-utils-0.8.4.tar.bz2) = 348601
diff --git a/multimedia/v4l-utils/files/extra-strnlen b/multimedia/v4l-utils/files/extra-strnlen
new file mode 100644
index 000000000000..3954167d8bad
--- /dev/null
+++ b/multimedia/v4l-utils/files/extra-strnlen
@@ -0,0 +1,45 @@
+copied from src/lib/libc/string/strnlen.c
+Copyright (c) 2009 David Schultz <das@FreeBSD.org>
+
+--- v4l2-compliance/v4l2-compliance.cpp.orig 2011-06-04 11:03:04.000000000 +0200
++++ v4l2-compliance/v4l2-compliance.cpp 2011-06-04 11:03:34.000000000 +0200
+@@ -56,6 +56,18 @@ enum Option {
+ OptLast = 256
+ };
+
++static size_t
++strnlen(const char *s, size_t maxlen)
++{
++ size_t len;
++
++ for (len = 0; len < maxlen; len++, s++) {
++ if (!*s)
++ break;
++ }
++ return (len);
++}
++
+ static char options[OptLast];
+
+ static int app_result;
+--- v4l2-compliance/v4l2-test-controls.cpp.orig 2011-06-04 11:12:52.000000000 +0200
++++ v4l2-compliance/v4l2-test-controls.cpp 2011-06-04 11:13:06.000000000 +0200
+@@ -32,6 +32,18 @@
+ #include <vector>
+ #include "v4l2-compliance.h"
+
++static size_t
++strnlen(const char *s, size_t maxlen)
++{
++ size_t len;
++
++ for (len = 0; len < maxlen; len++, s++) {
++ if (!*s)
++ break;
++ }
++ return (len);
++}
++
+ static int checkQCtrl(struct node *node, struct test_queryctrl &qctrl)
+ {
+ struct v4l2_querymenu qmenu;
diff --git a/multimedia/v4l-utils/files/patch-Make.rules b/multimedia/v4l-utils/files/patch-Make.rules
new file mode 100644
index 000000000000..23ed35a13bef
--- /dev/null
+++ b/multimedia/v4l-utils/files/patch-Make.rules
@@ -0,0 +1,26 @@
+--- ../Make.rules.orig 2010-08-26 17:19:37.000000000 +0200
++++ ../Make.rules 2010-11-04 20:26:22.000000000 +0100
+@@ -7,8 +7,8 @@ CFLAGS += -Wall -Wpointer-arith
+ CXXFLAGS := $(CFLAGS)
+ CFLAGS += -Wstrict-prototypes -Wmissing-prototypes
+
+-PREFIX = /usr/local
+-LIBDIR = $(PREFIX)/lib
++PREFIX ?= /usr/local
++LIBDIR ?= $(PREFIX)/lib
+ # subdir below LIBDIR in which to install the libv4lx libc wrappers
+ LIBSUBDIR = libv4l
+
+@@ -22,10 +22,10 @@ LIB_RELEASE = 0
+ # And last various rules
+
+ %.o: %.c
+- $(CC) -Wp,-MMD,"$*.d",-MQ,"$@",-MP -c $(CPPFLAGS) $(CFLAGS) -o $@ $<
++ $(CC) -MMD -MF "$*.d" -MQ "$@" -MP -c $(CPPFLAGS) $(CFLAGS) -o $@ $<
+
+ %.o: %.cpp
+- $(CXX) -Wp,-MMD,"$*.d",-MQ,"$@",-MP -c $(CPPFLAGS) $(CXXFLAGS) -o $@ $<
++ $(CXX) -MMD -MF "$*.d" -MQ "$@" -MP -c $(CPPFLAGS) $(CXXFLAGS) -o $@ $<
+
+ %.so:
+ $(CC) -shared $(LDFLAGS) -Wl,-soname,$@.$(LIB_RELEASE) -o $@.$(LIB_RELEASE) $^ $(LIBS_$*)
diff --git a/multimedia/v4l-utils/files/patch-Makefile b/multimedia/v4l-utils/files/patch-Makefile
new file mode 100644
index 000000000000..645b2f73573e
--- /dev/null
+++ b/multimedia/v4l-utils/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- ./Makefile.orig 2011-02-09 23:04:27.000000000 +0100
++++ ./Makefile 2011-06-03 19:08:13.000000000 +0200
+@@ -1,4 +1,5 @@
+-SUBDIRS=libv4l2util decode_tm6000 keytable rds v4l2-compliance v4l2-ctl v4l2-dbg xc3028-firmware
++#SUBDIRS=libv4l2util decode_tm6000 keytable rds v4l2-compliance v4l2-ctl v4l2-dbg xc3028-firmware
++SUBDIRS=libv4l2util decode_tm6000 keytable v4l2-compliance v4l2-ctl v4l2-dbg
+
+ all install:
+ @for i in $(SUBDIRS); do \
+@@ -10,6 +11,7 @@
+ $(MAKE) -C v4l2-sysfs-path $@; \
+ fi
+
++ifdef WITH_QV4L2
+ # Test whether qmake is installed, and whether it is for qt4.
+ @if which qmake-qt4 >/dev/null 2>&1; then \
+ QMAKE=qmake-qt4; \
+@@ -24,6 +26,7 @@
+ $(MAKE) -C qv4l2 -f Makefile.install $@; \
+ fi \
+ fi
++endif
+
+ sync-with-kernel:
+ $(MAKE) -C keytable $@
diff --git a/multimedia/v4l-utils/files/patch-decode_tm6000__decode_tm6000.c b/multimedia/v4l-utils/files/patch-decode_tm6000__decode_tm6000.c
new file mode 100644
index 000000000000..ee2d3f5022d9
--- /dev/null
+++ b/multimedia/v4l-utils/files/patch-decode_tm6000__decode_tm6000.c
@@ -0,0 +1,11 @@
+--- ./decode_tm6000/decode_tm6000.c.orig 2011-02-09 23:04:27.000000000 +0100
++++ ./decode_tm6000/decode_tm6000.c 2011-06-03 19:08:13.000000000 +0200
+@@ -41,6 +41,8 @@
+ { 0, 0, 0, 0, 0, 0 }
+ };
+
++#define devname dev_name
++
+ static char outbuf[692224];
+ static int debug=0, audio=0, use_mmap=1, nbufs=4;
+ static float freq_mhz=193.25;
diff --git a/multimedia/v4l-utils/files/patch-keytable__Makefile b/multimedia/v4l-utils/files/patch-keytable__Makefile
new file mode 100644
index 000000000000..181a3cc40549
--- /dev/null
+++ b/multimedia/v4l-utils/files/patch-keytable__Makefile
@@ -0,0 +1,24 @@
+--- keytable/Makefile.orig 2011-06-01 13:23:03.000000000 +0200
++++ keytable/Makefile 2011-06-04 09:43:14.000000000 +0200
+@@ -34,12 +34,14 @@
+ install: $(TARGETS)
+ mkdir -p $(DESTDIR)$(PREFIX)/bin $(DESTDIR)/etc
+ install -m 755 $(TARGETS) $(DESTDIR)$(PREFIX)/bin
+- install -m 644 -p rc_maps.cfg $(DESTDIR)/etc
+- install -m 755 -d $(DESTDIR)/etc/rc_keymaps
+- install -m 644 -p rc_keymaps/* $(DESTDIR)/etc/rc_keymaps
+- install -m 755 -d $(DESTDIR)/lib/udev/rules.d
+- install -m 644 -p 70-infrared.rules $(DESTDIR)/lib/udev/rules.d
+- install -m 755 -d $(DESTDIR)$(MANDIR)/man1
+- install -m 644 -p ir-keytable.1 $(DESTDIR)$(MANDIR)/man1
++ install -m 644 -p rc_maps.cfg $(DESTDIR)$(PREFIX)/etc
++ install -m 755 -d $(DESTDIR)$(PREFIX)/etc/rc_keymaps
++ install -m 644 -p rc_keymaps/* $(DESTDIR)$(PREFIX)/etc/rc_keymaps
++ifdef UDEV
++ install -m 755 -d $(DESTDIR)$(PREFIX)/etc/udev/rules.d
++ install -m 644 -p 70-infrared.rules $(DESTDIR)$(PREFIX)/etc/udev/rules.d
++endif
++ install -m 755 -d $(DESTDIR)$(PREFIX)/man/man1
++ install -m 644 -p ir-keytable.1 $(DESTDIR)$(PREFIX)/man/man1
+
+ include ../../Make.rules
diff --git a/multimedia/v4l-utils/files/patch-keytable__keytable.c b/multimedia/v4l-utils/files/patch-keytable__keytable.c
new file mode 100644
index 000000000000..f34d2009aa4b
--- /dev/null
+++ b/multimedia/v4l-utils/files/patch-keytable__keytable.c
@@ -0,0 +1,25 @@
+--- ./keytable/keytable.c.orig 2011-02-09 23:04:27.000000000 +0100
++++ ./keytable/keytable.c 2011-06-03 19:08:13.000000000 +0200
+@@ -28,7 +28,11 @@
+ #include "parse.h"
+
+ /* Default place where the keymaps will be stored */
++#ifndef __FreeBSD__
+ #define CFGDIR "/etc/rc_keymaps"
++#else
++#define CFGDIR PREFIX "/etc/rc_keymaps"
++#endif
+
+ struct input_keymap_entry_v2 {
+ #define KEYMAP_BY_INDEX (1 << 0)
+@@ -137,6 +141,10 @@
+ "--sysdev [ir class (f. ex. rc0)]\n"
+ "[for using the rc0 sysdev]";
+
++#ifdef __FreeBSD__
++#define devname dev_name
++#endif
++
+ /* Static vars to store the parameters */
+ static char *devclass = "rc0";
+ static char *devname = NULL;
diff --git a/multimedia/v4l-utils/files/patch-libv4l2util__v4l2_driver.c b/multimedia/v4l-utils/files/patch-libv4l2util__v4l2_driver.c
new file mode 100644
index 000000000000..e9690ce5ac82
--- /dev/null
+++ b/multimedia/v4l-utils/files/patch-libv4l2util__v4l2_driver.c
@@ -0,0 +1,14 @@
+--- ./libv4l2util/v4l2_driver.c.orig 2011-02-09 23:04:27.000000000 +0100
++++ ./libv4l2util/v4l2_driver.c 2011-06-03 19:08:13.000000000 +0200
+@@ -15,7 +15,11 @@
+ #include <assert.h>
+ #include <errno.h>
+ #include <fcntl.h>
++#ifndef __FreeBSD__
+ #include <malloc.h>
++#else
++#include <stdlib.h>
++#endif
+ #include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
diff --git a/multimedia/v4l-utils/files/patch-qv4l2__v4l2-api.h b/multimedia/v4l-utils/files/patch-qv4l2__v4l2-api.h
new file mode 100644
index 000000000000..3b5df556261a
--- /dev/null
+++ b/multimedia/v4l-utils/files/patch-qv4l2__v4l2-api.h
@@ -0,0 +1,13 @@
+--- ./qv4l2/v4l2-api.h.orig 2011-02-09 23:04:27.000000000 +0100
++++ ./qv4l2/v4l2-api.h 2011-06-03 19:08:13.000000000 +0200
+@@ -24,6 +24,10 @@
+ #include <linux/videodev2.h>
+ #include <libv4lconvert.h>
+
++#ifdef __FreeBSD__
++typedef off_t __off64_t;
++#endif
++
+ class v4l2
+ {
+ public:
diff --git a/multimedia/v4l-utils/files/patch-v4l2-ctl__ivtv-ctl.c b/multimedia/v4l-utils/files/patch-v4l2-ctl__ivtv-ctl.c
new file mode 100644
index 000000000000..2563313399d0
--- /dev/null
+++ b/multimedia/v4l-utils/files/patch-v4l2-ctl__ivtv-ctl.c
@@ -0,0 +1,17 @@
+--- ./v4l2-ctl/ivtv-ctl.c.orig 2011-02-09 23:04:27.000000000 +0100
++++ ./v4l2-ctl/ivtv-ctl.c 2011-06-03 19:20:05.000000000 +0200
+@@ -498,7 +498,13 @@
+ if (ioctl(fd, VIDEO_GET_EVENT, &ev) < 0) {
+ fprintf(stderr, "ioctl: VIDEO_GET_EVENT failed\n");
+ break;
+- } else if (ev.timestamp == 0) {
++ }
++#ifndef __FreeBSD__
++ else if (ev.timestamp == 0)
++#else
++ else if (ev.timestamp.tv_sec == 0)
++#endif
++ {
+ unsigned long long pts = 0, frame = 0;
+ struct timeval tv;
+ gettimeofday(&tv, NULL);
diff --git a/multimedia/v4l-utils/files/patch-v4l2-ctl__v4l2-ctl.cpp b/multimedia/v4l-utils/files/patch-v4l2-ctl__v4l2-ctl.cpp
new file mode 100644
index 000000000000..e4258ecfe63b
--- /dev/null
+++ b/multimedia/v4l-utils/files/patch-v4l2-ctl__v4l2-ctl.cpp
@@ -0,0 +1,34 @@
+--- v4l2-ctl/v4l2-ctl.cpp.orig 2011-06-01 13:23:03.000000000 +0200
++++ v4l2-ctl/v4l2-ctl.cpp 2011-06-04 10:03:21.000000000 +0200
+@@ -21,7 +21,6 @@
+ */
+
+ #include <unistd.h>
+-#include <features.h> /* Uses _GNU_SOURCE to define getsubopt in stdlib.h */
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -36,7 +35,6 @@
+ #include <sys/time.h>
+ #include <dirent.h>
+ #include <math.h>
+-#include <sys/klog.h>
+
+ #include <linux/videodev2.h>
+ #include <libv4l2.h>
+@@ -3279,6 +3277,7 @@
+ static char buf[40960];
+ int len;
+
++#ifndef __FreeBSD__
+ if (doioctl(fd, VIDIOC_LOG_STATUS, NULL) == 0) {
+ printf("\nStatus Log:\n\n");
+ len = klogctl(3, buf, sizeof(buf) - 1);
+@@ -3300,6 +3299,7 @@
+ }
+ }
+ }
++#endif
+ }
+
+ /* List options */
diff --git a/multimedia/v4l-utils/files/patch-v4l2-dbg__v4l2-dbg.cpp b/multimedia/v4l-utils/files/patch-v4l2-dbg__v4l2-dbg.cpp
new file mode 100644
index 000000000000..6652666a88c9
--- /dev/null
+++ b/multimedia/v4l-utils/files/patch-v4l2-dbg__v4l2-dbg.cpp
@@ -0,0 +1,34 @@
+--- v4l2-dbg/v4l2-dbg.cpp.orig 2011-06-01 13:23:03.000000000 +0200
++++ v4l2-dbg/v4l2-dbg.cpp 2011-06-04 10:04:30.000000000 +0200
+@@ -17,7 +17,6 @@
+ */
+
+ #include <unistd.h>
+-#include <features.h> /* Uses _GNU_SOURCE to define getsubopt in stdlib.h */
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -31,7 +30,6 @@
+ #include <sys/ioctl.h>
+ #include <sys/time.h>
+ #include <math.h>
+-#include <sys/klog.h>
+
+ #include <linux/videodev2.h>
+ #include <media/v4l2-chip-ident.h>
+@@ -767,6 +765,7 @@
+ static char buf[40960];
+ int len;
+
++#ifndef __FreeBSD__
+ if (doioctl(fd, VIDIOC_LOG_STATUS, NULL, "VIDIOC_LOG_STATUS") == 0) {
+ printf("\nStatus Log:\n\n");
+ len = klogctl(3, buf, sizeof(buf) - 1);
+@@ -788,6 +787,7 @@
+ }
+ }
+ }
++#endif
+ }
+
+ if (options[OptListSymbols]) {
diff --git a/multimedia/v4l-utils/pkg-descr b/multimedia/v4l-utils/pkg-descr
new file mode 100644
index 000000000000..f5072f93c750
--- /dev/null
+++ b/multimedia/v4l-utils/pkg-descr
@@ -0,0 +1,5 @@
+Linux V4L2 and DVB API utilities shipped with the v4l libraries (libv4l).
+You can always find the latest development v4l-utils in the git repo:
+http://git.linuxtv.org/v4l-utils.git
+
+WWW: http://freshmeat.net/projects/libv4l
diff --git a/multimedia/v4l-utils/pkg-plist b/multimedia/v4l-utils/pkg-plist
new file mode 100644
index 000000000000..22f53c50d182
--- /dev/null
+++ b/multimedia/v4l-utils/pkg-plist
@@ -0,0 +1,117 @@
+bin/cx18-ctl
+bin/decode_tm6000
+bin/ir-keytable
+bin/ivtv-ctl
+bin/v4l2-compliance
+bin/v4l2-ctl
+etc/rc_keymaps/a800
+etc/rc_keymaps/adstech_dvb_t_pci
+etc/rc_keymaps/af9005
+etc/rc_keymaps/alink_dtu_m
+etc/rc_keymaps/anysee
+etc/rc_keymaps/apac_viewcomp
+etc/rc_keymaps/asus_pc39
+etc/rc_keymaps/ati_tv_wonder_hd_600
+etc/rc_keymaps/avermedia
+etc/rc_keymaps/avermedia_a16d
+etc/rc_keymaps/avermedia_cardbus
+etc/rc_keymaps/avermedia_dvbt
+etc/rc_keymaps/avermedia_m135a
+etc/rc_keymaps/avermedia_m733a_rm_k6
+etc/rc_keymaps/avermedia_rm_ks
+etc/rc_keymaps/avertv_303
+etc/rc_keymaps/azurewave_ad_tu700
+etc/rc_keymaps/behold
+etc/rc_keymaps/behold_columbus
+etc/rc_keymaps/budget_ci_old
+etc/rc_keymaps/cinergy
+etc/rc_keymaps/cinergy_1400
+etc/rc_keymaps/cinergyt2
+etc/rc_keymaps/d680_dmb
+etc/rc_keymaps/dib0700_nec
+etc/rc_keymaps/dib0700_rc5
+etc/rc_keymaps/dibusb
+etc/rc_keymaps/digitalnow_tinytwin
+etc/rc_keymaps/digittrade
+etc/rc_keymaps/digitv
+etc/rc_keymaps/dm1105_nec
+etc/rc_keymaps/dntv_live_dvb_t
+etc/rc_keymaps/dntv_live_dvbt_pro
+etc/rc_keymaps/dtt200u
+etc/rc_keymaps/dvico_mce
+etc/rc_keymaps/dvico_portable
+etc/rc_keymaps/dw210x
+etc/rc_keymaps/em_terratec
+etc/rc_keymaps/encore_enltv
+etc/rc_keymaps/encore_enltv2
+etc/rc_keymaps/encore_enltv_fm53
+etc/rc_keymaps/evga_indtube
+etc/rc_keymaps/eztv
+etc/rc_keymaps/flydvb
+etc/rc_keymaps/flyvideo
+etc/rc_keymaps/fusionhdtv_mce
+etc/rc_keymaps/gadmei_rm008z
+etc/rc_keymaps/genius_tvgo_a11mce
+etc/rc_keymaps/gotview7135
+etc/rc_keymaps/haupp
+etc/rc_keymaps/hauppauge
+etc/rc_keymaps/imon_mce
+etc/rc_keymaps/imon_pad
+etc/rc_keymaps/iodata_bctv7e
+etc/rc_keymaps/kaiomy
+etc/rc_keymaps/kworld_315u
+etc/rc_keymaps/kworld_plus_tv_analog
+etc/rc_keymaps/leadtek_y04g0051
+etc/rc_keymaps/lme2510
+etc/rc_keymaps/manli
+etc/rc_keymaps/megasky
+etc/rc_keymaps/msi_digivox_ii
+etc/rc_keymaps/msi_digivox_iii
+etc/rc_keymaps/msi_tvanywhere
+etc/rc_keymaps/msi_tvanywhere_plus
+etc/rc_keymaps/nebula
+etc/rc_keymaps/nec_terratec_cinergy_xs
+etc/rc_keymaps/norwood
+etc/rc_keymaps/npgtech
+etc/rc_keymaps/opera1
+etc/rc_keymaps/pctv_sedna
+etc/rc_keymaps/pinnacle310e
+etc/rc_keymaps/pinnacle_color
+etc/rc_keymaps/pinnacle_grey
+etc/rc_keymaps/pinnacle_pctv_hd
+etc/rc_keymaps/pixelview
+etc/rc_keymaps/pixelview_002t
+etc/rc_keymaps/pixelview_mk12
+etc/rc_keymaps/pixelview_new
+etc/rc_keymaps/powercolor_real_angel
+etc/rc_keymaps/proteus_2309
+etc/rc_keymaps/purpletv
+etc/rc_keymaps/pv951
+etc/rc_keymaps/rc6_mce
+etc/rc_keymaps/real_audio_220_32_keys
+etc/rc_keymaps/streamzap
+etc/rc_keymaps/su3000
+etc/rc_keymaps/tbs
+etc/rc_keymaps/tbs_nec
+etc/rc_keymaps/technisat_usb2
+etc/rc_keymaps/terratec_cinergy_xs
+etc/rc_keymaps/terratec_slim
+etc/rc_keymaps/terratec_slim_2
+etc/rc_keymaps/tevii
+etc/rc_keymaps/tevii_nec
+etc/rc_keymaps/tivo
+etc/rc_keymaps/total_media_in_hand
+etc/rc_keymaps/trekstor
+etc/rc_keymaps/tt_1500
+etc/rc_keymaps/tvwalkertwin
+etc/rc_keymaps/twinhan_vp1027_dvbs
+etc/rc_keymaps/videomate_m1f
+etc/rc_keymaps/videomate_s350
+etc/rc_keymaps/videomate_tv_pvr
+etc/rc_keymaps/vp702x
+etc/rc_keymaps/vp7045
+etc/rc_keymaps/winfast
+etc/rc_keymaps/winfast_usbii_deluxe
+etc/rc_maps.cfg
+sbin/v4l2-dbg
+@dirrmtry etc/rc_keymaps