aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-upnp/files/patch-Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2011-03-26 19:21:08 +0000
committerJuergen Lock <nox@FreeBSD.org>2011-03-26 19:21:08 +0000
commitccc7f468f6ba0dfb0dbcb8fea824e25c20eaaf2f (patch)
treed2e005286d99c83639a47a2bbd83da7d3c8610f1 /multimedia/vdr-plugin-upnp/files/patch-Makefile
parent32777e78a4d6211eb29c25c27c96fbdd6bc11c54 (diff)
downloadports-ccc7f468f6ba0dfb0dbcb8fea824e25c20eaaf2f.tar.gz
ports-ccc7f468f6ba0dfb0dbcb8fea824e25c20eaaf2f.zip
Notes
Diffstat (limited to 'multimedia/vdr-plugin-upnp/files/patch-Makefile')
-rw-r--r--multimedia/vdr-plugin-upnp/files/patch-Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/multimedia/vdr-plugin-upnp/files/patch-Makefile b/multimedia/vdr-plugin-upnp/files/patch-Makefile
new file mode 100644
index 000000000000..3576ae999cc7
--- /dev/null
+++ b/multimedia/vdr-plugin-upnp/files/patch-Makefile
@@ -0,0 +1,31 @@
+--- a/Makefile
++++ b/Makefile
+@@ -42,6 +42,9 @@ PACKAGE = vdr-$(ARCHIVE)
+
+ ### Includes and Defines (add further entries here):
+
++ifdef FREEBSD
++LIBS += -L${LOCALBASE}/lib
++endif
+ LIBS += -lupnp -lixml -lsqlite3 -lavformat -lavcodec
+
+ INCLUDES += -I$(VDRDIR)/include -I/usr/include -Iinc \
+@@ -150,7 +153,11 @@ i18n: $(I18Nmsgs) $(I18Npot)
+
+ libvdr-$(PLUGIN).so: $(OBJS)
+ $(CXX) $(CXXFLAGS) $(LIBS) -shared $(OBJS) -o $@ -lc
++ifdef FREEBSD
++ @cp -f $@ $(LIBDIR)/$@.$(APIVERSION)
++else
+ @cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
++endif
+
+ dist: clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+@@ -162,3 +169,6 @@ dist: clean
+
+ clean:
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~ $(PODIR)/*.mo $(PODIR)/*.pot
++
++install:
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)