aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-wirbelscan/files
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2011-04-30 19:09:06 +0000
committerJuergen Lock <nox@FreeBSD.org>2011-04-30 19:09:06 +0000
commit69f41c8ff4bd1173fdc99e32cd14ca17954957ed (patch)
treeb86e707ce5926cade858061f0a0135604e6dc178 /multimedia/vdr-plugin-wirbelscan/files
parent551fea4ca8232638928ed49d03c90d4007cf53ab (diff)
downloadports-69f41c8ff4bd1173fdc99e32cd14ca17954957ed.tar.gz
ports-69f41c8ff4bd1173fdc99e32cd14ca17954957ed.zip
Notes
Diffstat (limited to 'multimedia/vdr-plugin-wirbelscan/files')
-rw-r--r--multimedia/vdr-plugin-wirbelscan/files/patch-Makefile21
-rw-r--r--multimedia/vdr-plugin-wirbelscan/files/types.sed5
2 files changed, 26 insertions, 0 deletions
diff --git a/multimedia/vdr-plugin-wirbelscan/files/patch-Makefile b/multimedia/vdr-plugin-wirbelscan/files/patch-Makefile
new file mode 100644
index 000000000000..fa0a8e115701
--- /dev/null
+++ b/multimedia/vdr-plugin-wirbelscan/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -119,7 +119,11 @@ i18n: $(I18Nmsgs) $(I18Npot)
+
+ libvdr-$(PLUGIN).so: $(OBJS)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
++ifdef FREEBSD
++ @cp -f $@ $(LIBDIR)/$@.$(APIVERSION)
++else
+ @cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
++endif
+
+ perm:
+ @chmod 644 *.{c,h,html} COPYING HISTORY README TODO Makefile po/* patches/*
+@@ -138,3 +142,6 @@ clean:
+
+ clean_code: clean
+ uncrustify -c ../../../../clean_code/config --replace --no-backup $(UNCRUSTIFY_FILES)
++
++install:
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
diff --git a/multimedia/vdr-plugin-wirbelscan/files/types.sed b/multimedia/vdr-plugin-wirbelscan/files/types.sed
new file mode 100644
index 000000000000..6230cb96b7a1
--- /dev/null
+++ b/multimedia/vdr-plugin-wirbelscan/files/types.sed
@@ -0,0 +1,5 @@
+/^#include <linux\/dvb\/frontend.h>/i\
+#include <stdint.h>
+s/^#include <linux\/types.h>/#include <stdint.h>/
+s/__u8/uint8_t/g
+s/__u32/uint32_t/g