aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-xineliboutput
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2013-10-03 18:18:01 +0000
committerJuergen Lock <nox@FreeBSD.org>2013-10-03 18:18:01 +0000
commit200890c2c6c7d115e333db32f8ad1c854cbdb5bd (patch)
tree1b076f455170619ef6e77e3dd4acf15597f8dadc /multimedia/vdr-plugin-xineliboutput
parentf73ef1b8cebac1204f30d9d7ee52863551960f95 (diff)
downloadports-200890c2c6c7d115e333db32f8ad1c854cbdb5bd.tar.gz
ports-200890c2c6c7d115e333db32f8ad1c854cbdb5bd.zip
- Invoke configure seperately as gmake apparently no longer picks up
the generated config.mak properly otherwise, breaking the build again with clang. - Fix passing of conditional configure args in the process. - Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=329219
Diffstat (limited to 'multimedia/vdr-plugin-xineliboutput')
-rw-r--r--multimedia/vdr-plugin-xineliboutput/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/multimedia/vdr-plugin-xineliboutput/Makefile b/multimedia/vdr-plugin-xineliboutput/Makefile
index 1ead04373c88..0d18859fa374 100644
--- a/multimedia/vdr-plugin-xineliboutput/Makefile
+++ b/multimedia/vdr-plugin-xineliboutput/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vdr-plugin-xineliboutput
PORTVERSION= 1.0.90s20120511
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= multimedia
MASTER_SITES= SF:release \
LOCAL:snapshot
@@ -30,27 +30,27 @@ WRKSRC= ${WRKDIR}/vdr-${PLUGIN}
OPTIONS_DEFINE= LIBBLURAY LIBEXTRACTOR
+HAS_CONFIGURE= yes
NO_STAGE= yes
+
.include "${.CURDIR}/../vdr/Makefile.plugins"
.include <bsd.port.pre.mk>
+CONFIGURE_ARGS+= --cc="${CC}" --cxx="${CXX}" --add-cflags=-I$(VDRDIR)
+
.if ${PORT_OPTIONS:MLIBEXTRACTOR}
LIB_DEPENDS+= extractor:${PORTSDIR}/textproc/libextractor
-CONFIGURE_OPTS+= --enable-libextractor
.else
-CONFIGURE_OPTS+= --disable-libextractor
+CONFIGURE_ARGS+= --disable-libextractor
.endif
.if ${PORT_OPTIONS:MLIBBLURAY}
-CONFIGURE_OPTS+= --enable-libbluray
LIB_DEPENDS+= bluray:${PORTSDIR}/multimedia/libbluray
.else
-CONFIGURE_OPTS+= --disable-libbluray
+CONFIGURE_ARGS+= --disable-libbluray
.endif
-MAKE_ARGS+= CONFIGURE_OPTS="${CONFIGURE_OPTS}"
-
post-patch: post-patch-plugin
# clang doesn't know -MG
${TOUCH} -t 200001010000 ${WRKSRC}/nosignal_720x576.c \