aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vlc-devel/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2004-11-17 01:05:23 +0000
committerMichael Johnson <ahze@FreeBSD.org>2004-11-17 01:05:23 +0000
commita894ef19696df1a711b6ce833769684712834a5f (patch)
tree39bdac2462cf70f1cb16e498325831da085a14fb /multimedia/vlc-devel/Makefile
parentf1faac256accbf32ed3f5af1492bed649c92e3d8 (diff)
downloadports-a894ef19696df1a711b6ce833769684712834a5f.tar.gz
ports-a894ef19696df1a711b6ce833769684712834a5f.zip
Notes
Diffstat (limited to 'multimedia/vlc-devel/Makefile')
-rw-r--r--multimedia/vlc-devel/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/multimedia/vlc-devel/Makefile b/multimedia/vlc-devel/Makefile
index 3225826230b9..d2dbc7c39681 100644
--- a/multimedia/vlc-devel/Makefile
+++ b/multimedia/vlc-devel/Makefile
@@ -166,6 +166,7 @@
PORTNAME= vlc
PORTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/vlc/${PORTVERSION}/ \
http://download.videolan.org/pub/videolan/vlc/${PORTVERSION}/contrib/:ffmpeg \
@@ -476,7 +477,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libmatroska.a:${PORTSDIR}/multimedia/libmatrosk
.if !defined(WITHOUT_LIBA52)
LIB_DEPENDS+= a52.0:${PORTSDIR}/audio/liba52
CONFIGURE_ARGS+=--enable-a52 \
- --with-a52=${LOCALBASE}
+ --with-a52-tree=${LOCALBASE}
.else
CONFIGURE_ARGS+=--diable-a52
.endif
@@ -639,6 +640,10 @@ post-patch:
s|$$(libdir)/mozilla/components|${FAKEDIR}/mozilla|' \
${WRKSRC}/mozilla/Makefile.in
.endif
+# a52
+ @${REINPLACE_CMD} -e 's|include/a52.h|include/a52dec/a52.h|' \
+ ${WRKSRC}/modules/audio_filter/converter/a52tofloat32.c \
+ ${WRKSRC}/configure
# skins2 interface
@${REINPLACE_CMD} -e 's|lrint|rint|' \
${WRKSRC}/modules/gui/skins2/controls/ctrl_list.cpp