aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vlc-devel
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-10-31 06:24:31 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-10-31 06:24:31 +0000
commitf8af6811d0259a75833197f06e87ab86005689ec (patch)
tree2db2f2a0f353284182be953cb059efa104c93d7e /multimedia/vlc-devel
parent3371eb509783a9320d0c576496cb2b4a1f796079 (diff)
downloadports-f8af6811d0259a75833197f06e87ab86005689ec.tar.gz
ports-f8af6811d0259a75833197f06e87ab86005689ec.zip
Notes
Diffstat (limited to 'multimedia/vlc-devel')
-rw-r--r--multimedia/vlc-devel/Makefile6
-rw-r--r--multimedia/vlc-devel/files/patch-configure720
2 files changed, 725 insertions, 1 deletions
diff --git a/multimedia/vlc-devel/Makefile b/multimedia/vlc-devel/Makefile
index 8b4923d0957f..a6143f7ee175 100644
--- a/multimedia/vlc-devel/Makefile
+++ b/multimedia/vlc-devel/Makefile
@@ -218,7 +218,7 @@
PORTNAME= vlc
DISTVERSION= 0.8.4.20051027
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/vlc/snapshots/
# http://download2.videolan.org/pub/videolan/testing/${PORTNAME}-${DISTVERSION}/ \
@@ -405,6 +405,10 @@ DEFAULT_DVD_DEVICE=/dev/acd0
.endif
.endif
+.if ${HAVE_GNOME:Mgnomevfs2}
+USE_GNOME+= gnomevfs2
+.endif
+
.if defined(WITH_CDROM_DEVICE)
DEFAULT_CDROM_DEVICE=${WITH_CDROM_DEVICE}
.else
diff --git a/multimedia/vlc-devel/files/patch-configure b/multimedia/vlc-devel/files/patch-configure
new file mode 100644
index 000000000000..15573ec1bab6
--- /dev/null
+++ b/multimedia/vlc-devel/files/patch-configure
@@ -0,0 +1,720 @@
+--- configure 2005-10-28 17:50:35.000000000 +0200
++++ configure.good 2005-10-28 14:30:39.000000000 +0200
+@@ -25435,7 +25435,716 @@
+ fi
+ fi;
+
+- :
++
++ if test "${with_ffmpeg_tree}" = "no" -o -z "${with_ffmpeg_tree}"; then
++ CPPFLAGS="${CPPFLAGS_save} ${CPPFLAGS_ffmpeg}"
++ LDFLAGS="${LDFLAGS_save} ${LDFLAGS_ffmpeg}"
++
++for ac_header in ffmpeg/avcodec.h
++do
++as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
++if eval "test \"\${$as_ac_Header+set}\" = set"; then
++ echo "$as_me:$LINENO: checking for $ac_header" >&5
++echo $ECHO_N "checking for $ac_header... $ECHO_C" >&6
++if eval "test \"\${$as_ac_Header+set}\" = set"; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++fi
++echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Header'}'`" >&5
++echo "${ECHO_T}`eval echo '${'$as_ac_Header'}'`" >&6
++else
++ # Is the header compilable?
++echo "$as_me:$LINENO: checking $ac_header usability" >&5
++echo $ECHO_N "checking $ac_header usability... $ECHO_C" >&6
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++$ac_includes_default
++#include <$ac_header>
++_ACEOF
++rm -f conftest.$ac_objext
++if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
++ (eval $ac_compile) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest.$ac_objext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_header_compiler=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_header_compiler=no
++fi
++rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
++echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
++echo "${ECHO_T}$ac_header_compiler" >&6
++
++# Is the header present?
++echo "$as_me:$LINENO: checking $ac_header presence" >&5
++echo $ECHO_N "checking $ac_header presence... $ECHO_C" >&6
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++#include <$ac_header>
++_ACEOF
++if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
++ (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } >/dev/null; then
++ if test -s conftest.err; then
++ ac_cpp_err=$ac_c_preproc_warn_flag
++ ac_cpp_err=$ac_cpp_err$ac_c_werror_flag
++ else
++ ac_cpp_err=
++ fi
++else
++ ac_cpp_err=yes
++fi
++if test -z "$ac_cpp_err"; then
++ ac_header_preproc=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ ac_header_preproc=no
++fi
++rm -f conftest.err conftest.$ac_ext
++echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
++echo "${ECHO_T}$ac_header_preproc" >&6
++
++# So? What about this header?
++case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
++ yes:no: )
++ { echo "$as_me:$LINENO: WARNING: $ac_header: accepted by the compiler, rejected by the preprocessor!" >&5
++echo "$as_me: WARNING: $ac_header: accepted by the compiler, rejected by the preprocessor!" >&2;}
++ { echo "$as_me:$LINENO: WARNING: $ac_header: proceeding with the compiler's result" >&5
++echo "$as_me: WARNING: $ac_header: proceeding with the compiler's result" >&2;}
++ ac_header_preproc=yes
++ ;;
++ no:yes:* )
++ { echo "$as_me:$LINENO: WARNING: $ac_header: present but cannot be compiled" >&5
++echo "$as_me: WARNING: $ac_header: present but cannot be compiled" >&2;}
++ { echo "$as_me:$LINENO: WARNING: $ac_header: check for missing prerequisite headers?" >&5
++echo "$as_me: WARNING: $ac_header: check for missing prerequisite headers?" >&2;}
++ { echo "$as_me:$LINENO: WARNING: $ac_header: see the Autoconf documentation" >&5
++echo "$as_me: WARNING: $ac_header: see the Autoconf documentation" >&2;}
++ { echo "$as_me:$LINENO: WARNING: $ac_header: section \"Present But Cannot Be Compiled\"" >&5
++echo "$as_me: WARNING: $ac_header: section \"Present But Cannot Be Compiled\"" >&2;}
++ { echo "$as_me:$LINENO: WARNING: $ac_header: proceeding with the preprocessor's result" >&5
++echo "$as_me: WARNING: $ac_header: proceeding with the preprocessor's result" >&2;}
++ { echo "$as_me:$LINENO: WARNING: $ac_header: in the future, the compiler will take precedence" >&5
++echo "$as_me: WARNING: $ac_header: in the future, the compiler will take precedence" >&2;}
++ (
++ cat <<\_ASBOX
++## ------------------------------ ##
++## Report this to the vlc lists. ##
++## ------------------------------ ##
++_ASBOX
++ ) |
++ sed "s/^/$as_me: WARNING: /" >&2
++ ;;
++esac
++echo "$as_me:$LINENO: checking for $ac_header" >&5
++echo $ECHO_N "checking for $ac_header... $ECHO_C" >&6
++if eval "test \"\${$as_ac_Header+set}\" = set"; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ eval "$as_ac_Header=\$ac_header_preproc"
++fi
++echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Header'}'`" >&5
++echo "${ECHO_T}`eval echo '${'$as_ac_Header'}'`" >&6
++
++fi
++if test `eval echo '${'$as_ac_Header'}'` = yes; then
++ cat >>confdefs.h <<_ACEOF
++#define `echo "HAVE_$ac_header" | $as_tr_cpp` 1
++_ACEOF
++
++else
++ { { echo "$as_me:$LINENO: error: Missing header file ffmpeg/avcodec.h." >&5
++echo "$as_me: error: Missing header file ffmpeg/avcodec.h." >&2;}
++ { (exit 1); exit 1; }; }
++fi
++
++done
++
++
++for ac_header in postproc/postprocess.h
++do
++as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
++if eval "test \"\${$as_ac_Header+set}\" = set"; then
++ echo "$as_me:$LINENO: checking for $ac_header" >&5
++echo $ECHO_N "checking for $ac_header... $ECHO_C" >&6
++if eval "test \"\${$as_ac_Header+set}\" = set"; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++fi
++echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Header'}'`" >&5
++echo "${ECHO_T}`eval echo '${'$as_ac_Header'}'`" >&6
++else
++ # Is the header compilable?
++echo "$as_me:$LINENO: checking $ac_header usability" >&5
++echo $ECHO_N "checking $ac_header usability... $ECHO_C" >&6
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++$ac_includes_default
++#include <$ac_header>
++_ACEOF
++rm -f conftest.$ac_objext
++if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
++ (eval $ac_compile) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest.$ac_objext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_header_compiler=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_header_compiler=no
++fi
++rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
++echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
++echo "${ECHO_T}$ac_header_compiler" >&6
++
++# Is the header present?
++echo "$as_me:$LINENO: checking $ac_header presence" >&5
++echo $ECHO_N "checking $ac_header presence... $ECHO_C" >&6
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++#include <$ac_header>
++_ACEOF
++if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
++ (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } >/dev/null; then
++ if test -s conftest.err; then
++ ac_cpp_err=$ac_c_preproc_warn_flag
++ ac_cpp_err=$ac_cpp_err$ac_c_werror_flag
++ else
++ ac_cpp_err=
++ fi
++else
++ ac_cpp_err=yes
++fi
++if test -z "$ac_cpp_err"; then
++ ac_header_preproc=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ ac_header_preproc=no
++fi
++rm -f conftest.err conftest.$ac_ext
++echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
++echo "${ECHO_T}$ac_header_preproc" >&6
++
++# So? What about this header?
++case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
++ yes:no: )
++ { echo "$as_me:$LINENO: WARNING: $ac_header: accepted by the compiler, rejected by the preprocessor!" >&5
++echo "$as_me: WARNING: $ac_header: accepted by the compiler, rejected by the preprocessor!" >&2;}
++ { echo "$as_me:$LINENO: WARNING: $ac_header: proceeding with the compiler's result" >&5
++echo "$as_me: WARNING: $ac_header: proceeding with the compiler's result" >&2;}
++ ac_header_preproc=yes
++ ;;
++ no:yes:* )
++ { echo "$as_me:$LINENO: WARNING: $ac_header: present but cannot be compiled" >&5
++echo "$as_me: WARNING: $ac_header: present but cannot be compiled" >&2;}
++ { echo "$as_me:$LINENO: WARNING: $ac_header: check for missing prerequisite headers?" >&5
++echo "$as_me: WARNING: $ac_header: check for missing prerequisite headers?" >&2;}
++ { echo "$as_me:$LINENO: WARNING: $ac_header: see the Autoconf documentation" >&5
++echo "$as_me: WARNING: $ac_header: see the Autoconf documentation" >&2;}
++ { echo "$as_me:$LINENO: WARNING: $ac_header: section \"Present But Cannot Be Compiled\"" >&5
++echo "$as_me: WARNING: $ac_header: section \"Present But Cannot Be Compiled\"" >&2;}
++ { echo "$as_me:$LINENO: WARNING: $ac_header: proceeding with the preprocessor's result" >&5
++echo "$as_me: WARNING: $ac_header: proceeding with the preprocessor's result" >&2;}
++ { echo "$as_me:$LINENO: WARNING: $ac_header: in the future, the compiler will take precedence" >&5
++echo "$as_me: WARNING: $ac_header: in the future, the compiler will take precedence" >&2;}
++ (
++ cat <<\_ASBOX
++## ------------------------------ ##
++## Report this to the vlc lists. ##
++## ------------------------------ ##
++_ASBOX
++ ) |
++ sed "s/^/$as_me: WARNING: /" >&2
++ ;;
++esac
++echo "$as_me:$LINENO: checking for $ac_header" >&5
++echo $ECHO_N "checking for $ac_header... $ECHO_C" >&6
++if eval "test \"\${$as_ac_Header+set}\" = set"; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ eval "$as_ac_Header=\$ac_header_preproc"
++fi
++echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Header'}'`" >&5
++echo "${ECHO_T}`eval echo '${'$as_ac_Header'}'`" >&6
++
++fi
++if test `eval echo '${'$as_ac_Header'}'` = yes; then
++ cat >>confdefs.h <<_ACEOF
++#define `echo "HAVE_$ac_header" | $as_tr_cpp` 1
++_ACEOF
++
++else
++ { { echo "$as_me:$LINENO: error: Missing header file postproc/postprocess.h." >&5
++echo "$as_me: error: Missing header file postproc/postprocess.h." >&2;}
++ { (exit 1); exit 1; }; }
++fi
++
++done
++
++
++ echo "$as_me:$LINENO: checking for av_add_i in -lavutil" >&5
++echo $ECHO_N "checking for av_add_i in -lavutil... $ECHO_C" >&6
++if test "${ac_cv_lib_avutil_av_add_i+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-lavutil $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char av_add_i ();
++int
++main ()
++{
++av_add_i ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_avutil_av_add_i=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_avutil_av_add_i=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_avutil_av_add_i" >&5
++echo "${ECHO_T}$ac_cv_lib_avutil_av_add_i" >&6
++if test $ac_cv_lib_avutil_av_add_i = yes; then
++
++
++ for element in ffmpeg; do
++ eval "LDFLAGS_${element}="'"'"-lavutil "'$'"{LDFLAGS_${element}} "'"'
++ am_modules_with_ldflags="${am_modules_with_ldflags} ${element}"
++ done
++
++ LDAVUTIL="-lavutil"
++fi
++
++
++ echo "$as_me:$LINENO: checking for avcodec_init in -lavcodec" >&5
++echo $ECHO_N "checking for avcodec_init in -lavcodec... $ECHO_C" >&6
++if test "${ac_cv_lib_avcodec_avcodec_init+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-lavcodec $LDAVUTIL $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char avcodec_init ();
++int
++main ()
++{
++avcodec_init ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_avcodec_avcodec_init=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_avcodec_avcodec_init=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_avcodec_avcodec_init" >&5
++echo "${ECHO_T}$ac_cv_lib_avcodec_avcodec_init" >&6
++if test $ac_cv_lib_avcodec_avcodec_init = yes; then
++
++
++ BUILTINS="${BUILTINS} ffmpeg"
++
++
++
++
++ for element in ffmpeg; do
++ eval "LDFLAGS_${element}="'"'"-lavcodec "'$'"{LDFLAGS_${element}} "'"'
++ am_modules_with_ldflags="${am_modules_with_ldflags} ${element}"
++ done
++
++ if test "${enable_sout}" != "no"; then
++
++ BUILTINS="${BUILTINS} stream_out_switcher"
++
++ fi
++else
++ { { echo "$as_me:$LINENO: error: Could not find ffmpeg on your system: you may get it from http://ffmpeg.sf.net/ (cvs version is recommended). Alternatively you can use --disable-ffmpeg to disable the ffmpeg plugins." >&5
++echo "$as_me: error: Could not find ffmpeg on your system: you may get it from http://ffmpeg.sf.net/ (cvs version is recommended). Alternatively you can use --disable-ffmpeg to disable the ffmpeg plugins." >&2;}
++ { (exit 1); exit 1; }; }
++fi
++
++ echo "$as_me:$LINENO: checking for av_open_input_stream in -lavformat" >&5
++echo $ECHO_N "checking for av_open_input_stream in -lavformat... $ECHO_C" >&6
++if test "${ac_cv_lib_avformat_av_open_input_stream+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-lavformat -lavcodec -lz $LDAVUTIL $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char av_open_input_stream ();
++int
++main ()
++{
++av_open_input_stream ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_avformat_av_open_input_stream=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_avformat_av_open_input_stream=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_avformat_av_open_input_stream" >&5
++echo "${ECHO_T}$ac_cv_lib_avformat_av_open_input_stream" >&6
++if test $ac_cv_lib_avformat_av_open_input_stream = yes; then
++
++
++cat >>confdefs.h <<\_ACEOF
++#define HAVE_LIBAVFORMAT 1
++_ACEOF
++
++
++ for element in ffmpeg; do
++ eval "LDFLAGS_${element}="'"'"-lavformat -lz "'$'"{LDFLAGS_${element}} "'"'
++ am_modules_with_ldflags="${am_modules_with_ldflags} ${element}"
++ done
++
++fi
++
++ LDFLAGS="${LDFLAGS_save}"
++ CPPFLAGS="${CPPFLAGS_save}"
++ fi
++
++ if test "${with_ffmpeg_tree}" != "no" -a -n "${with_ffmpeg_tree}"; then
++ echo "$as_me:$LINENO: checking for libavcodec.a in ${with_ffmpeg_tree}" >&5
++echo $ECHO_N "checking for libavcodec.a in ${with_ffmpeg_tree}... $ECHO_C" >&6
++ real_ffmpeg_tree="`cd ${with_ffmpeg_tree} 2>/dev/null && pwd`"
++ if test -z "${real_ffmpeg_tree}"; then
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++ { { echo "$as_me:$LINENO: error: cannot cd to ${with_ffmpeg_tree}" >&5
++echo "$as_me: error: cannot cd to ${with_ffmpeg_tree}" >&2;}
++ { (exit 1); exit 1; }; }
++ fi
++ if ! test -f "${real_ffmpeg_tree}/libavcodec/libavcodec.a"; then
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++ { { echo "$as_me:$LINENO: error: cannot find ${real_ffmpeg_tree}/libavcodec/libavcodec.a, make sure you compiled libavcodec in ${with_ffmpeg_tree}" >&5
++echo "$as_me: error: cannot find ${real_ffmpeg_tree}/libavcodec/libavcodec.a, make sure you compiled libavcodec in ${with_ffmpeg_tree}" >&2;}
++ { (exit 1); exit 1; }; }
++ fi
++ if ! fgrep -s "pp_get_context" "${real_ffmpeg_tree}/libavcodec/libavcodec.a"; then
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++ { { echo "$as_me:$LINENO: error: ${real_ffmpeg_tree}/libavcodec/libavcodec.a was not compiled with postprocessing support, make sure you configured ffmpeg with --enable-pp" >&5
++echo "$as_me: error: ${real_ffmpeg_tree}/libavcodec/libavcodec.a was not compiled with postprocessing support, make sure you configured ffmpeg with --enable-pp" >&2;}
++ { (exit 1); exit 1; }; }
++ fi
++ echo "$as_me:$LINENO: result: ${real_ffmpeg_tree}/libavcodec/libavcodec.a" >&5
++echo "${ECHO_T}${real_ffmpeg_tree}/libavcodec/libavcodec.a" >&6
++
++ if fgrep -s "CONFIG_ZLIB=yes" "${real_ffmpeg_tree}/config.mak"; then
++ if test "${with_ffmpeg_zlib}" != "yes"; then
++
++ for element in ffmpeg; do
++ eval "LDFLAGS_${element}="'"'"-lz "'$'"{LDFLAGS_${element}} "'"'
++ am_modules_with_ldflags="${am_modules_with_ldflags} ${element}"
++ done
++
++ fi
++ fi
++ if fgrep -s "CONFIG_MP3LAME=yes" "${real_ffmpeg_tree}/config.mak"; then
++ if test "${with_ffmpeg_mp3lame}" != "yes"; then
++
++ for element in ffmpeg; do
++ eval "LDFLAGS_${element}="'"'"-lmp3lame "'$'"{LDFLAGS_${element}} "'"'
++ am_modules_with_ldflags="${am_modules_with_ldflags} ${element}"
++ done
++
++ fi
++ fi
++ if fgrep -s "CONFIG_FAAC=yes" "${real_ffmpeg_tree}/config.mak"; then
++ if test "${with_ffmpeg_faac}" != "yes"; then
++
++ for element in ffmpeg; do
++ eval "LDFLAGS_${element}="'"'"-lfaac "'$'"{LDFLAGS_${element}} "'"'
++ am_modules_with_ldflags="${am_modules_with_ldflags} ${element}"
++ done
++
++ fi
++ fi
++ if fgrep -s "CONFIG_DTS=yes" "${real_ffmpeg_tree}/config.mak"; then
++ if test "${with_ffmpeg_dts}" != "yes"; then
++
++ for element in ffmpeg; do
++ eval "LDFLAGS_${element}="'"'"-ldts "'$'"{LDFLAGS_${element}} "'"'
++ am_modules_with_ldflags="${am_modules_with_ldflags} ${element}"
++ done
++
++ fi
++ fi
++ if fgrep -s "CONFIG_VORBIS=yes" "${real_ffmpeg_tree}/config.mak"; then
++
++ for element in ffmpeg; do
++ eval "LDFLAGS_${element}="'"'"-lvorbis -lvorbisenc "'$'"{LDFLAGS_${element}} "'"'
++ am_modules_with_ldflags="${am_modules_with_ldflags} ${element}"
++ done
++
++ fi
++ if fgrep -s "CONFIG_FAAD=yes" "${real_ffmpeg_tree}/config.mak"; then
++
++ for element in ffmpeg; do
++ eval "LDFLAGS_${element}="'"'"-lfaad "'$'"{LDFLAGS_${element}} "'"'
++ am_modules_with_ldflags="${am_modules_with_ldflags} ${element}"
++ done
++
++ fi
++ if fgrep -s "CONFIG_XVID=yes" "${real_ffmpeg_tree}/config.mak"; then
++
++ for element in ffmpeg; do
++ eval "LDFLAGS_${element}="'"'"-lxvidcore "'$'"{LDFLAGS_${element}} "'"'
++ am_modules_with_ldflags="${am_modules_with_ldflags} ${element}"
++ done
++
++ fi
++
++
++ BUILTINS="${BUILTINS} ffmpeg"
++
++ if test "${enable_sout}" != "no"; then
++
++ BUILTINS="${BUILTINS} stream_out_switcher"
++
++ fi
++
++ if test -f "${real_ffmpeg_tree}/libavutil/libavutil.a"; then
++
++ for element in ffmpeg; do
++ eval "LDFLAGS_${element}="'"'"-L${real_ffmpeg_tree}/libavutil ${real_ffmpeg_tree}/libavutil/libavutil.a "'$'"{LDFLAGS_${element}} "'"'
++ am_modules_with_ldflags="${am_modules_with_ldflags} ${element}"
++ done
++
++
++ for element in ffmpeg stream_out_switcher; do
++ eval "CPPFLAGS_${element}="'"$'"{CPPFLAGS_${element}} -I${real_ffmpeg_tree}/libavutil"'"'
++ am_modules_with_cppflags="${am_modules_with_cppflags} ${element}"
++ done
++
++ fi
++
++
++ for element in ffmpeg; do
++ eval "LDFLAGS_${element}="'"'"-L${real_ffmpeg_tree}/libavcodec ${real_ffmpeg_tree}/libavcodec/libavcodec.a "'$'"{LDFLAGS_${element}} "'"'
++ am_modules_with_ldflags="${am_modules_with_ldflags} ${element}"
++ done
++
++
++ for element in ffmpeg stream_out_switcher; do
++ eval "CPPFLAGS_${element}="'"$'"{CPPFLAGS_${element}} -I${real_ffmpeg_tree}/libavcodec"'"'
++ am_modules_with_cppflags="${am_modules_with_cppflags} ${element}"
++ done
++
++
++ if test -f "${real_ffmpeg_tree}/libavformat/libavformat.a"; then
++
++cat >>confdefs.h <<\_ACEOF
++#define HAVE_LIBAVFORMAT 1
++_ACEOF
++
++
++ for element in ffmpeg; do
++ eval "LDFLAGS_${element}="'"'"-L${real_ffmpeg_tree}/libavformat ${real_ffmpeg_tree}/libavformat/libavformat.a "'$'"{LDFLAGS_${element}} "'"'
++ am_modules_with_ldflags="${am_modules_with_ldflags} ${element}"
++ done
++
++
++ for element in ffmpeg stream_out_switcher; do
++ eval "CPPFLAGS_${element}="'"$'"{CPPFLAGS_${element}} -I${real_ffmpeg_tree}/libavformat"'"'
++ am_modules_with_cppflags="${am_modules_with_cppflags} ${element}"
++ done
++
++ fi
++ fi
+
+ # Check whether --with-ffmpeg-tree or --without-ffmpeg-tree was given.
+ if test "${with_ffmpeg_tree+set}" = set; then