aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vlc/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /multimedia/vlc/Makefile
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'multimedia/vlc/Makefile')
-rw-r--r--multimedia/vlc/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 0b101d37db6c..494374ceec94 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -237,13 +237,15 @@ PNG_CONFIGURE_ENABLE= png
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CONFIGURE_ENABLE= pulse
-QT4_USE= QT4=gui,corelib,moc_build,rcc_build,uic_build
+QT4_USES= qt:4
+QT4_USE= QT=gui,corelib,moc_build,rcc_build,uic_build
# QT_CFLAGS: pkg-config --cflags "QtCore QtGui >= 4.6.0"
# QT_LIBS: pkg-config --libs "QtCore QtGui >= 4.6.0"
QT4_CONFIGURE_ENV= QT_CFLAGS="-I${QT_INCDIR}/QtGui -DQT_SHARED -I${QT_INCDIR} -I${QT_INCDIR}/QtCore" \
QT_LIBS="-lQtGui -L${QT_LIBDIR} -lQtCore"
-QT5_USE= QT5=gui,core,widgets,x11extras,buildtools_build
+QT5_USES= qt:5
+QT5_USE= QT=gui,core,widgets,x11extras,buildtools_build
REALRTSP_CONFIGURE_ENABLE= realrtsp