aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vlc/Makefile
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-09-14 09:56:09 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-09-14 09:56:09 +0000
commit63dcec2a01d0319828b5db86dc1cbbc758b763a9 (patch)
tree86e488992e6b796ecbecf51fd402ec8b54489390 /multimedia/vlc/Makefile
parent3c8a99c287abc89dea98e3896af3b478dd4ca576 (diff)
downloadports-63dcec2a01d0319828b5db86dc1cbbc758b763a9.tar.gz
ports-63dcec2a01d0319828b5db86dc1cbbc758b763a9.zip
Notes
Diffstat (limited to 'multimedia/vlc/Makefile')
-rw-r--r--multimedia/vlc/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index d74054294aa6..bb51d385061a 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -31,10 +31,18 @@ LIB_DEPENDS= dvdcss.2:${PORTSDIR}/multimedia/libdvdcss \
# After libmpeg2 release 0.3.2
# mpeg2.0:${PORTSDIR}/multimedia/libmpeg2 \
+USE_GETOPT_LONG=yes
+USE_GMAKE= yes
+USE_GNOME= gtk12
+USE_REINPLACE= yes
+USE_SDL= yes
USE_XLIB= yes
-GNU_CONFIGURE= yes
+
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= PATH_GTKCONFIG="${GTK_CONFIG}"
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= PATH_GTKCONFIG="${GTK_CONFIG}" \
+ CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_ARGS+=--with-dvdcss=${LOCALBASE} \
--with-dvdread=${LOCALBASE} \
--with-mad=${LOCALBASE} \
@@ -44,14 +52,11 @@ CONFIGURE_ARGS+=--with-dvdcss=${LOCALBASE} \
--enable-ffmpeg \
--with-ffmpeg=${LOCALBASE} \
--disable-libmpeg2 \
+ --program-prefix="" \
--without-libintl-prefix \
--without-libiconv-prefix
-# dirty
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-USE_GNOME= gtk12
-USE_GMAKE= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's/-lc_r/${PTHREAD_LIBS}/' ${WRKSRC}/configure
.include <bsd.port.mk>