aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vlc/files
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2010-07-11 02:06:56 +0000
committerWesley Shields <wxs@FreeBSD.org>2010-07-11 02:06:56 +0000
commitf528d378df7ba0217fb1f7b9b4cf457c80e6c8a2 (patch)
tree1090a8e15e8a177f13278c284c02b0347cd61877 /multimedia/vlc/files
parent04709ba6bb3485f6a93a26b1fe0e12d423898887 (diff)
downloadports-f528d378df7ba0217fb1f7b9b4cf457c80e6c8a2.tar.gz
ports-f528d378df7ba0217fb1f7b9b4cf457c80e6c8a2.zip
Notes
Diffstat (limited to 'multimedia/vlc/files')
-rw-r--r--multimedia/vlc/files/extra-patch-modules__access__v4l2.c (renamed from multimedia/vlc/files/extra-patch-modules_access_v4l2.c)0
-rw-r--r--multimedia/vlc/files/extra-patch-modules__misc__inhibit__xdg.c31
-rw-r--r--multimedia/vlc/files/extra-patch-modules__misc__inhibit__xscreensaver.c25
-rw-r--r--multimedia/vlc/files/extra-patch-src_misc_thread.c11
-rw-r--r--multimedia/vlc/files/patch-configure-dvbpsi20
-rw-r--r--multimedia/vlc/files/patch-modules__Makefile.am30
-rw-r--r--multimedia/vlc/files/patch-modules__Makefile.in33
-rw-r--r--multimedia/vlc/files/patch-modules__access__file.c11
-rw-r--r--multimedia/vlc/files/patch-modules__access__v4l.c (renamed from multimedia/vlc/files/patch-v4l)0
-rw-r--r--multimedia/vlc/files/patch-modules__gui__qt4__util__customwidgets.cpp11
-rw-r--r--multimedia/vlc/files/patch-modules_access_pvr.c12
-rw-r--r--multimedia/vlc/files/patch-modules_codec_png.c20
12 files changed, 141 insertions, 63 deletions
diff --git a/multimedia/vlc/files/extra-patch-modules_access_v4l2.c b/multimedia/vlc/files/extra-patch-modules__access__v4l2.c
index 02ac708d65d2..02ac708d65d2 100644
--- a/multimedia/vlc/files/extra-patch-modules_access_v4l2.c
+++ b/multimedia/vlc/files/extra-patch-modules__access__v4l2.c
diff --git a/multimedia/vlc/files/extra-patch-modules__misc__inhibit__xdg.c b/multimedia/vlc/files/extra-patch-modules__misc__inhibit__xdg.c
new file mode 100644
index 000000000000..e0435a756f2d
--- /dev/null
+++ b/multimedia/vlc/files/extra-patch-modules__misc__inhibit__xdg.c
@@ -0,0 +1,31 @@
+--- ./modules/misc/inhibit/xdg.c.orig 2010-07-10 19:56:31.000000000 -0400
++++ ./modules/misc/inhibit/xdg.c 2010-07-10 20:07:33.000000000 -0400
+@@ -25,7 +25,6 @@
+ #include <vlc_common.h>
+ #include <vlc_plugin.h>
+ #include <vlc_inhibit.h>
+-#include <spawn.h>
+ #include <sys/wait.h>
+
+ static int Open (vlc_object_t *);
+@@ -123,19 +122,9 @@
+ id,
+ NULL,
+ };
+- pid_t pid;
+ int canc = vlc_savecancel ();
+
+- if (!posix_spawnp (&pid, "xdg-screensaver", NULL, NULL, argv, environ))
+- {
+- int status;
+-
+- msg_Dbg (ih, "started xdg-screensaver (PID = %d)", (int)pid);
+- /* Wait for command to complete */
+- while (waitpid (pid, &status, 0) == -1);
+- }
+- else/* We don't handle the error, but busy looping would be worse :( */
+- msg_Warn (ih, "could not start xdg-screensaver");
++ msg_Warn (ih, "could not start xdg-screensaver");
+ suspended = !suspended;
+ vlc_restorecancel (canc);
+ }
diff --git a/multimedia/vlc/files/extra-patch-modules__misc__inhibit__xscreensaver.c b/multimedia/vlc/files/extra-patch-modules__misc__inhibit__xscreensaver.c
new file mode 100644
index 000000000000..02e34095006f
--- /dev/null
+++ b/multimedia/vlc/files/extra-patch-modules__misc__inhibit__xscreensaver.c
@@ -0,0 +1,25 @@
+--- ./modules/misc/inhibit/xscreensaver.c.orig 2010-07-10 19:56:49.000000000 -0400
++++ ./modules/misc/inhibit/xscreensaver.c 2010-07-10 20:05:33.000000000 -0400
+@@ -39,7 +39,6 @@
+ #include <sys/wait.h>
+ #include <fcntl.h>
+ #include <signal.h>
+-#include <spawn.h>
+
+ /*****************************************************************************
+ * Local prototypes
+@@ -133,14 +132,6 @@
+ *****************************************************************************/
+ static void Execute (vlc_inhibit_t *p_ih, const char *const *argv)
+ {
+- vlc_inhibit_sys_t *p_sys = p_ih->p_sys;
+- pid_t pid;
+-
+- if (posix_spawnp (&pid, argv[0], &p_sys->actions, &p_sys->attr,
+- (char **)argv, environ) == 0)
+- {
+- while (waitpid (pid, NULL, 0) != pid);
+- }
+ }
+
+ /*****************************************************************************
diff --git a/multimedia/vlc/files/extra-patch-src_misc_thread.c b/multimedia/vlc/files/extra-patch-src_misc_thread.c
deleted file mode 100644
index 9647b82f1878..000000000000
--- a/multimedia/vlc/files/extra-patch-src_misc_thread.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/misc/threads.c.orig 2009-08-01 09:34:56.000000000 -0400
-+++ src/misc/threads.c 2009-08-01 09:40:24.000000000 -0400
-@@ -784,7 +784,7 @@
- pthread_sigmask (SIG_BLOCK, &set, &oldset);
- }
-
--#if defined (_POSIX_PRIORITY_SCHEDULING) && (_POSIX_PRIORITY_SCHEDULING >= 0) \
-+#if 0 && defined (_POSIX_PRIORITY_SCHEDULING) && (_POSIX_PRIORITY_SCHEDULING >= 0) \
- && defined (_POSIX_THREAD_PRIORITY_SCHEDULING) \
- && (_POSIX_THREAD_PRIORITY_SCHEDULING >= 0)
- {
diff --git a/multimedia/vlc/files/patch-configure-dvbpsi b/multimedia/vlc/files/patch-configure-dvbpsi
deleted file mode 100644
index 0e84164c00e6..000000000000
--- a/multimedia/vlc/files/patch-configure-dvbpsi
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.orig 2009-09-23 23:31:31.000000000 +0100
-+++ configure 2009-09-23 23:30:51.000000000 +0100
-@@ -29130,7 +29130,16 @@
- CPPFLAGS="${CPPFLAGS_save} ${CPPFLAGS_test}"
- for ac_header in dvbpsi/dr.h
- do :
-- ac_fn_c_check_header_mongrel "$LINENO" "dvbpsi/dr.h" "ac_cv_header_dvbpsi_dr_h" "$ac_includes_default"
-+ ac_fn_c_check_header_compile "$LINENO" "dvbpsi/dr.h" "ac_cv_header_dvbpsi_dr_h" "#if defined( HAVE_STDINT_H )
-+# include <stdint.h>
-+#elif defined( HAVE_INTTYPES_H )
-+# include <inttypes.h>
-+#endif
-+#include <dvbpsi/dvbpsi.h>
-+#include <dvbpsi/descriptor.h>
-+#include <dvbpsi/pat.h>
-+#include <dvbpsi/pmt.h>
-+"
- if test "x$ac_cv_header_dvbpsi_dr_h" = x""yes; then :
- cat >>confdefs.h <<_ACEOF
- #define HAVE_DVBPSI_DR_H 1
diff --git a/multimedia/vlc/files/patch-modules__Makefile.am b/multimedia/vlc/files/patch-modules__Makefile.am
new file mode 100644
index 000000000000..2da5f4d70dce
--- /dev/null
+++ b/multimedia/vlc/files/patch-modules__Makefile.am
@@ -0,0 +1,30 @@
+--- ./modules/Makefile.am.orig 2010-06-24 05:07:31.000000000 -0400
++++ ./modules/Makefile.am 2010-06-24 05:09:12.000000000 -0400
+@@ -62,16 +62,16 @@
+ .PHONY: stamp-cache
+
+ stamp-cache:
+- $(AM_V_GEN)if test "$(build)" = "$(host)"; then \
+- ../bin/vlc-cache-gen$(EXEEXT) . ; \
+- else \
+- echo "Cross-compilation: cache generation skipped!" ; \
+- fi
+- $(AM_V_at)touch stamp-cache
++# $(AM_V_GEN)if test "$(build)" = "$(host)"; then \
++# ../bin/vlc-cache-gen$(EXEEXT) . ; \
++# else \
++# echo "Cross-compilation: cache generation skipped!" ; \
++# fi
++# $(AM_V_at)touch stamp-cache
+
+ install-exec-hook:
+- if test -z "$(DESTDIR)"; then \
+- ../bin/vlc-cache-gen$(EXEEXT) "$(vlclibdir)/plugins" ; \
+- else \
+- echo "Staged installation: cache generation skipped!" ; \
+- fi
++# if test -z "$(DESTDIR)"; then \
++# ../bin/vlc-cache-gen$(EXEEXT) "$(vlclibdir)/plugins" ; \
++# else \
++# echo "Staged installation: cache generation skipped!" ; \
++# fi
diff --git a/multimedia/vlc/files/patch-modules__Makefile.in b/multimedia/vlc/files/patch-modules__Makefile.in
new file mode 100644
index 000000000000..5c2091b004d9
--- /dev/null
+++ b/multimedia/vlc/files/patch-modules__Makefile.in
@@ -0,0 +1,33 @@
+--- ./modules/Makefile.in.orig 2010-06-24 05:07:46.000000000 -0400
++++ ./modules/Makefile.in 2010-06-24 05:09:54.000000000 -0400
+@@ -1008,19 +1008,19 @@
+ .PHONY: stamp-cache
+
+ stamp-cache:
+- $(AM_V_GEN)if test "$(build)" = "$(host)"; then \
+- ../bin/vlc-cache-gen$(EXEEXT) . ; \
+- else \
+- echo "Cross-compilation: cache generation skipped!" ; \
+- fi
+- $(AM_V_at)touch stamp-cache
++# $(AM_V_GEN)if test "$(build)" = "$(host)"; then \
++# ../bin/vlc-cache-gen$(EXEEXT) . ; \
++# else \
++# echo "Cross-compilation: cache generation skipped!" ; \
++# fi
++# $(AM_V_at)touch stamp-cache
+
+ install-exec-hook:
+- if test -z "$(DESTDIR)"; then \
+- ../bin/vlc-cache-gen$(EXEEXT) "$(vlclibdir)/plugins" ; \
+- else \
+- echo "Staged installation: cache generation skipped!" ; \
+- fi
++# if test -z "$(DESTDIR)"; then \
++# ../bin/vlc-cache-gen$(EXEEXT) "$(vlclibdir)/plugins" ; \
++# else \
++# echo "Staged installation: cache generation skipped!" ; \
++# fi
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/multimedia/vlc/files/patch-modules__access__file.c b/multimedia/vlc/files/patch-modules__access__file.c
new file mode 100644
index 000000000000..16dd208965a3
--- /dev/null
+++ b/multimedia/vlc/files/patch-modules__access__file.c
@@ -0,0 +1,11 @@
+--- ./modules/access/file.c.orig 2010-06-22 02:05:28.000000000 -0400
++++ ./modules/access/file.c 2010-06-22 02:05:57.000000000 -0400
+@@ -96,7 +96,7 @@
+ if (fstatvfs (fd, &stf))
+ return false;
+ /* fstatvfs() is in POSIX, but MNT_LOCAL is not */
+- return !(s.f_flag & MNT_LOCAL);
++ return !(stf.f_flag & MNT_LOCAL);
+
+ #elif defined (HAVE_LINUX_MAGIC_H)
+ struct statfs stf;
diff --git a/multimedia/vlc/files/patch-v4l b/multimedia/vlc/files/patch-modules__access__v4l.c
index eb19e2f390ce..eb19e2f390ce 100644
--- a/multimedia/vlc/files/patch-v4l
+++ b/multimedia/vlc/files/patch-modules__access__v4l.c
diff --git a/multimedia/vlc/files/patch-modules__gui__qt4__util__customwidgets.cpp b/multimedia/vlc/files/patch-modules__gui__qt4__util__customwidgets.cpp
new file mode 100644
index 000000000000..7924a7f9a8fc
--- /dev/null
+++ b/multimedia/vlc/files/patch-modules__gui__qt4__util__customwidgets.cpp
@@ -0,0 +1,11 @@
+--- ./modules/gui/qt4/util/customwidgets.cpp.orig 2010-06-22 02:57:13.000000000 -0400
++++ ./modules/gui/qt4/util/customwidgets.cpp 2010-06-22 02:57:45.000000000 -0400
+@@ -380,7 +380,7 @@
+
+ if( qtk <= 0xff )
+ /* VLC and X11 use lowercase whereas Qt uses uppercase */
+-#if defined( __STDC_ISO_10646__ ) || defined( _WIN32 )
++#if defined( __STDC_ISO_10646__ ) || defined( _WIN32 ) || defined(__FreeBSD__)
+ i_vlck = towlower( qtk );
+ #else
+ # error FIXME
diff --git a/multimedia/vlc/files/patch-modules_access_pvr.c b/multimedia/vlc/files/patch-modules_access_pvr.c
deleted file mode 100644
index de303ad8d7f6..000000000000
--- a/multimedia/vlc/files/patch-modules_access_pvr.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- modules/access/pvr.c.orig 2010-03-23 17:37:48.000000000 +0100
-+++ modules/access/pvr.c 2010-03-23 17:38:04.000000000 +0100
-@@ -38,7 +38,9 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <errno.h>
-+#ifdef __linux__
- #include <linux/types.h>
-+#endif
- #include <sys/ioctl.h>
- #include <sys/poll.h>
- #ifdef HAVE_NEW_LINUX_VIDEODEV2_H
diff --git a/multimedia/vlc/files/patch-modules_codec_png.c b/multimedia/vlc/files/patch-modules_codec_png.c
deleted file mode 100644
index 81ceeac2ea0d..000000000000
--- a/multimedia/vlc/files/patch-modules_codec_png.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- modules/codec/png.c.orig 2009-12-20 18:43:39.000000000 +0100
-+++ modules/codec/png.c 2010-03-28 17:09:18.000000000 +0200
-@@ -155,7 +155,7 @@
- p_info = png_create_info_struct( p_png );
- if( p_info == NULL )
- {
-- png_destroy_read_struct( &p_png, png_infopp_NULL, png_infopp_NULL );
-+ png_destroy_read_struct( &p_png, NULL, NULL );
- block_Release( p_block ); *pp_block = NULL;
- return NULL;
- }
-@@ -163,7 +163,7 @@
- p_end_info = png_create_info_struct( p_png );
- if( p_end_info == NULL )
- {
-- png_destroy_read_struct( &p_png, &p_info, png_infopp_NULL );
-+ png_destroy_read_struct( &p_png, &p_info, NULL );
- block_Release( p_block ); *pp_block = NULL;
- return NULL;
- }