aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vodcatcher
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-09-05 03:51:59 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-09-05 03:51:59 +0000
commit6e80b5f22c0c2eca990bf967113d7cd119c8eaf7 (patch)
treed28f9e03d74abb2ecca13951b0b7f7e6aee65376 /multimedia/vodcatcher
parentc022284af4a5729629c438d8ca094638683b3ef9 (diff)
downloadports-6e80b5f22c0c2eca990bf967113d7cd119c8eaf7.tar.gz
ports-6e80b5f22c0c2eca990bf967113d7cd119c8eaf7.zip
Notes
Diffstat (limited to 'multimedia/vodcatcher')
-rw-r--r--multimedia/vodcatcher/Makefile27
-rw-r--r--multimedia/vodcatcher/distinfo3
-rw-r--r--multimedia/vodcatcher/pkg-descr10
3 files changed, 40 insertions, 0 deletions
diff --git a/multimedia/vodcatcher/Makefile b/multimedia/vodcatcher/Makefile
new file mode 100644
index 000000000000..2ea19ae6faa8
--- /dev/null
+++ b/multimedia/vodcatcher/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: vodcatcher
+# Date created: Sep 5, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= vodcatcher
+PORTVERSION= 1.3.3
+CATEGORIES= multimedia ruby
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= Video podcast client for the command line
+
+USE_RUBY= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+
+PLIST_FILES= bin/vodcatcher
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/multimedia/vodcatcher/distinfo b/multimedia/vodcatcher/distinfo
new file mode 100644
index 000000000000..018bbdd41700
--- /dev/null
+++ b/multimedia/vodcatcher/distinfo
@@ -0,0 +1,3 @@
+MD5 (vodcatcher-1.3.3.tar.gz) = 42f1123a224f097b3e390b19f3d04358
+SHA256 (vodcatcher-1.3.3.tar.gz) = 650d24b60b192a30036929b377cfd56c37400028fc7115675555d4e04b2ab5a9
+SIZE (vodcatcher-1.3.3.tar.gz) = 12406
diff --git a/multimedia/vodcatcher/pkg-descr b/multimedia/vodcatcher/pkg-descr
new file mode 100644
index 000000000000..e70719e8f68a
--- /dev/null
+++ b/multimedia/vodcatcher/pkg-descr
@@ -0,0 +1,10 @@
+Armangil's vodcatcher is a video podcast (or vodcast) client for the command
+line. It provides several download strategies (new shows only, back-catalog
+allowed, etc), supports BitTorrent, offers cache management, and generates
+playlists for video player applications.
+
+This application accepts one or more feeds (RSS or Atom) or subscription lists
+(OPML or iTunes PCAST) as argument, in the form of URLs or filenames.
+Alternatively, it tries to read one such document from the standard input.
+
+WWW: http://vodcatcher.rubyforge.org/