aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vstream-client
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-07 13:14:37 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-07 13:14:37 +0000
commit35ba0d49de3675dcfea693f0b8b74bccb58ebcec (patch)
tree09bb8a1367e866dcd2bfba79de73205964da5a28 /multimedia/vstream-client
parent859c129c2b0280db3add961dfc8fa3b825e3979f (diff)
Notes
Diffstat (limited to 'multimedia/vstream-client')
-rw-r--r--multimedia/vstream-client/Makefile18
-rw-r--r--multimedia/vstream-client/distinfo2
-rw-r--r--multimedia/vstream-client/files/patch-test-client.c11
-rw-r--r--multimedia/vstream-client/pkg-descr11
-rw-r--r--multimedia/vstream-client/pkg-plist3
5 files changed, 45 insertions, 0 deletions
diff --git a/multimedia/vstream-client/Makefile b/multimedia/vstream-client/Makefile
new file mode 100644
index 000000000000..9877ae5e0630
--- /dev/null
+++ b/multimedia/vstream-client/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: vstream-client
+# Date created: 2005-10-06
+# Whom: Frank Mayhar <frank@exit.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vstream-client
+PORTVERSION= 1.2
+CATEGORIES= multimedia
+MASTER_SITES= http://mirror-jtan.nicewarrior.org/${PORTNAME}/
+
+MAINTAINER= frank@exit.com
+COMMENT= The vstream library from the tivo-mplayer project
+
+HAS_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/multimedia/vstream-client/distinfo b/multimedia/vstream-client/distinfo
new file mode 100644
index 000000000000..e01f762ffebc
--- /dev/null
+++ b/multimedia/vstream-client/distinfo
@@ -0,0 +1,2 @@
+MD5 (vstream-client-1.2.tar.gz) = 91088dad9234dd1176ddb84e6fbee69c
+SIZE (vstream-client-1.2.tar.gz) = 33772
diff --git a/multimedia/vstream-client/files/patch-test-client.c b/multimedia/vstream-client/files/patch-test-client.c
new file mode 100644
index 000000000000..781652d17bac
--- /dev/null
+++ b/multimedia/vstream-client/files/patch-test-client.c
@@ -0,0 +1,11 @@
+--- test-client.c Thu Apr 28 12:28:25 2005
++++ /home/frank/tivo/vstream-client-1.2/test-client.c Thu Oct 6 21:47:52 2005
+@@ -6,7 +6,7 @@
+ #define CHUNK ( 1024 * 1024 )
+
+ // on cygwin, we have large file support already, and no fopen64.
+-#ifdef __CYGWIN__
++#if defined(__CYGWIN__) || defined(__FreeBSD__)
+ #define fopen64 fopen
+ #endif
+
diff --git a/multimedia/vstream-client/pkg-descr b/multimedia/vstream-client/pkg-descr
new file mode 100644
index 000000000000..6011ad26a77c
--- /dev/null
+++ b/multimedia/vstream-client/pkg-descr
@@ -0,0 +1,11 @@
+This is a fork off of the vstream library from the tivo-mplayer project.
+It has been stripped down to just the client code, and includes an example
+client application. If you have vserver installed on your Tivo (which most
+tivo hackers do), then you can use this simple client to stream .ty files
+from it. MPlayer will also include support for this library soon. This
+library can also be used by MPlayer/MEncoder to watch/re-encode tivo
+streams live over a network.
+
+(As of October 2005, mplayer does in fact have support for this library.)
+
+WWW: http://armory.nicewarrior.org/projects/vstream-client/
diff --git a/multimedia/vstream-client/pkg-plist b/multimedia/vstream-client/pkg-plist
new file mode 100644
index 000000000000..b96b0a8a6c6d
--- /dev/null
+++ b/multimedia/vstream-client/pkg-plist
@@ -0,0 +1,3 @@
+bin/vstream-client
+lib/libvstream-client.a
+include/vstream-client.h