aboutsummaryrefslogtreecommitdiff
path: root/multimedia/webcamd
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-12-12 22:52:07 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-12-12 22:52:07 +0000
commit7853cb3ecb868a3824c56c9e245185b6e59a7d55 (patch)
tree786f731b4e968883ab37452fd8116375a21dc53e /multimedia/webcamd
parentda45faad91b2e37f9862e0a589d783fd71c9c952 (diff)
downloadports-7853cb3ecb868a3824c56c9e245185b6e59a7d55.tar.gz
ports-7853cb3ecb868a3824c56c9e245185b6e59a7d55.zip
Notes
Diffstat (limited to 'multimedia/webcamd')
-rw-r--r--multimedia/webcamd/Makefile28
-rw-r--r--multimedia/webcamd/distinfo5
-rw-r--r--multimedia/webcamd/files/webcamd.in12
3 files changed, 34 insertions, 11 deletions
diff --git a/multimedia/webcamd/Makefile b/multimedia/webcamd/Makefile
index 57fa88e938a0..d542d9cc9ca6 100644
--- a/multimedia/webcamd/Makefile
+++ b/multimedia/webcamd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= webcamd
-PORTVERSION= 0.1.16
+PORTVERSION= 0.1.18
CATEGORIES= multimedia
MASTER_SITES= http://www.selasky.org/hans_petter/video4bsd/releases/
@@ -14,25 +14,39 @@ MAINTAINER= hselasky@FreeBSD.org
COMMENT= A port of Linux USB webcam and DVB drivers into userspace
BUILD_DEPENDS= v4l_compat>=1.0.20100321:${PORTSDIR}/multimedia/v4l_compat \
- cuse4bsd-kmod>=0.1.8:${PORTSDIR}/multimedia/cuse4bsd-kmod
+ cuse4bsd-kmod>=0.1.13:${PORTSDIR}/multimedia/cuse4bsd-kmod
+LIB_DEPENDS= v4l1.0:${PORTSDIR}/multimedia/libv4l \
+ cuse4bsd.1:${PORTSDIR}/multimedia/cuse4bsd-kmod
-LIB_DEPENDS= v4l1.0:${PORTSDIR}/multimedia/libv4l
+LICENSE= GPLv2
USE_RC_SUBR= webcamd
USE_BZIP2= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
+MANCOMPRESSED= yes
+MAN4= au0828.4 benq.4 bttv.4 conex.4 cpiax.4 cx23885.4 cx88.4 \
+ em28xx.4 et61x251.4 finepix.4 gl860.4 ibmcam.4 ivtv.4 \
+ jeilinj.4 m5602.4 mars.4 meye.4 mr97310a.4 ov519.4 ov534.4 \
+ pacxxx.4 pvrusb2.4 pwc.4 saa7134.4 saa7164.4 se401.4 si470x.4 \
+ sn9c102.4 sn9c20x.4 sonixj.4 spca5xx.4 sq905c.4 stk014.4 \
+ stv06xx.4 sunplus.4 t613.4 tv8532.4 usbvision.4 vc032x.4 \
+ w9966.4 w996x.4 zc0301.4 zc3xx.4 zoran.4 zr364xx.4
+MAN8= webcamd.8
LIBDIR= ${PREFIX}/lib
-OPTIONS= HAL "Build with HAL and DBUS support" On
+OPTIONS= HAL "Build with HAL and DBUS support" On \
+ DEBUG "Build with debugging support" Off
.include <bsd.port.pre.mk>
LIBCUSE=${LIBDIR}/libcuse4bsd.so
+MAKE_ARGS+=" HAVE_MAN=YES"
+
.if defined(WITH_HAL)
-MAKE_ARGS+="HAVE_HAL=YES"
+MAKE_ARGS+=" HAVE_HAL=YES"
LIBHAL=${LIBDIR}/libhal.so:${LIBDIR}/libdbus-1.so:
LIB_DEPENDS+=hal.1:${PORTSDIR}/sysutils/hal
LIB_DEPENDS+=dbus-1:${PORTSDIR}/devel/dbus
@@ -40,6 +54,10 @@ LIB_DEPENDS+=dbus-1:${PORTSDIR}/devel/dbus
LIBHAL=
.endif
+.if defined(WITH_DEBUG)
+MAKE_ARGS+=" HAVE_DEBUG=YES"
+.endif
+
.if ${OSVERSION} < 800000
IGNORE= requires FreeBSD 8.0-RELEASE or later
.endif
diff --git a/multimedia/webcamd/distinfo b/multimedia/webcamd/distinfo
index 9df9e7479530..66f09d8c8d2e 100644
--- a/multimedia/webcamd/distinfo
+++ b/multimedia/webcamd/distinfo
@@ -1,3 +1,2 @@
-MD5 (webcamd-0.1.16.tar.bz2) = 2e48673e4f729ac4ebfcbddf9985c18e
-SHA256 (webcamd-0.1.16.tar.bz2) = ab5e5b7253414c822ce434317e5a0b0c82827765433bf4d115812d6e5ad8b192
-SIZE (webcamd-0.1.16.tar.bz2) = 3543806
+SHA256 (webcamd-0.1.18.tar.bz2) = 5ebb5b5347ddf6f3552141fa43036e330ece54133a66e7f2832de9770eb96aeb
+SIZE (webcamd-0.1.18.tar.bz2) = 3545356
diff --git a/multimedia/webcamd/files/webcamd.in b/multimedia/webcamd/files/webcamd.in
index 4271b72c0893..db1859b5c2ff 100644
--- a/multimedia/webcamd/files/webcamd.in
+++ b/multimedia/webcamd/files/webcamd.in
@@ -19,9 +19,14 @@ rcvar=`set_rcvar`
command=%%PREFIX%%/sbin/webcamd
command_args="-B"
-if [ -n "$hald_enable" ]; then
+start_precmd="${name}_prestart"
+
+webcamd_prestart()
+{
+ if checkyesno hald_enable ; then
command_args="$command_args -H"
-fi
+ fi
+}
pidfile="/var/run/webcamd.*.0.pid"
@@ -29,5 +34,6 @@ load_rc_config $name
if [ $# -gt 1 ]; then
pidfile="webcamd.dummy"
command_args="$command_args -d $2 -i 0"
+ # Only run the rc command if the appropriate arguments are specified:
+ run_rc_command $1
fi
-run_rc_command $1