aboutsummaryrefslogtreecommitdiff
path: root/multimedia/webcamd
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-01-16 19:55:32 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-01-16 19:55:32 +0000
commit2ba486a5a6c056ab3ab6349e4d48daa9b238b532 (patch)
tree74fdddeea0b6302f005d557397755251294b4a80 /multimedia/webcamd
parent53716d313b89ab9b0e7bc2523304841c96e264fe (diff)
downloadports-2ba486a5a6c056ab3ab6349e4d48daa9b238b532.tar.gz
ports-2ba486a5a6c056ab3ab6349e4d48daa9b238b532.zip
Notes
Diffstat (limited to 'multimedia/webcamd')
-rw-r--r--multimedia/webcamd/Makefile2
-rw-r--r--multimedia/webcamd/distinfo4
-rw-r--r--multimedia/webcamd/files/webcamd.in9
3 files changed, 12 insertions, 3 deletions
diff --git a/multimedia/webcamd/Makefile b/multimedia/webcamd/Makefile
index 9937005e416e..3b5c1b2b9739 100644
--- a/multimedia/webcamd/Makefile
+++ b/multimedia/webcamd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= webcamd
-PORTVERSION= 3.1.0.4
+PORTVERSION= 3.2.0.2
CATEGORIES= multimedia
MASTER_SITES= http://www.selasky.org/hans_petter/distfiles/ \
http://hselasky.homeunix.org:8192/distfiles/
diff --git a/multimedia/webcamd/distinfo b/multimedia/webcamd/distinfo
index f36761c7ca64..25bca899ee9b 100644
--- a/multimedia/webcamd/distinfo
+++ b/multimedia/webcamd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (webcamd-3.1.0.4.tar.bz2) = 05c6ed8027ca9c458e0bda042ec50b4696d3b0d6328cf522101d73cfe00616a2
-SIZE (webcamd-3.1.0.4.tar.bz2) = 8510595
+SHA256 (webcamd-3.2.0.2.tar.bz2) = 227e4166f70f060559633b528975d9e030df986663fc269103e55ab3fbc6d1d8
+SIZE (webcamd-3.2.0.2.tar.bz2) = 8825403
diff --git a/multimedia/webcamd/files/webcamd.in b/multimedia/webcamd/files/webcamd.in
index e02205b1e7a5..4e963675913c 100644
--- a/multimedia/webcamd/files/webcamd.in
+++ b/multimedia/webcamd/files/webcamd.in
@@ -31,6 +31,15 @@ webcamd_prestart()
pidfile="/var/run/webcamd.*.0.pid"
load_rc_config $name
+
+if [ "$2" = "vflip" ] || [ "$3" = "vflip" ]; then
+ command_args="$command_args -m v4l2.vflip=1"
+fi
+
+if [ "$2" = "hflip" ] || [ "$3" = "hflip" ]; then
+ command_args="$command_args -m v4l2.hflip=1"
+fi
+
if [ $# -gt 1 ]; then
pidfile="webcamd.dummy"
command_args="$command_args -d $2 -i 0"