aboutsummaryrefslogtreecommitdiff
path: root/multimedia/webcamd
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-06-28 17:49:51 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-06-28 17:49:51 +0000
commitef16d2e450342ea7c3cbfde50b170e0bac4a850d (patch)
treeb664103a38793e0d08c90c682a8a1bcccf66173e /multimedia/webcamd
parent3b3ad926b50c1395846a0be2c6d49ff6665d7bf7 (diff)
downloadports-ef16d2e450342ea7c3cbfde50b170e0bac4a850d.tar.gz
ports-ef16d2e450342ea7c3cbfde50b170e0bac4a850d.zip
Notes
Diffstat (limited to 'multimedia/webcamd')
-rw-r--r--multimedia/webcamd/Makefile1
-rw-r--r--multimedia/webcamd/files/patch-media_tree-include-linux-dvb-ca.h20
2 files changed, 21 insertions, 0 deletions
diff --git a/multimedia/webcamd/Makefile b/multimedia/webcamd/Makefile
index 20c271a0007c..72b591f57f26 100644
--- a/multimedia/webcamd/Makefile
+++ b/multimedia/webcamd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= webcamd
PORTVERSION= 3.6.0.1
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://www.selasky.org/hans_petter/distfiles/ \
http://hselasky.homeunix.org:8192/distfiles/
diff --git a/multimedia/webcamd/files/patch-media_tree-include-linux-dvb-ca.h b/multimedia/webcamd/files/patch-media_tree-include-linux-dvb-ca.h
new file mode 100644
index 000000000000..8841d967f0c4
--- /dev/null
+++ b/multimedia/webcamd/files/patch-media_tree-include-linux-dvb-ca.h
@@ -0,0 +1,20 @@
+--- media_tree/include/linux/dvb/ca.h.orig
++++ media_tree/include/linux/dvb/ca.h
+@@ -80,9 +80,17 @@ typedef struct ca_pid {
+
+ #define CA_RESET _IO('o', 128)
+ #define CA_GET_CAP _IOR('o', 129, ca_caps_t)
++
++/* At least CA_GET_SLOT_INFO and CA_GET_MSG need to be _IOWR not _IOR.
++ * This is wrong on Linux too but there the driver doesn't care.
++ *
+ #define CA_GET_SLOT_INFO _IOR('o', 130, ca_slot_info_t)
+ #define CA_GET_DESCR_INFO _IOR('o', 131, ca_descr_info_t)
+ #define CA_GET_MSG _IOR('o', 132, ca_msg_t)
++ */
++#define CA_GET_SLOT_INFO _IOWR('o', 130, ca_slot_info_t)
++#define CA_GET_DESCR_INFO _IOR('o', 131, ca_descr_info_t)
++#define CA_GET_MSG _IOWR('o', 132, ca_msg_t)
+ #define CA_SEND_MSG _IOW('o', 133, ca_msg_t)
+ #define CA_SET_DESCR _IOW('o', 134, ca_descr_t)
+ #define CA_SET_PID _IOW('o', 135, ca_pid_t)