aboutsummaryrefslogtreecommitdiff
path: root/multimedia/webcamd
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-07-16 21:35:48 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-07-16 21:35:48 +0000
commit19a753f745558270a804d0db644824ceedad655d (patch)
tree84a5fb23bb0c27407235e53fc7398c555c8073e1 /multimedia/webcamd
parentbbd0bbbec3c9233e0ab50f42d109891bc4ec6b5a (diff)
downloadports-19a753f745558270a804d0db644824ceedad655d.tar.gz
ports-19a753f745558270a804d0db644824ceedad655d.zip
Notes
Diffstat (limited to 'multimedia/webcamd')
-rw-r--r--multimedia/webcamd/Makefile1
-rw-r--r--multimedia/webcamd/files/patch-input.h17
2 files changed, 18 insertions, 0 deletions
diff --git a/multimedia/webcamd/Makefile b/multimedia/webcamd/Makefile
index 457745280808..8354457052e9 100644
--- a/multimedia/webcamd/Makefile
+++ b/multimedia/webcamd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= webcamd
PORTVERSION= 3.0.0.1
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://www.selasky.org/hans_petter/distfiles/ \
http://hselasky.homeunix.org:8192/distfiles/
diff --git a/multimedia/webcamd/files/patch-input.h b/multimedia/webcamd/files/patch-input.h
new file mode 100644
index 000000000000..0d7e0389c74a
--- /dev/null
+++ b/multimedia/webcamd/files/patch-input.h
@@ -0,0 +1,17 @@
+--- media_tree/include/linux/input.h.orig
++++ media_tree/include/linux/input.h
+@@ -104,8 +104,12 @@ struct input_keymap_entry {
+ #define EVIOCGREP _IOR('E', 0x03, unsigned int[2]) /* get repeat settings */
+ #define EVIOCSREP _IOW('E', 0x03, unsigned int[2]) /* set repeat settings */
+
+-#define EVIOCGKEYCODE _IOR('E', 0x04, unsigned int[2]) /* get keycode */
+-#define EVIOCGKEYCODE_V2 _IOR('E', 0x04, struct input_keymap_entry)
++/*
++ * These two need to be _IOWR not _IOR (they're wrong on Linux too but
++ * there the driver doesn't care.)
++ */
++#define EVIOCGKEYCODE _IOWR('E', 0x04, unsigned int[2]) /* get keycode */
++#define EVIOCGKEYCODE_V2 _IOWR('E', 0x04, struct input_keymap_entry)
+ #define EVIOCSKEYCODE _IOW('E', 0x04, unsigned int[2]) /* set keycode */
+ #define EVIOCSKEYCODE_V2 _IOW('E', 0x04, struct input_keymap_entry)
+