aboutsummaryrefslogtreecommitdiff
path: root/multimedia/win32-codecs
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-01-07 14:36:04 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-01-07 14:36:04 +0000
commit73e30486a1f0f2834f7b38ebfea05a1db205b0f9 (patch)
tree53293bf4b9b107f7ea2cecf4e05db5fbb919d970 /multimedia/win32-codecs
parent94e97f31226463eda41f687dd0db90d7338c1ed6 (diff)
downloadports-73e30486a1f0f2834f7b38ebfea05a1db205b0f9.tar.gz
ports-73e30486a1f0f2834f7b38ebfea05a1db205b0f9.zip
Notes
Diffstat (limited to 'multimedia/win32-codecs')
-rw-r--r--multimedia/win32-codecs/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/multimedia/win32-codecs/Makefile b/multimedia/win32-codecs/Makefile
index 2140e940e232..d4d2eff103e4 100644
--- a/multimedia/win32-codecs/Makefile
+++ b/multimedia/win32-codecs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= avifile
PORTVERSION= 0.53.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://ernie.eit.uni-kl.de/avifile/ \
http://divx.euro.ru/ \
@@ -18,7 +19,8 @@ EXTRACT_ONLY= avifile-${PORTVERSION}.tar.gz
MAINTAINER= holger@eit.uni-kl.de
-LIB_DEPENDS= SDL-1.1.2:${PORTSDIR}/devel/sdl-devel
+LIB_DEPENDS= SDL-1.1.2:${PORTSDIR}/devel/sdl-devel \
+ mp3lame.1:${PORTSDIR}/audio/lame
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
WRKSRC= ${WRKDIR}/${PORTNAME}-0.53
@@ -41,6 +43,7 @@ CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
CONFIGURE_ARGS= --with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-win32-path=${LOCALBASE}/lib/win32 \
+ --with-mp3-lame \
--enable-release
PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
@@ -58,6 +61,18 @@ DIFF?= /usr/bin/diff
.include <bsd.port.pre.mk>
+.if make(lib-depends)
+.if !exists(${LOCALBASE}/lib/libmp3lame.so) && exists(${LOCALBASE}/bin/lame)
+lib-depends:
+ @${ECHO_MSG} ====>
+ @${ECHO_MSG} ====> Error: You have an old version of lame installed.
+ @${ECHO_MSG} ====> You need at least port version 3.70_1!
+ @${ECHO_MSG} ====> Please deinstall lame first, then build avifile.
+ @${ECHO_MSG} ====>
+ @${FALSE}
+.endif
+.endif
+
post-extract:
@${LOCALBASE}/bin/unzip ${DISTDIR}/binaries-${CODEC_VERSION}.zip \
-d ${WRKDIR}/codecs