aboutsummaryrefslogtreecommitdiff
path: root/multimedia/x264
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-07-24 15:30:17 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-07-24 15:30:17 +0000
commit165386783ba6531e28f1bca60cd816a88a4f565f (patch)
tree595ff5d059002dcd6d13a16697308567acd720e4 /multimedia/x264
parenta9a479c415d9824088d1f0264a4ac55e2ee83f3d (diff)
downloadports-165386783ba6531e28f1bca60cd816a88a4f565f.tar.gz
ports-165386783ba6531e28f1bca60cd816a88a4f565f.zip
Notes
Diffstat (limited to 'multimedia/x264')
-rw-r--r--multimedia/x264/Makefile7
-rw-r--r--multimedia/x264/distinfo6
-rw-r--r--multimedia/x264/files/patch-Makefile12
-rw-r--r--multimedia/x264/files/patch-common_cpu.c57
-rw-r--r--multimedia/x264/files/patch-configure34
-rw-r--r--multimedia/x264/pkg-plist2
6 files changed, 58 insertions, 60 deletions
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
index 911eb31c4a66..acaacf019244 100644
--- a/multimedia/x264/Makefile
+++ b/multimedia/x264/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= x264
-PORTVERSION= 0.0.20100222
-PORTREVISION= 2
+PORTVERSION= 0.0.20100624
CATEGORIES= multimedia
MASTER_SITES= http://downloads.videolan.org/pub/videolan/x264/snapshots/ \
http://samples.mplayerhq.hu/yuv4mpeg2/:pgo
@@ -88,9 +87,9 @@ RESTRICTED_FILES= ${Y4M_VIDEO_DISTFILE}
.if !defined(WITHOUT_GPAC)
BUILD_DEPENDS+= gpac-libgpac>=0.4.5,1:${PORTSDIR}/multimedia/gpac-libgpac
LIB_DEPENDS+= gpac.1:${PORTSDIR}/multimedia/gpac-libgpac
-CONFIGURE_ARGS+= --enable-mp4-output
+CONFIGURE_ARGS+= --enable-gpac
.else
-CONFIGURE_ARGS+= --disable-mp4-output
+CONFIGURE_ARGS+= --disable-gpac
.endif
.if defined(WITH_X11_OUTPUT)
diff --git a/multimedia/x264/distinfo b/multimedia/x264/distinfo
index 5f2428bd15e8..9fbec344dd50 100644
--- a/multimedia/x264/distinfo
+++ b/multimedia/x264/distinfo
@@ -1,6 +1,6 @@
-MD5 (x264/x264-snapshot-20100222-2245.tar.bz2) = a68827d2e47920ee3ae655f8b8c51013
-SHA256 (x264/x264-snapshot-20100222-2245.tar.bz2) = 6f197d825315f077fabaf6340c324462cdceaf0417500dadea3511b1ad26ac2f
-SIZE (x264/x264-snapshot-20100222-2245.tar.bz2) = 400392
+MD5 (x264/x264-snapshot-20100624-2245.tar.bz2) = c510db9f178396d9de2926729a071d40
+SHA256 (x264/x264-snapshot-20100624-2245.tar.bz2) = 58e3093bbdd84c1e7a4797def1e654aae832ae91418971031d14a6048f1c6a43
+SIZE (x264/x264-snapshot-20100624-2245.tar.bz2) = 422940
MD5 (x264/example.y4m.bz2) = e0948016cd4a52e75d6a74d998bd6ae6
SHA256 (x264/example.y4m.bz2) = a5bec9d37362bd9d7773fbd0644643f9ec096d654d20823004e88d5df32bbff7
SIZE (x264/example.y4m.bz2) = 4910029
diff --git a/multimedia/x264/files/patch-Makefile b/multimedia/x264/files/patch-Makefile
index 5c743b2b520e..22aa6debe7a5 100644
--- a/multimedia/x264/files/patch-Makefile
+++ b/multimedia/x264/files/patch-Makefile
@@ -1,7 +1,7 @@
---- Makefile.orig 2010-02-22 22:45:05.000000000 +0100
-+++ Makefile 2010-04-18 10:43:06.325179277 +0200
-@@ -53,12 +53,12 @@
- cpu-a.asm dct-32.asm
+--- Makefile.orig 2010-07-07 22:45:06.000000000 +0200
++++ Makefile 2010-07-08 17:08:43.434178535 +0200
+@@ -56,12 +56,12 @@
+ cpu-a.asm dct-32.asm bitstream-a.asm
X86SRC = $(X86SRC0:%=common/x86/%)
-ifeq ($(ARCH),X86)
@@ -15,12 +15,12 @@
ARCH_X86 = yes
ASMSRC = $(X86SRC:-32.asm=-64.asm)
ASFLAGS += -DARCH_X86_64
-@@ -74,7 +74,7 @@
+@@ -77,7 +77,7 @@
endif
# AltiVec optims
-ifeq ($(ARCH),PPC)
+ifeq ($(ARCH),powerpc)
+ ifneq ($(AS),)
SRCS += common/ppc/mc.c common/ppc/pixel.c common/ppc/dct.c \
common/ppc/quant.c common/ppc/deblock.c \
- common/ppc/predict.c
diff --git a/multimedia/x264/files/patch-common_cpu.c b/multimedia/x264/files/patch-common_cpu.c
index 3dee424cc366..b1c529d67055 100644
--- a/multimedia/x264/files/patch-common_cpu.c
+++ b/multimedia/x264/files/patch-common_cpu.c
@@ -1,30 +1,29 @@
---- common/cpu.c.orig 2010-02-28 10:49:54.000000000 -0800
-+++ common/cpu.c 2010-02-28 10:56:06.000000000 -0800
-@@ -211,6 +211,27 @@
- return cpu;
- }
+--- common/cpu.c.orig 2010-06-24 22:45:07.000000000 +0200
++++ common/cpu.c 2010-07-18 22:55:49.324572565 +0200
+@@ -234,7 +234,7 @@
-+#elif defined(SYS_FREEBSD)
-+#include <sys/sysctl.h>
-+uint32_t x264_cpu_detect( void )
-+{
-+ uint32_t cpu;
-+ int has_altivec, error;
-+ size_t length;
-+
-+ cpu = 0;
-+ has_altivec = 0;
-+ length = sizeof( has_altivec );
-+ error = sysctlbyname("hw.altivec", &has_altivec, &length, NULL, 0 );
-+
-+ if( error == 0 && has_altivec != 0 )
-+ {
-+ cpu |= X264_CPU_ALTIVEC;
-+ }
-+
-+ return cpu;
-+}
-+
- #elif defined( SYS_LINUX )
- #include <signal.h>
- #include <setjmp.h>
+ #elif ARCH_PPC
+
+-#if SYS_MACOSX || SYS_OPENBSD
++#if SYS_MACOSX || SYS_OPENBSD || SYS_FREEBSD
+ #include <sys/sysctl.h>
+ uint32_t x264_cpu_detect( void )
+ {
+@@ -242,12 +242,16 @@
+ uint32_t cpu = 0;
+ #if SYS_OPENBSD
+ int selectors[2] = { CTL_MACHDEP, CPU_ALTIVEC };
+-#else
++#elif SYS_MACOSX
+ int selectors[2] = { CTL_HW, HW_VECTORUNIT };
+ #endif
+ int has_altivec = 0;
+ size_t length = sizeof( has_altivec );
++#if SYS_MACOSX || SYS_OPENBSD
+ int error = sysctl( selectors, 2, &has_altivec, &length, NULL, 0 );
++#else
++ int error = sysctlbyname("hw.altivec", &has_altivec, &length, NULL, 0 );
++#endif
+
+ if( error == 0 && has_altivec != 0 )
+ cpu |= X264_CPU_ALTIVEC;
diff --git a/multimedia/x264/files/patch-configure b/multimedia/x264/files/patch-configure
index d851deb3671e..10e0da310121 100644
--- a/multimedia/x264/files/patch-configure
+++ b/multimedia/x264/files/patch-configure
@@ -1,38 +1,38 @@
---- configure.orig 2010-02-22 22:45:05.000000000 +0100
-+++ configure 2010-04-23 12:56:49.647782200 +0200
+--- configure.orig 2010-06-24 22:45:07.000000000 +0200
++++ configure 2010-07-18 22:56:20.252020411 +0200
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
if test x"$1" = x"-h" -o x"$1" = x"--help" ; then
-@@ -317,11 +317,15 @@
+@@ -297,11 +297,15 @@
ARCH="X86"
AS="yasm"
ASFLAGS="$ASFLAGS -O2"
-- if [[ "$asm" == yes && "$CFLAGS" != *-march* ]]; then
+- if [[ "$asm" == auto && "$CFLAGS" != *-march* ]]; then
- CFLAGS="$CFLAGS -march=i686"
- fi
-- if [[ "$asm" == yes && "$CFLAGS" != *-mfpmath* ]]; then
+- if [[ "$asm" == auto && "$CFLAGS" != *-mfpmath* ]]; then
- CFLAGS="$CFLAGS -mfpmath=sse -msse"
+ if [ "$asm" = yes ]; then
-+ case "$CFLAGS" in
-+ *-march*) ;;
-+ *) CFLAGS="$CFLAGS -march=i686" ;;
-+ esac
-+ case "$CFLAGS" in
-+ *-mfpmath*) ;;
-+ *) CFLAGS="$CFLAGS -mfpmath=sse -msse" ;;
-+ esac
++ case "$CFLAGS" in
++ *-march*) ;;
++ *) CFLAGS="$CFLAGS -march=i686" ;;
++ esac
++ case "$CFLAGS" in
++ *-mfpmath*) ;;
++ *) CFLAGS="$CFLAGS -mfpmath=sse -msse" ;;
++ esac
fi
if [ "$SYS" = MACOSX ]; then
ASFLAGS="$ASFLAGS -f macho -DPREFIX"
-@@ -578,7 +582,7 @@
+@@ -572,7 +576,7 @@
[ -n "$LAVF_CFLAGS" ] && CFLAGS="$CFLAGS $LAVF_CFLAGS"
fi
--MP4_LDFLAGS="-lgpac_static"
-+MP4_LDFLAGS="-lgpac"
+-GPAC_LIBS="-lgpac_static"
++GPAC_LIBS="-lgpac"
if [ $SYS = MINGW ]; then
- MP4_LDFLAGS="$MP4_LDFLAGS -lwinmm"
+ GPAC_LIBS="$GPAC_LIBS -lwinmm"
fi
diff --git a/multimedia/x264/pkg-plist b/multimedia/x264/pkg-plist
index 0a24c478cdf9..d761f3ff3768 100644
--- a/multimedia/x264/pkg-plist
+++ b/multimedia/x264/pkg-plist
@@ -2,5 +2,5 @@ bin/x264
include/x264.h
lib/libx264.a
lib/libx264.so
-lib/libx264.so.85
+lib/libx264.so.98
libdata/pkgconfig/x264.pc