aboutsummaryrefslogtreecommitdiff
path: root/multimedia/x265
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-07-19 21:11:01 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-07-19 21:11:01 +0000
commita72292eb225ca1e050d7ca134f6268080b265f07 (patch)
tree2f152aa4c76252777ef878e90a107901e8e21de8 /multimedia/x265
parentd20914ecc305bb56f56c8315bfdb64c190f95364 (diff)
Notes
Diffstat (limited to 'multimedia/x265')
-rw-r--r--multimedia/x265/Makefile7
-rw-r--r--multimedia/x265/distinfo14
-rw-r--r--multimedia/x265/files/patch-svt-hevc-1.3.053
-rw-r--r--multimedia/x265/pkg-plist2
4 files changed, 58 insertions, 18 deletions
diff --git a/multimedia/x265/Makefile b/multimedia/x265/Makefile
index efd5f6e152c5..4e989f8d25c7 100644
--- a/multimedia/x265/Makefile
+++ b/multimedia/x265/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= x265
-PORTVERSION= 3.0
-PORTREVISION= 1
+PORTVERSION= 3.1.1
CATEGORIES= multimedia
MASTER_SITES= https://downloads.videolan.org/pub/videolan/x265/ \
https://mirror.leaseweb.com/videolan/x265/ \
@@ -11,10 +10,6 @@ MASTER_SITES= https://downloads.videolan.org/pub/videolan/x265/ \
http://mirror.leaseweb.com/videolan/x265/
DISTNAME= ${PORTNAME}_${PORTVERSION}
-PATCH_SITES= http://hg.videolan.org/${PORTNAME}/raw-rev/
-PATCHFILES+= 878541319ea1:-p1 a41325fc854f:-p1 # SVT-HEVC
-PATCHFILES+= 31ab7e09a3b5:-p1 e16999096b48:-p1 # SVT-HEVC
-
MAINTAINER= mi@aldan.algebra.com
COMMENT= H.265/High Efficiency Video Coding (HEVC) format
diff --git a/multimedia/x265/distinfo b/multimedia/x265/distinfo
index 94fb1b962dd2..9f4d59c9bf6d 100644
--- a/multimedia/x265/distinfo
+++ b/multimedia/x265/distinfo
@@ -1,11 +1,3 @@
-TIMESTAMP = 1548236838
-SHA256 (x265_3.0.tar.gz) = c5b9fc260cabbc4a81561a448f4ce9cad7218272b4011feabc3a6b751b2f0662
-SIZE (x265_3.0.tar.gz) = 1398519
-SHA256 (878541319ea1) = cb135430143d4d0df4e1d7e5b9d7994f0b6279796f44f7b8b6e5159c00c92768
-SIZE (878541319ea1) = 86799
-SHA256 (a41325fc854f) = 5fb5a2d97cecf9920f5800364534f56584dbf805f1e215de9dbdeca025eb3ec8
-SIZE (a41325fc854f) = 912
-SHA256 (31ab7e09a3b5) = ecf6349c12cdb060ccbd7dfcf013599208cd9239b1fbc877318f3a779b98b7aa
-SIZE (31ab7e09a3b5) = 2927
-SHA256 (e16999096b48) = 7e4cdeb59d172ab0b04c03356ad05a38bec1802f44b64ce56bf3694efe06cc82
-SIZE (e16999096b48) = 1105
+TIMESTAMP = 1562584219
+SHA256 (x265_3.1.1.tar.gz) = 827900c7cc0a0105b8a96460fab7cd22b97afa7b2835b5cb979c44bddaa3c8d0
+SIZE (x265_3.1.1.tar.gz) = 1419826
diff --git a/multimedia/x265/files/patch-svt-hevc-1.3.0 b/multimedia/x265/files/patch-svt-hevc-1.3.0
new file mode 100644
index 000000000000..08c4eb3c2242
--- /dev/null
+++ b/multimedia/x265/files/patch-svt-hevc-1.3.0
@@ -0,0 +1,53 @@
+encoderColorFormat, tileColumnCount, etc. were added after 1.3.0, so omit it for now.
+
+source/x265.cpp:570:13: error: no member named 'encoderColorFormat' in 'EB_H265_ENC_CONFIGURATION'
+ svtParam->encoderColorFormat = (EB_COLOR_FORMAT)param->internalCsp;
+ ~~~~~~~~ ^
+source/x265.cpp:570:35: error: use of undeclared identifier 'EB_COLOR_FORMAT'
+ svtParam->encoderColorFormat = (EB_COLOR_FORMAT)param->internalCsp;
+ ^
+source/common/param.cpp:2505:19: error: no member named 'tileColumnCount' in 'EB_H265_ENC_CONFIGURATION'
+ svtHevcParam->tileColumnCount = 1;
+ ~~~~~~~~~~~~ ^
+source/common/param.cpp:2506:19: error: no member named 'tileRowCount' in 'EB_H265_ENC_CONFIGURATION'
+ svtHevcParam->tileRowCount = 1;
+ ~~~~~~~~~~~~ ^
+source/common/param.cpp:2507:19: error: no member named 'tileSliceMode' in 'EB_H265_ENC_CONFIGURATION'
+ svtHevcParam->tileSliceMode = 0;
+ ~~~~~~~~~~~~ ^
+source/common/param.cpp:2508:19: error: no member named 'unrestrictedMotionVector' in 'EB_H265_ENC_CONFIGURATION'
+ svtHevcParam->unrestrictedMotionVector = 1;
+ ~~~~~~~~~~~~ ^
+
+--- source/common/param.cpp.orig 2019-07-08 11:10:19 UTC
++++ source/common/param.cpp
+@@ -2454,7 +2454,6 @@ void svt_param_default(x265_param* param)
+ svtHevcParam->frameRateNumerator = 0;
+ svtHevcParam->frameRateDenominator = 0;
+ svtHevcParam->encoderBitDepth = 8;
+- svtHevcParam->encoderColorFormat = EB_YUV420;
+ svtHevcParam->compressedTenBitFormat = 0;
+ svtHevcParam->rateControlMode = 0;
+ svtHevcParam->sceneChangeDetection = 1;
+@@ -2502,11 +2501,6 @@ void svt_param_default(x265_param* param)
+ svtHevcParam->logicalProcessors = 0;
+ svtHevcParam->switchThreadsToRtPriority = 1;
+ svtHevcParam->fpsInVps = 0;
+-
+- svtHevcParam->tileColumnCount = 1;
+- svtHevcParam->tileRowCount = 1;
+- svtHevcParam->tileSliceMode = 0;
+- svtHevcParam->unrestrictedMotionVector = 1;
+ }
+
+ int svt_set_preset_tune(x265_param* param, const char* preset, const char* tune)
+--- source/x265.cpp.orig 2019-07-08 11:10:19 UTC
++++ source/x265.cpp
+@@ -567,7 +567,6 @@ bool CLIOptions::parse(int argc, char **argv)
+ svtParam->frameRateNumerator = param->fpsNum;
+ svtParam->frameRateDenominator = param->fpsDenom;
+ svtParam->framesToBeEncoded = param->totalFrames;
+- svtParam->encoderColorFormat = (EB_COLOR_FORMAT)param->internalCsp;
+ }
+ #endif
+
diff --git a/multimedia/x265/pkg-plist b/multimedia/x265/pkg-plist
index c7e971fda4b0..26d9ed9d0fed 100644
--- a/multimedia/x265/pkg-plist
+++ b/multimedia/x265/pkg-plist
@@ -3,5 +3,5 @@ include/x265.h
include/x265_config.h
lib/libx265.a
lib/libx265.so
-lib/libx265.so.170
+lib/libx265.so.176
libdata/pkgconfig/x265.pc