aboutsummaryrefslogtreecommitdiff
path: root/multimedia/xbmc-pvr
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /multimedia/xbmc-pvr
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'multimedia/xbmc-pvr')
-rw-r--r--multimedia/xbmc-pvr/Makefile4
-rw-r--r--multimedia/xbmc-pvr/files/patch-lib-cximage-6.0-CxImage-ximapng.cpp74
-rw-r--r--multimedia/xbmc-pvr/files/patch-lib-cximage-6.0-CxImage-ximapng.h19
3 files changed, 95 insertions, 2 deletions
diff --git a/multimedia/xbmc-pvr/Makefile b/multimedia/xbmc-pvr/Makefile
index 3078b85c75e2..22407a2b6e5f 100644
--- a/multimedia/xbmc-pvr/Makefile
+++ b/multimedia/xbmc-pvr/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xbmc
PORTVERSION= 70
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= LOCAL/nox
PKGNAMESUFFIX= -pvr-ppa-odk
@@ -47,7 +47,7 @@ LIB_DEPENDS= asound.2:${PORTSDIR}/audio/alsa-lib \
mpeg2:${PORTSDIR}/multimedia/libmpeg2 \
ogg.7:${PORTSDIR}/audio/libogg \
pcre.1:${PORTSDIR}/devel/pcre \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
samplerate.1:${PORTSDIR}/audio/libsamplerate \
smbclient.0:${PORTSDIR}/net/samba-libsmbclient \
sqlite3.8:${PORTSDIR}/databases/sqlite3 \
diff --git a/multimedia/xbmc-pvr/files/patch-lib-cximage-6.0-CxImage-ximapng.cpp b/multimedia/xbmc-pvr/files/patch-lib-cximage-6.0-CxImage-ximapng.cpp
new file mode 100644
index 000000000000..227ee6e097e7
--- /dev/null
+++ b/multimedia/xbmc-pvr/files/patch-lib-cximage-6.0-CxImage-ximapng.cpp
@@ -0,0 +1,74 @@
+--- lib/cximage-6.0/CxImage/ximapng.cpp.orig 2012-03-16 00:33:05.000000000 +0100
++++ lib/cximage-6.0/CxImage/ximapng.cpp 2012-04-28 06:40:43.000000000 +0200
+@@ -15,7 +15,7 @@
+ void CxImagePNG::ima_png_error(png_struct *png_ptr, char *message)
+ {
+ strcpy(info.szLastError,message);
+- longjmp(png_ptr->jmpbuf, 1);
++ longjmp(png_jmpbuf(png_ptr), 1);
+ }
+ ////////////////////////////////////////////////////////////////////////////////
+ #if CXIMAGE_SUPPORT_DECODE
+@@ -62,7 +62,7 @@
+ /* Set error handling if you are using the setjmp/longjmp method (this is
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier. */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ delete [] row_pointers;
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+@@ -80,7 +80,7 @@
+ head.biWidth = info_ptr->width;
+ head.biHeight= info_ptr->height;
+ info.dwType = CXIMAGE_FORMAT_PNG;
+- longjmp(png_ptr->jmpbuf, 1);
++ longjmp(png_jmpbuf(png_ptr), 1);
+ }
+
+ /* calculate new number of channels */
+@@ -101,7 +101,7 @@
+ break;
+ default:
+ strcpy(info.szLastError,"unknown PNG color type");
+- longjmp(png_ptr->jmpbuf, 1);
++ longjmp(png_jmpbuf(png_ptr), 1);
+ }
+
+ //find the right pixel depth used for cximage
+@@ -111,7 +111,7 @@
+ if (channels >= 3) pixel_depth=24;
+
+ if (!Create(info_ptr->width, info_ptr->height, pixel_depth, CXIMAGE_FORMAT_PNG)){
+- longjmp(png_ptr->jmpbuf, 1);
++ longjmp(png_jmpbuf(png_ptr), 1);
+ }
+
+ /* get metrics */
+@@ -207,7 +207,7 @@
+ }
+
+ // <vho> - handle cancel
+- if (info.nEscape) longjmp(png_ptr->jmpbuf, 1);
++ if (info.nEscape) longjmp(png_jmpbuf(png_ptr), 1);
+
+ // row_bytes is the width x number of channels x (bit-depth / 8)
+ row_pointers = new BYTE[info_ptr->rowbytes + 8];
+@@ -230,7 +230,7 @@
+ do {
+
+ // <vho> - handle cancel
+- if (info.nEscape) longjmp(png_ptr->jmpbuf, 1);
++ if (info.nEscape) longjmp(png_jmpbuf(png_ptr), 1);
+
+ #if CXIMAGE_SUPPORT_ALPHA // <vho>
+ if (AlphaIsValid()) {
+@@ -361,7 +361,7 @@
+ /* Set error handling. REQUIRED if you aren't supplying your own
+ * error hadnling functions in the png_create_write_struct() call.
+ */
+- if (setjmp(png_ptr->jmpbuf)){
++ if (setjmp(png_jmpbuf(png_ptr))){
+ /* If we get here, we had a problem reading the file */
+ if (info_ptr->palette) free(info_ptr->palette);
+ png_destroy_write_struct(&png_ptr, (png_infopp)&info_ptr);
diff --git a/multimedia/xbmc-pvr/files/patch-lib-cximage-6.0-CxImage-ximapng.h b/multimedia/xbmc-pvr/files/patch-lib-cximage-6.0-CxImage-ximapng.h
new file mode 100644
index 000000000000..136d212061ad
--- /dev/null
+++ b/multimedia/xbmc-pvr/files/patch-lib-cximage-6.0-CxImage-ximapng.h
@@ -0,0 +1,19 @@
+--- lib/cximage-6.0/CxImage/ximapng.h.orig 2012-03-16 00:33:05.000000000 +0100
++++ lib/cximage-6.0/CxImage/ximapng.h 2012-04-28 06:17:43.000000000 +0200
+@@ -25,6 +25,7 @@
+ #ifdef _LINUX
+ #undef _DLL
+ #include <png.h>
++#include <pngpriv.h>
+ #else
+ #include "../png/png.h"
+ #endif
+@@ -70,7 +71,7 @@
+ static void PNGAPI user_error_fn(png_structp png_ptr,png_const_charp error_msg)
+ {
+ strncpy((char*)png_ptr->error_ptr,error_msg,255);
+- longjmp(png_ptr->jmpbuf, 1);
++ longjmp(png_jmpbuf(png_ptr), 1);
+ }
+ };
+