aboutsummaryrefslogtreecommitdiff
path: root/multimedia/xfce4-media
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2007-01-22 16:45:10 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2007-01-22 16:45:10 +0000
commit307bdced85efa099cb28882bf2904d68809a7547 (patch)
treea8d9f0fef2ab3a02971ab0000c95884bb3b29557 /multimedia/xfce4-media
parent7f941ef93ab911655cb1a2e6b7c89f115be1318c (diff)
downloadports-307bdced85efa099cb28882bf2904d68809a7547.tar.gz
ports-307bdced85efa099cb28882bf2904d68809a7547.zip
Notes
Diffstat (limited to 'multimedia/xfce4-media')
-rw-r--r--multimedia/xfce4-media/Makefile46
-rw-r--r--multimedia/xfce4-media/files/patch-src_xfmedia-xine.c20
2 files changed, 45 insertions, 21 deletions
diff --git a/multimedia/xfce4-media/Makefile b/multimedia/xfce4-media/Makefile
index 89293e15336e..48d31c8479d3 100644
--- a/multimedia/xfce4-media/Makefile
+++ b/multimedia/xfce4-media/Makefile
@@ -16,46 +16,50 @@ DIST_SUBDIR= xfce4
MAINTAINER= r.c.ladan@gmail.com
COMMENT= Lightweight media player for Xfce4 based on the xine engine
-LIB_DEPENDS= xfcegui4.3:${PORTSDIR}/x11-toolkits/libxfce4gui \
- startup-notification-1.0:${PORTSDIR}/x11/startup-notification \
- xine.16:${PORTSDIR}/multimedia/libxine \
- exo-0.3.0:${PORTSDIR}/x11/libexo
-
-OPTIONS= TAGLIB "Enable metadata editing" off \
- DBUS "Enable remote control support" off
+LIB_DEPENDS= xine.16:${PORTSDIR}/multimedia/libxine \
+ exo-0.3:${PORTSDIR}/x11/libexo
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
USE_BZIP2= yes
+USE_GCC= 3.4+
USE_GETOPT_LONG=yes
USE_GETTEXT= yes
-#NLS is hardcoded to "yes" in source, so no WITHOUT_NLS
USE_GMAKE= yes
-USE_GNOME= libxml2 intlhack
+USE_GNOME= glib20 gnomehack gnometarget gtk20 intltool intlhack pkgconfig
+USE_XFCE= configenv libexo libgui libutilpanel
USE_XLIB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-USE_LDCONFIG= yes
-INSTALLS_ICONS= yes
+OPTIONS= TAGLIB "Enable metadata editing" off \
+ DBUS "Enable D-BUS support" on \
+ STARTUP "Enable startup notification support" on
.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
.if defined(WITH_TAGLIB)
LIB_DEPENDS+= tag.5:${PORTSDIR}/audio/taglib
-CONFIGURE_ARGS+= --with-taglib
+CONFIGURE_ARGS+=--with-taglib
.else
-CONFIGURE_ARGS+= --without-taglib
+CONFIGURE_ARGS+=--without-taglib
.endif
-.if defined(WITH_DBUS)
+.if !defined(WITHOUT_DBUS)
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
-CONFIGURE_ARGS+= --enable-dbus
+CONFIGURE_ARGS+=--enable-dbus
+.else
+CONFIGURE_ARGS+=--disable-dbus
+.endif
+
+.if !defined(WITHOUT_STARTUP)
+LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+CONFIGURE_ARGS+=--enable-startup-notification
.else
-CONFIGURE_ARGS+= --disable-dbus
+CONFIGURE_ARGS+=--disable-startup-notification
.endif
post-patch:
- @${REINPLACE_CMD} -e "s|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g" \
- ${WRKSRC}/xfmedia/Makefile.in
+ @${REINPLACE_CMD} -e "s|xfmedia_remote_LDADD = |&@LIBXFCEGUI4_LIBS@|" \
+ ${WRKSRC}/src/Makefile.in
.include <bsd.port.post.mk>
diff --git a/multimedia/xfce4-media/files/patch-src_xfmedia-xine.c b/multimedia/xfce4-media/files/patch-src_xfmedia-xine.c
new file mode 100644
index 000000000000..fc68d41e27c7
--- /dev/null
+++ b/multimedia/xfce4-media/files/patch-src_xfmedia-xine.c
@@ -0,0 +1,20 @@
+--- src/xfmedia-xine.c.orig Thu Nov 30 17:49:55 2006
++++ src/xfmedia-xine.c Thu Nov 30 17:50:48 2006
+@@ -38,14 +38,14 @@
+ #ifdef HAVE_MATH_H
+ #include <math.h>
+ #endif
++#ifdef HAVE_SYS_TYPES_H
++#include <sys/types.h>
++#endif
+ #ifdef HAVE_SYS_SELECT_H
+ #include <sys/select.h>
+ #endif
+ #ifdef HAVE_SYS_TIME_H
+ #include <sys/time.h>
+-#endif
+-#ifdef HAVE_SYS_TYPES_H
+-#include <sys/types.h>
+ #endif
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>