aboutsummaryrefslogtreecommitdiff
path: root/multimedia/xine_artsplugin
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-02-26 15:22:37 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-02-26 15:22:37 +0000
commitd613b75b1d87505cc967bc6f8b7a419b2d57be5b (patch)
treefb8dfa0620864eed2a359680644745507734b86a /multimedia/xine_artsplugin
parent448b972896fbb34deed41c2bf9c30b12c6b16bc6 (diff)
downloadports-d613b75b1d87505cc967bc6f8b7a419b2d57be5b.tar.gz
ports-d613b75b1d87505cc967bc6f8b7a419b2d57be5b.zip
Notes
Diffstat (limited to 'multimedia/xine_artsplugin')
-rw-r--r--multimedia/xine_artsplugin/Makefile2
-rw-r--r--multimedia/xine_artsplugin/files/patch-xine_artsplugin-xinePlayObject_impl.cpp42
2 files changed, 43 insertions, 1 deletions
diff --git a/multimedia/xine_artsplugin/Makefile b/multimedia/xine_artsplugin/Makefile
index 40c260e60e88..0a6f4269206c 100644
--- a/multimedia/xine_artsplugin/Makefile
+++ b/multimedia/xine_artsplugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xine_artsplugin
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= multimedia kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/multimedia/xine_artsplugin/files/patch-xine_artsplugin-xinePlayObject_impl.cpp b/multimedia/xine_artsplugin/files/patch-xine_artsplugin-xinePlayObject_impl.cpp
new file mode 100644
index 000000000000..8a2e0890c2f2
--- /dev/null
+++ b/multimedia/xine_artsplugin/files/patch-xine_artsplugin-xinePlayObject_impl.cpp
@@ -0,0 +1,42 @@
+--- xine_artsplugin/xinePlayObject_impl.cpp.orig
++++ xine_artsplugin/xinePlayObject_impl.cpp
+@@ -698,9 +698,12 @@ void xinePlayObject_impl::eventLoop()
+
+ if (stream != 0)
+ {
+- xine_gui_send_vo_data( stream,
+- XINE_GUI_SEND_EXPOSE_EVENT,
+- &event );
++ // xine_gui_send_vo_data( stream,
++ // XINE_GUI_SEND_EXPOSE_EVENT,
++ // &event );
++ xine_port_send_gui_data( vo_port,
++ XINE_GUI_SEND_EXPOSE_EVENT,
++ &event );
+ }
+ else
+ {
+@@ -714,7 +717,10 @@ void xinePlayObject_impl::eventLoop()
+
+ if (stream != 0)
+ {
+- xine_gui_send_vo_data( stream,
++ // xine_gui_send_vo_data( stream,
++ // XINE_GUI_SEND_COMPLETION_EVENT,
++ // &event );
++ xine_port_send_gui_data( vo_port,
+ XINE_GUI_SEND_COMPLETION_EVENT,
+ &event );
+ }
+@@ -748,7 +754,10 @@ void xineVideoPlayObject_impl::x11Window
+ {
+ resizeNotify();
+
+- xine_gui_send_vo_data( stream,
++ // xine_gui_send_vo_data( stream,
++ // XINE_GUI_SEND_DRAWABLE_CHANGED,
++ // (void *)window );
++ xine_port_send_gui_data( vo_port,
+ XINE_GUI_SEND_DRAWABLE_CHANGED,
+ (void *)window );
+ }