aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-06-24 11:02:06 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-06-24 11:02:06 +0000
commit19b99d8af67f50a18c12db649270ae86a948ce44 (patch)
tree195fb9cb2e09d81177eca20f82eaeb795c2244e2 /multimedia
parent9d5cbdc3ea2beaaa77870ad9e6b84020791290cc (diff)
downloadports-19b99d8af67f50a18c12db649270ae86a948ce44.tar.gz
ports-19b99d8af67f50a18c12db649270ae86a948ce44.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vlc/Makefile8
-rw-r--r--multimedia/vlc/files/patch-modules-visualization-galaktos_PCM.c10
2 files changed, 14 insertions, 4 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 28372b96d308..3d895997067c 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -10,7 +10,7 @@
PORTNAME= vlc
DISTVERSION= 0.8.6h
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/vlc/${DISTVERSION}/ \
@@ -63,8 +63,6 @@ OPTIONS+= X264 "Enable H.264/AVC codec support" On
CONFLICTS= vlc-devel-[0-9]*
-WITH_VLC_DEFAULT_FONT?= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf
-
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -99,6 +97,8 @@ MAN1= vlc.1 \
.include <bsd.port.pre.mk>
+WITH_VLC_DEFAULT_FONT?= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf
+
.if ${PERL_LEVEL} < 500800
BROKEN= Does not compile with perl ${PERL_VERSION}
.endif
@@ -172,7 +172,7 @@ CONFIGURE_ARGS+=--disable-loader
.endif
.if !defined(WITHOUT_WXGTK)
-USE_WX= 2.8
+USE_WX= 2.6
WX_UNICODE= yes
CONFIGURE_ARGS+=--enable-wxwidgets
.else
diff --git a/multimedia/vlc/files/patch-modules-visualization-galaktos_PCM.c b/multimedia/vlc/files/patch-modules-visualization-galaktos_PCM.c
new file mode 100644
index 000000000000..c5f775189af1
--- /dev/null
+++ b/multimedia/vlc/files/patch-modules-visualization-galaktos_PCM.c
@@ -0,0 +1,10 @@
+--- modules/visualization/galaktos/PCM.c.orig 2008-06-24 00:46:12.000000000 +0200
++++ modules/visualization/galaktos/PCM.c 2008-06-24 00:46:31.000000000 +0200
+@@ -32,6 +32,7 @@
+
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <inttypes>
+
+ double **PCMd; //data structure to store PCM data PCM[channels][maxsamples]
+ int maxsamples; //size of PCM buffer