aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-10-16 08:22:02 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-10-16 08:22:02 +0000
commit6aca9683424cfda5bab08f9a7276db589c6cf51e (patch)
tree78c01a67580afddda2181951cff64e7bb4fd9a63 /multimedia
parent99745399609455bc230f1d04bf00a3facd9407e4 (diff)
downloadports-6aca9683424cfda5bab08f9a7276db589c6cf51e.tar.gz
ports-6aca9683424cfda5bab08f9a7276db589c6cf51e.zip
multimedia/kodi-devel: Unbreak GBM and WAYLAND
- Disable them on FreeBSD 10 as they are unlikely to work there - Make sure the necessary evdev headers can be found xbmc/windowing/wayland/WindowDecorator.cpp:16:10: fatal error: 'linux/input-event-codes.h' file not found #include <linux/input-event-codes.h> ^~~~~~~~~~~~~~~~~~~~~~~~~~~ - Explicitly link with libpthread and librt to get past the configure stage with GBM=on /usr/local/lib/libepoll-shim.so: undefined reference to `timer_settime' /usr/local/lib/libepoll-shim.so: undefined reference to `timer_delete' /usr/local/lib/libepoll-shim.so: undefined reference to `pthread_getthreadid_np' /usr/local/lib/libepoll-shim.so: undefined reference to `pthread_create' /usr/local/lib/libepoll-shim.so: undefined reference to `timer_create' /usr/local/lib/libepoll-shim.so: undefined reference to `timer_getoverrun' PR: 232299
Notes
Notes: svn path=/head/; revision=482209
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/kodi-devel/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/multimedia/kodi-devel/Makefile b/multimedia/kodi-devel/Makefile
index 795fcc7df435..8f9d81656d2d 100644
--- a/multimedia/kodi-devel/Makefile
+++ b/multimedia/kodi-devel/Makefile
@@ -86,6 +86,7 @@ OPTIONS_SINGLE= PLATFORM
OPTIONS_SINGLE_PLATFORM= GBM RPI WAYLAND X11
OPTIONS_EXCLUDE_amd64= RPI
OPTIONS_EXCLUDE_i386= RPI
+OPTIONS_EXCLUDE_FreeBSD_10= GBM WAYLAND
OPTIONS_SUB= yes
OPTIONS_GROUP= SOUND
@@ -105,11 +106,11 @@ CEC_CMAKE_BOOL= ENABLE_CEC
DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
DBUS_CMAKE_BOOL= ENABLE_DBUS
-GBM_BUILD_DEPENDS= v4l_compat>=0:multimedia/v4l_compat
GBM_CMAKE_ON= -DCORE_PLATFORM_NAME:STRING="gbm" \
-DGBM_RENDER_SYSTEM:STRING="gl"
-GBM_CFLAGS= -I${LOCALBASE}/include/libepoll-shim
-GBM_LDFLAGS= -L${LOCALBASE}/lib -lepoll-shim
+GBM_CFLAGS= -I${LOCALBASE}/include/libepoll-shim \
+ -I${WRKDIR}/evdev-proto
+GBM_LDFLAGS= -L${LOCALBASE}/lib -lepoll-shim -lpthread -lrt
GBM_LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
libinput.so:x11/libinput \
libxkbcommon.so:x11/libxkbcommon
@@ -163,8 +164,8 @@ VAAPI_LIB_DEPENDS= libva.so:multimedia/libva
VDPAU_CMAKE_BOOL= ENABLE_VDPAU
VDPAU_LIB_DEPENDS= libvdpau.so:multimedia/libvdpau
-WAYLAND_BUILD_DEPENDS= v4l_compat>=0:multimedia/v4l_compat \
- wayland-protocols>=0:graphics/wayland-protocols
+WAYLAND_BUILD_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols
+WAYLAND_CFLAGS= -I${WRKDIR}/evdev-proto
WAYLAND_CMAKE_ON= -DCORE_PLATFORM_NAME:STRING="wayland" \
-DWAYLAND_RENDER_SYSTEM:STRING="gl"
WAYLAND_LIB_DEPENDS= libinput.so:x11/libinput \
@@ -184,6 +185,15 @@ X11_USE= XORG=x11,xext,xrandr
PORTDATA= *
.endif
+# Avoid patching evdev header locations (too much pointless churn)
+post-extract-GBM-on:
+ @${MKDIR} ${WRKDIR}/evdev-proto/linux
+ @${CP} /usr/include/dev/evdev/* ${WRKDIR}/evdev-proto/linux
+
+post-extract-WAYLAND-on:
+ @${MKDIR} ${WRKDIR}/evdev-proto/linux
+ @${CP} /usr/include/dev/evdev/* ${WRKDIR}/evdev-proto/linux
+
post-patch:
# Do not try to download dvdnav/dvdread during the build, instead
# we'll manually point the build to the system's libdvd{nav,read}.so