aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 10:22:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 10:22:41 +0000
commit062ed8d36fcff34f0d3051dd7687377d27558a32 (patch)
tree35173dab2afafdac2c12b688bfc1f1397a7b8cfb /multimedia
parent00787ee8ab577b8449043d2c735d6136daf31f74 (diff)
downloadports-062ed8d36fcff34f0d3051dd7687377d27558a32.tar.gz
ports-062ed8d36fcff34f0d3051dd7687377d27558a32.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/banshee/Makefile3
-rw-r--r--multimedia/bino/Makefile4
-rw-r--r--multimedia/freevo/Makefile16
-rw-r--r--multimedia/gaupol/Makefile10
-rw-r--r--multimedia/gmencoder/Makefile2
-rw-r--r--multimedia/gnome-subtitles/Makefile10
-rw-r--r--multimedia/gopchop/Makefile17
-rw-r--r--multimedia/linux-realplayer/Makefile10
-rw-r--r--multimedia/sabbu/Makefile12
9 files changed, 40 insertions, 44 deletions
diff --git a/multimedia/banshee/Makefile b/multimedia/banshee/Makefile
index 48300951105f..10d21f041f31 100644
--- a/multimedia/banshee/Makefile
+++ b/multimedia/banshee/Makefile
@@ -1,4 +1,3 @@
-# Created by: Florent Thoumie <flz@FreeBSD.org>
# $FreeBSD$
PORTNAME= banshee
@@ -52,7 +51,7 @@ CONFIGURE_ARGS= --with-vendor-build-id=FreeBSD\ BSD\#\ Project --disable-gio-har
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/multimedia/bino/Makefile b/multimedia/bino/Makefile
index 6a0c2057d564..1dac904f6e6a 100644
--- a/multimedia/bino/Makefile
+++ b/multimedia/bino/Makefile
@@ -31,7 +31,9 @@ LIB_DEPENDS+= ass.5:${PORTSDIR}/multimedia/libass \
MAN1= bino.1
INFO= bino
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/multimedia/freevo/Makefile b/multimedia/freevo/Makefile
index 8892a14c1816..61dfd6c93789 100644
--- a/multimedia/freevo/Makefile
+++ b/multimedia/freevo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: freevo
-# Date created: April 10 2004
-# Whom: Lewis Thompson (purple@lewiz.net)
-#
+# Created by: Lewis Thompson (purple@lewiz.net)
# $FreeBSD$
-#
PORTNAME= freevo
PORTVERSION= 1.9.0
@@ -54,15 +50,17 @@ CONFDIR= ${PREFIX}/etc/${PORTNAME}
DATADIR= ${PREFIX}/share/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e 's| freevo_locale| # freevo_locale|' ${WRKSRC}/${PORTNAME}
@${MV} ${WRKSRC}/i18n ${WRKSRC}/i18n-nls-disabled
.endif
diff --git a/multimedia/gaupol/Makefile b/multimedia/gaupol/Makefile
index 986ecb69aea3..fdf8e83aa52a 100644
--- a/multimedia/gaupol/Makefile
+++ b/multimedia/gaupol/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gaupol
-# Date created: 08 January 2007
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gaupol
PORTVERSION= 0.19.2
@@ -28,7 +24,9 @@ INSTALLS_ICONS= yes
MAN1= ${PORTNAME}.1
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/multimedia/gmencoder/Makefile b/multimedia/gmencoder/Makefile
index 4b58ea6695b0..3c8cf8930968 100644
--- a/multimedia/gmencoder/Makefile
+++ b/multimedia/gmencoder/Makefile
@@ -55,7 +55,7 @@ post-patch:
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|' \
${WRKSRC}/src/main.c ${WRKSRC}/src/interface.c
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e '/^ALL_LINGUAS/d' ${WRKSRC}/configure
.endif
diff --git a/multimedia/gnome-subtitles/Makefile b/multimedia/gnome-subtitles/Makefile
index 8c34efcf9521..d0157408ae4f 100644
--- a/multimedia/gnome-subtitles/Makefile
+++ b/multimedia/gnome-subtitles/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gnome-subtitles
-# Date created: 23 March 2007
-# Whom: Marcin Simonides <marcin@studio4plus.com>
-#
+# Created by: Marcin Simonides <marcin@studio4plus.com>
# $FreeBSD$
-#
PORTNAME= gnome-subtitles
PORTVERSION= 1.2
@@ -35,7 +31,9 @@ USE_LDCONFIG= ${PREFIX}/lib/gnome-subtitles
MAN1= gnome-subtitles.1
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/multimedia/gopchop/Makefile b/multimedia/gopchop/Makefile
index ac9c24391ad5..fa209173d480 100644
--- a/multimedia/gopchop/Makefile
+++ b/multimedia/gopchop/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: GOPchop
-# Date created: Apr 24, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= gopchop
PORTVERSION= 1.0.0
@@ -28,12 +23,14 @@ PORTSCOUT= skipv:1.1.0,1.1.1,1.1.2,1.1.3,1.1.4,1.1.5,1.1.6,1.1.7,1.1.8
CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
LDFLAGS+= -L${LOCALBASE}/lib
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
diff --git a/multimedia/linux-realplayer/Makefile b/multimedia/linux-realplayer/Makefile
index 5eef0b29dc51..90e6c3934e0e 100644
--- a/multimedia/linux-realplayer/Makefile
+++ b/multimedia/linux-realplayer/Makefile
@@ -28,10 +28,12 @@ RADIR= ${PREFIX}/lib/RealPlayer
PLUGINSDIR= ${PREFIX}/lib/linux-mozilla/plugins
RABINDIR= ${PREFIX}/bin
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS="" LINUXBASE="${LINUXBASE}"
+.else
+PLIST_SUB+= NLS="@comment "
.endif
.include <bsd.port.pre.mk>
@@ -84,7 +86,7 @@ do-install:
${LN} -sf $c.so.6.0 ${RADIR}/codecs/$c.so
.endfor
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
@${MKDIR} ${RADIR}/share/locale
${CP} -Rp ${WRKSRC}/share/locale/* ${RADIR}/share/locale
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${RADIR}/share/locale
diff --git a/multimedia/sabbu/Makefile b/multimedia/sabbu/Makefile
index 58f388db472e..e2b8b7d84769 100644
--- a/multimedia/sabbu/Makefile
+++ b/multimedia/sabbu/Makefile
@@ -21,16 +21,18 @@ USE_GNOME= gtk20
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lswscale
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= WITH_NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= WITH_NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= WITH_NLS="@comment "
.endif
ASPELL_PORT?= textproc/aspell
-.if !defined(WITHOUT_GTKSPELL)
+.if ${PORT_OPTIONS:MGTKSPELL}
LIB_DEPENDS+= gtkspell:${PORTSDIR}/textproc/gtkspell
PLIST_SUB+= WITH_ASPELL=""
.else