aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-04-03 09:35:07 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-04-03 09:35:07 +0000
commit7835620f4fbfbe8f8690269437c3a4a77e370c8e (patch)
treefadbd8bb0ec0b62aecb6d588bf76e514528acce2 /multimedia
parentac8f75a3d0f90b280a594506d5761191a0f5da1e (diff)
downloadports-7835620f4fbfbe8f8690269437c3a4a77e370c8e.tar.gz
ports-7835620f4fbfbe8f8690269437c3a4a77e370c8e.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/smpeg-xmms/Makefile2
-rw-r--r--multimedia/smpeg-xmms/distinfo2
-rw-r--r--multimedia/smpeg-xmms/files/patch-ab76
-rw-r--r--multimedia/smpeg-xmms/files/patch-configure23
4 files changed, 25 insertions, 78 deletions
diff --git a/multimedia/smpeg-xmms/Makefile b/multimedia/smpeg-xmms/Makefile
index 52b98275fe17..081d865c02f0 100644
--- a/multimedia/smpeg-xmms/Makefile
+++ b/multimedia/smpeg-xmms/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= smpeg-xmms
-PORTVERSION= 0.3.3
+PORTVERSION= 0.3.4
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.xmms.org/xmms/plugins/smpeg-xmms/
diff --git a/multimedia/smpeg-xmms/distinfo b/multimedia/smpeg-xmms/distinfo
index eb3ed4352c49..755f96a411b2 100644
--- a/multimedia/smpeg-xmms/distinfo
+++ b/multimedia/smpeg-xmms/distinfo
@@ -1 +1 @@
-MD5 (smpeg-xmms-0.3.3.tar.gz) = 3eacf44852c40f821a68a28693693553
+MD5 (smpeg-xmms-0.3.4.tar.gz) = d42622e606ac66346b376bc225f90dec
diff --git a/multimedia/smpeg-xmms/files/patch-ab b/multimedia/smpeg-xmms/files/patch-ab
deleted file mode 100644
index 169595771a5d..000000000000
--- a/multimedia/smpeg-xmms/files/patch-ab
+++ /dev/null
@@ -1,76 +0,0 @@
---- src/smpeg-xmms.c 2000/12/19 16:41:23 1.1
-+++ src/smpeg-xmms.c 2000/12/19 16:48:55
-@@ -269,6 +269,7 @@
- smpeg_seek(MIN((gint)info.total_time,
- (gint)info.current_time + 5));
- }
-+#ifdef __linux
- else
- {
- SDL_mutexP(vcd_mutex);
-@@ -278,6 +279,7 @@
- vcdpos = vcdpos_max;
- SDL_mutexV(vcd_mutex);
- }
-+#endif
- break;
- case SDLK_LEFT:
- if (!is_vcd)
-@@ -287,6 +289,7 @@
- SDL_mutexV(mpeg_mutex);
- smpeg_seek(MAX(0, (gint)info.current_time - 5));
- }
-+#ifdef __linux
- else
- {
- SDL_mutexP(vcd_mutex);
-@@ -296,6 +299,7 @@
- vcdpos = 0;
- SDL_mutexV(vcd_mutex);
- }
-+#endif
- break;
- case SDLK_UP:
- i = xmms_remote_get_main_volume(ctrlsocket_get_session_id());
-@@ -748,9 +752,11 @@
- }
- if(is_vcd)
- {
-+#ifdef __linux
- set_track_number(CDROM_LEADOUT, &m, &s, &f);
- vcdpos_max = (((m * CD_SECS) + s) * CD_FRAMES) + f;
- smpeg_ip.set_info(name, (1000 * vcdpos_max) / CD_FRAMES, bitrate * 1000, srate, nch);
-+#endif
- }
- else
- {
-@@ -869,12 +875,14 @@
- SMPEG_seek(mpeg, (gint) (((gdouble) time / info.total_time) *
- info.total_size));
- }
-+#ifdef __linux
- else
- {
- SDL_mutexP(vcd_mutex);
- vcdpos = msf_to_lba(0, (int) time, 0);
- SDL_mutexV(vcd_mutex);
- }
-+#endif
- SDL_mutexV(mpeg_mutex);
- }
-
-@@ -900,9 +908,14 @@
-
- return (info.current_time * 1000);
- }
-+#ifdef __linux
-+ else
-+ {
- SDL_mutexV(mpeg_mutex);
- lba_to_msf(vcdpos, &m, &s, &f);
- return (1000 * ((m * CD_SECS) + s) + (f * 1000 / 75));
-+ }
-+#endif
- }
-
- static void smpeg_get_song_info(gchar * filename, gchar ** title, gint * length)
diff --git a/multimedia/smpeg-xmms/files/patch-configure b/multimedia/smpeg-xmms/files/patch-configure
new file mode 100644
index 000000000000..aacfc9393d4d
--- /dev/null
+++ b/multimedia/smpeg-xmms/files/patch-configure
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- configure 2001/04/03 09:08:00 1.1
++++ configure 2001/04/03 09:08:19
+@@ -3015,14 +3015,14 @@
+ fi
+
+
+-echo $ac_n "checking for XvGetVideo in -lSDL""... $ac_c" 1>&6
+-echo "configure:3020: checking for XvGetVideo in -lSDL" >&5
++echo $ac_n "checking for XvGetVideo in -lSDL-1.1""... $ac_c" 1>&6
++echo "configure:3020: checking for XvGetVideo in -lSDL-1.1" >&5
+ ac_lib_var=`echo SDL'_'XvGetVideo | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lSDL "-lc_r" $LIBS"
++LIBS="-lSDL-1.1 "-lc_r" $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 3028 "configure"
+ #include "confdefs.h"