aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-08-15 20:03:21 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-08-15 20:03:21 +0000
commit82a022574b53274481ab81913c82ed134c9544df (patch)
tree17af9f687115c7e7fe8e2fb055b14a14221c8f73 /multimedia
parent4595ee5a715814e318d756a62de40493e3096eb7 (diff)
downloadports-82a022574b53274481ab81913c82ed134c9544df.tar.gz
ports-82a022574b53274481ab81913c82ed134c9544df.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/py-gstreamer/Makefile2
-rw-r--r--multimedia/py-gstreamer1/Makefile4
-rw-r--r--multimedia/py3-gstreamer1/Makefile4
3 files changed, 5 insertions, 5 deletions
diff --git a/multimedia/py-gstreamer/Makefile b/multimedia/py-gstreamer/Makefile
index 2285064e7710..163bd7bab21e 100644
--- a/multimedia/py-gstreamer/Makefile
+++ b/multimedia/py-gstreamer/Makefile
@@ -27,7 +27,7 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
PLIST_SUB= VERSION="${GST_VERSION}"
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}
+LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e 's|DLFCN|dl|g' ${WRKSRC}/gst/__init__.py
diff --git a/multimedia/py-gstreamer1/Makefile b/multimedia/py-gstreamer1/Makefile
index 2c9fb8a2414b..846488c13274 100644
--- a/multimedia/py-gstreamer1/Makefile
+++ b/multimedia/py-gstreamer1/Makefile
@@ -21,8 +21,8 @@ USE_GNOME= pygobject3
USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
PLIST_SUB= VERSION="${GST_VERSION}"
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE} ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
post-install:
diff --git a/multimedia/py3-gstreamer1/Makefile b/multimedia/py3-gstreamer1/Makefile
index 23a713607d02..202243b9850d 100644
--- a/multimedia/py3-gstreamer1/Makefile
+++ b/multimedia/py3-gstreamer1/Makefile
@@ -21,8 +21,8 @@ USE_GNOME= py3gobject3
USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
PLIST_SUB= VERSION="${GST_VERSION}"
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE} ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
PLIST_SUB+= PVERSION=${PYTHON_VER:S/.//}