aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-03-14 02:10:35 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-03-14 02:10:35 +0000
commitdbd2d753996251efcfcaf22c11d91a2b79b3a0ee (patch)
tree47caffcb4dc7649c38816e72c6a00bd960b345cd /multimedia
parent0005347301cb2c85fa333e1e921e499dd4106fa9 (diff)
downloadports-dbd2d753996251efcfcaf22c11d91a2b79b3a0ee.tar.gz
ports-dbd2d753996251efcfcaf22c11d91a2b79b3a0ee.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mp4v2/Makefile6
-rw-r--r--multimedia/mp4v2/files/patch-ltmain.sh15
-rw-r--r--multimedia/mpeg4ip-libmp4v2/Makefile6
-rw-r--r--multimedia/mpeg4ip-libmp4v2/files/patch-ltmain.sh15
-rw-r--r--multimedia/mpeg4ip/Makefile8
-rw-r--r--multimedia/mpeg4ip/files/patch-lib::SDLAudio::ltmain.sh15
-rw-r--r--multimedia/mpeg4ip/files/patch-ltmain.sh15
-rw-r--r--multimedia/mpeg4ip/pkg-plist6
8 files changed, 15 insertions, 71 deletions
diff --git a/multimedia/mp4v2/Makefile b/multimedia/mp4v2/Makefile
index 67493f34a88c..0630d2c257bc 100644
--- a/multimedia/mp4v2/Makefile
+++ b/multimedia/mp4v2/Makefile
@@ -18,7 +18,7 @@ COMMENT= Mpeg-4 library and tools from mpeg4ip
USE_GMAKE= yes
USE_GNOME= gnometarget
-USE_INC_LIBTOOL_VER=15
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
@@ -33,8 +33,8 @@ INSTALL_WRKSRC= ${WRKSRC}/lib/mp4v2
BROKEN= "Please remove older version of faad before attempting to build ${PORTNAME}"
.endif
-.if ${OSVERSION} < 502110
-USE_GCC= 3.4
+.if ${OSVERSION} < 500000
+CFLAGS+= -O2
.endif
post-patch:
diff --git a/multimedia/mp4v2/files/patch-ltmain.sh b/multimedia/mp4v2/files/patch-ltmain.sh
deleted file mode 100644
index b7b985b46652..000000000000
--- a/multimedia/mp4v2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Thu Sep 30 04:09:46 2004
-+++ ltmain.sh Thu Sep 30 04:11:06 2004
-@@ -5425,10 +5425,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/multimedia/mpeg4ip-libmp4v2/Makefile b/multimedia/mpeg4ip-libmp4v2/Makefile
index 67493f34a88c..0630d2c257bc 100644
--- a/multimedia/mpeg4ip-libmp4v2/Makefile
+++ b/multimedia/mpeg4ip-libmp4v2/Makefile
@@ -18,7 +18,7 @@ COMMENT= Mpeg-4 library and tools from mpeg4ip
USE_GMAKE= yes
USE_GNOME= gnometarget
-USE_INC_LIBTOOL_VER=15
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
@@ -33,8 +33,8 @@ INSTALL_WRKSRC= ${WRKSRC}/lib/mp4v2
BROKEN= "Please remove older version of faad before attempting to build ${PORTNAME}"
.endif
-.if ${OSVERSION} < 502110
-USE_GCC= 3.4
+.if ${OSVERSION} < 500000
+CFLAGS+= -O2
.endif
post-patch:
diff --git a/multimedia/mpeg4ip-libmp4v2/files/patch-ltmain.sh b/multimedia/mpeg4ip-libmp4v2/files/patch-ltmain.sh
deleted file mode 100644
index b7b985b46652..000000000000
--- a/multimedia/mpeg4ip-libmp4v2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Thu Sep 30 04:09:46 2004
-+++ ltmain.sh Thu Sep 30 04:11:06 2004
-@@ -5425,10 +5425,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/multimedia/mpeg4ip/Makefile b/multimedia/mpeg4ip/Makefile
index f141c923b928..46d926017b41 100644
--- a/multimedia/mpeg4ip/Makefile
+++ b/multimedia/mpeg4ip/Makefile
@@ -25,12 +25,10 @@ LIB_DEPENDS= faac.0:${PORTSDIR}/audio/faac \
avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
mp4v2.0:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2
-USE_GNOME= \
- gtk20 \
- lthack
+USE_GNOME= gtk20
USE_SDL= sdl
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=15
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
@@ -96,7 +94,7 @@ MAN3= MP4.3 MP4AddAudioTrack.3 MP4AddHintTrack.3 MP4AddODTrack.3 \
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-lib::sdp::sdp_decode.c
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-player::src::codec::mp3::mp3_file.cpp
.else
-USE_GCC= 3.4
+CFLAGS+= -O2
.endif
###
diff --git a/multimedia/mpeg4ip/files/patch-lib::SDLAudio::ltmain.sh b/multimedia/mpeg4ip/files/patch-lib::SDLAudio::ltmain.sh
deleted file mode 100644
index 042b9d7965c9..000000000000
--- a/multimedia/mpeg4ip/files/patch-lib::SDLAudio::ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- lib/SDLAudio/ltmain.sh.orig Sun Nov 7 21:50:06 2004
-+++ lib/SDLAudio/ltmain.sh Sun Nov 7 21:50:28 2004
-@@ -5425,10 +5425,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/multimedia/mpeg4ip/files/patch-ltmain.sh b/multimedia/mpeg4ip/files/patch-ltmain.sh
deleted file mode 100644
index b7b985b46652..000000000000
--- a/multimedia/mpeg4ip/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Thu Sep 30 04:09:46 2004
-+++ ltmain.sh Thu Sep 30 04:11:06 2004
-@@ -5425,10 +5425,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/multimedia/mpeg4ip/pkg-plist b/multimedia/mpeg4ip/pkg-plist
index 77fe0963d6ad..7812d600343f 100644
--- a/multimedia/mpeg4ip/pkg-plist
+++ b/multimedia/mpeg4ip/pkg-plist
@@ -30,17 +30,23 @@ include/sdp.h
include/sdp_error.h
lib/libhttp.so
lib/libhttp.so.0
+lib/libmp4.a
lib/libmp4.so
lib/libmp4.so.0
+lib/libmp4av.a
lib/libmp4av.so
lib/libmp4av.so.0
+lib/libmp4util.a
lib/libmp4util.so
lib/libmp4util.so.0
lib/libmpeg4ipSDL-1.2.so
lib/libmpeg4ipSDL-1.2.so.7
+lib/libmpeg4ipSDL.a
lib/libmpeg4ipSDL.so
+lib/libmsg_queue.a
lib/libmsg_queue.so
lib/libmsg_queue.so.0
+lib/libsdp.a
lib/libsdp.so
lib/libsdp.so.0
lib/mp4player_plugin/a52_audio_plugin.so