aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-04-06 04:59:00 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-04-06 04:59:00 +0000
commit272014545e0601b52eb9c10f6defc13165155cf2 (patch)
tree9903c503f3bf6bdda7c887664455c4f8d8bc8706 /multimedia
parent86691745f8e5d5744d366e6f8c246b7712629d61 (diff)
downloadports-272014545e0601b52eb9c10f6defc13165155cf2.tar.gz
ports-272014545e0601b52eb9c10f6defc13165155cf2.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/okle/Makefile2
-rw-r--r--multimedia/okle/files/patch-src::okle_win.cpp40
2 files changed, 41 insertions, 1 deletions
diff --git a/multimedia/okle/Makefile b/multimedia/okle/Makefile
index 156077a9466e..071b870ef0d1 100644
--- a/multimedia/okle/Makefile
+++ b/multimedia/okle/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://okle.sourceforge.net/
MAINTAINER= lioux@FreeBSD.org
COMMENT= A KDE frontend to the Ogle DVD player
-BUILD_DEPENDS= ${LOCALBASE}/lib/ogle/libdvdcontrol.so.9:${PORTSDIR}/multimedia/ogle
+BUILD_DEPENDS= ${LOCALBASE}/lib/ogle/libdvdcontrol.so.10:${PORTSDIR}/multimedia/ogle
RUN_DEPENDS= ogle:${PORTSDIR}/multimedia/ogle
USE_AUTOCONF_VER= 253
diff --git a/multimedia/okle/files/patch-src::okle_win.cpp b/multimedia/okle/files/patch-src::okle_win.cpp
new file mode 100644
index 000000000000..f2b8321aca14
--- /dev/null
+++ b/multimedia/okle/files/patch-src::okle_win.cpp
@@ -0,0 +1,40 @@
+--- src/okle_win.cpp.orig Tue Feb 25 11:19:50 2003
++++ src/okle_win.cpp Sun Apr 6 01:50:55 2003
+@@ -34,6 +34,7 @@
+ #include <kstandarddirs.h>
+ #include <qtooltip.h>
+ #include <dcopclient.h>
++#include <kfileitem.h>
+
+ extern "C" {
+ #include <X11/Xlib.h>
+@@ -519,16 +520,16 @@
+ void OkleWin::slotFileOpenDisc()
+ {
+ conf->setGroup("DVD");
+- QString dvdp = conf->readEntry("dvdpath","/dev/dvd");
++ QString dvdp = conf->readEntry("dvdpath","/dev/acd0c");
+
+- QFileInfo fi(dvdp);
+- if(!fi.exists())
++ KFileItem fi(KFileItem::Unknown, KFileItem::Unknown, dvdp);
++ if(!QFile::exists(dvdp))
+ {
+ KMessageBox::error(0,QString(i18n("%1 does not exist!")).arg(dvdp),i18n("Error"));
+ return;
+ }
+
+- if(!fi.isFile() && !fi.isSymLink())
++ if(!fi.isFile() && !fi.isLink())
+ {
+ KMessageBox::error(0,QString(i18n("%1 exists but is not a file or symlink!")).arg(dvdp),i18n("Error"));
+ return;
+@@ -714,7 +715,7 @@
+ {
+ PrefsWin* prefs = new PrefsWin(this);
+ conf->setGroup("DVD");
+- prefs->setDVDPath(conf->readEntry("dvdpath","/dev/dvd"));
++ prefs->setDVDPath(conf->readEntry("dvdpath","/dev/acd0c"));
+ prefs->setRegion(conf->readNumEntry("region",1));
+ if(prefs->exec())
+ {