aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-04-15 22:39:54 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-04-15 22:39:54 +0000
commit9fa3b005432c22bff4b8e16d3266ff1590e4b2c2 (patch)
tree02684e4854a65e78ce3541db324ad59afa3f8c32 /multimedia
parent6a6b0483207f5378afcbb3a5009aa19dc20094d7 (diff)
downloadports-9fa3b005432c22bff4b8e16d3266ff1590e4b2c2.tar.gz
ports-9fa3b005432c22bff4b8e16d3266ff1590e4b2c2.zip
MFH: r384074
Fix build with GCC on recent head kernel by disabling PCH for GCC With hat: portmgr
Notes
Notes: svn path=/branches/2015Q2/; revision=384075
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mp4v2/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/multimedia/mp4v2/Makefile b/multimedia/mp4v2/Makefile
index 42bca29b278c..755683fc44cb 100644
--- a/multimedia/mp4v2/Makefile
+++ b/multimedia/mp4v2/Makefile
@@ -11,10 +11,17 @@ MAINTAINER= multimedia@FreeBSD.org
COMMENT= Library and tools to read, create, and modify mp4 files
CONFLICTS= mpeg4ip-libmp4v2-[0-9.]*
-USES= gmake libtool tar:bzip2
+USES= compiler gmake libtool tar:bzip2
MAKEFILE= GNUmakefile
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ENV= "FOUND_HELP2MAN=no"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# GCC is broken with PCH: https://lists.freebsd.org/pipermail/svn-src-all/2015-March/101722.html
+.if ${COMPILER_TYPE} == gcc
+CONFIGURE_ARGS= --disable-gch
+.endif
+
+.include <bsd.port.post.mk>