aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2024-03-16 16:38:09 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-03-16 16:38:28 +0000
commit712c8b449154517af198276e8361fb15da09df5b (patch)
tree0c5ffa8b73e515209fa32d03c2a007b81f2a5d3b /multimedia
parent243a07bc66101275e3c402dde96eb5637ad8c10a (diff)
multimedia/wireplumber: Session and policy manager for PipeWire
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/wireplumber/Makefile47
-rw-r--r--multimedia/wireplumber/distinfo3
-rw-r--r--multimedia/wireplumber/pkg-descr6
-rw-r--r--multimedia/wireplumber/pkg-plist178
5 files changed, 235 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index b0908ce6950f..d6ebc03a1e9a 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -390,6 +390,7 @@
SUBDIR += webcamoid
SUBDIR += wf-recorder
SUBDIR += winff
+ SUBDIR += wireplumber
SUBDIR += wl-screenrec
SUBDIR += wlrobs
SUBDIR += x264
diff --git a/multimedia/wireplumber/Makefile b/multimedia/wireplumber/Makefile
new file mode 100644
index 000000000000..2ecad6f3e3a4
--- /dev/null
+++ b/multimedia/wireplumber/Makefile
@@ -0,0 +1,47 @@
+PORTNAME= wireplumber
+DISTVERSION= 0.4.90
+CATEGORIES= multimedia
+
+MAINTAINER= arrowd@FreeBSD.org
+COMMENT= Session and policy manager for PipeWire
+WWW= https://pipewire.pages.freedesktop.org/wireplumber/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libpipewire-0.3.so:multimedia/pipewire
+
+USES= gnome localbase:ldflags lua meson pkgconfig python:build
+
+USE_GITLAB= yes
+GL_SITE= https://gitlab.freedesktop.org
+GL_ACCOUNT= pipewire
+
+USE_GNOME= glib20
+
+OPTIONS_DEFINE= DOCS DOXYGEN NLS
+
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
+ g-ir-scanner:devel/gobject-introspection \
+ sphinx-build:textproc/py-sphinx \
+ ${PYTHON_PKGNAMEPREFIX}breathe>0:devel/py-breathe@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${PY_FLAVOR}
+DOXYGEN_MESON_ENABLED= doc introspection
+DOXYGEN_IMPLIES= DOCS
+
+NLS_USES= gettext-runtime gettext-tools
+
+MESON_ARGS= -D system-lua=true \
+ -D systemd=disabled \
+ -D elogind=disabled
+
+OPTIONS_SUB= yes
+
+PORTDOCS= *
+
+post-patch:
+ ${REINPLACE_CMD} -e "s|'python3'|'python${PYTHON_VER}'|" \
+ ${WRKSRC}/docs/meson.build
+
+.include <bsd.port.mk>
diff --git a/multimedia/wireplumber/distinfo b/multimedia/wireplumber/distinfo
new file mode 100644
index 000000000000..a383050eb26e
--- /dev/null
+++ b/multimedia/wireplumber/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1710556110
+SHA256 (wireplumber-0.4.90.tar.bz2) = dea5d162f73a94d6b2d834ec4a5ea011e4917343c10869b8fcd72dbad461f32f
+SIZE (wireplumber-0.4.90.tar.bz2) = 398538
diff --git a/multimedia/wireplumber/pkg-descr b/multimedia/wireplumber/pkg-descr
new file mode 100644
index 000000000000..eac6e3b4fa89
--- /dev/null
+++ b/multimedia/wireplumber/pkg-descr
@@ -0,0 +1,6 @@
+PipeWire is a server and user space API to deal with multimedia pipelines.
+
+WirePlumber is a modular session / policy manager for PipeWire and a
+GObject-based high-level library that wraps PipeWire's API, providing
+convenience for writing the daemon's modules as well as external tools for
+managing PipeWire.
diff --git a/multimedia/wireplumber/pkg-plist b/multimedia/wireplumber/pkg-plist
new file mode 100644
index 000000000000..4ed2f0f3701f
--- /dev/null
+++ b/multimedia/wireplumber/pkg-plist
@@ -0,0 +1,178 @@
+bin/wireplumber
+bin/wpctl
+bin/wpexec
+include/wireplumber-0.5/wp/base-dirs.h
+include/wireplumber-0.5/wp/client.h
+include/wireplumber-0.5/wp/component-loader.h
+include/wireplumber-0.5/wp/conf.h
+include/wireplumber-0.5/wp/core.h
+include/wireplumber-0.5/wp/defs.h
+include/wireplumber-0.5/wp/device.h
+include/wireplumber-0.5/wp/error.h
+include/wireplumber-0.5/wp/event-dispatcher.h
+include/wireplumber-0.5/wp/event-hook.h
+include/wireplumber-0.5/wp/event.h
+include/wireplumber-0.5/wp/factory.h
+include/wireplumber-0.5/wp/global-proxy.h
+include/wireplumber-0.5/wp/iterator.h
+include/wireplumber-0.5/wp/json-utils.h
+include/wireplumber-0.5/wp/link.h
+include/wireplumber-0.5/wp/log.h
+include/wireplumber-0.5/wp/metadata.h
+include/wireplumber-0.5/wp/module.h
+include/wireplumber-0.5/wp/node.h
+include/wireplumber-0.5/wp/object-interest.h
+include/wireplumber-0.5/wp/object-manager.h
+include/wireplumber-0.5/wp/object.h
+include/wireplumber-0.5/wp/plugin.h
+include/wireplumber-0.5/wp/port.h
+include/wireplumber-0.5/wp/properties.h
+include/wireplumber-0.5/wp/proxy-interfaces.h
+include/wireplumber-0.5/wp/proxy.h
+include/wireplumber-0.5/wp/session-item.h
+include/wireplumber-0.5/wp/settings.h
+include/wireplumber-0.5/wp/si-factory.h
+include/wireplumber-0.5/wp/si-interfaces.h
+include/wireplumber-0.5/wp/spa-json.h
+include/wireplumber-0.5/wp/spa-pod.h
+include/wireplumber-0.5/wp/spa-type.h
+include/wireplumber-0.5/wp/state.h
+include/wireplumber-0.5/wp/transition.h
+include/wireplumber-0.5/wp/wp.h
+include/wireplumber-0.5/wp/wpenums.h
+include/wireplumber-0.5/wp/wpversion.h
+%%DOXYGEN%%lib/girepository-1.0/Wp-0.5.typelib
+lib/libwireplumber-0.5.so
+lib/libwireplumber-0.5.so.0
+lib/libwireplumber-0.5.so.0.4.90
+lib/wireplumber-0.5/libwireplumber-module-dbus-connection.so
+lib/wireplumber-0.5/libwireplumber-module-default-nodes-api.so
+lib/wireplumber-0.5/libwireplumber-module-file-monitor-api.so
+lib/wireplumber-0.5/libwireplumber-module-log-settings.so
+lib/wireplumber-0.5/libwireplumber-module-lua-scripting.so
+lib/wireplumber-0.5/libwireplumber-module-mixer-api.so
+lib/wireplumber-0.5/libwireplumber-module-portal-permissionstore.so
+lib/wireplumber-0.5/libwireplumber-module-reserve-device.so
+lib/wireplumber-0.5/libwireplumber-module-settings.so
+lib/wireplumber-0.5/libwireplumber-module-si-audio-adapter.so
+lib/wireplumber-0.5/libwireplumber-module-si-audio-virtual.so
+lib/wireplumber-0.5/libwireplumber-module-si-node.so
+lib/wireplumber-0.5/libwireplumber-module-si-standard-link.so
+lib/wireplumber-0.5/libwireplumber-module-standard-event-source.so
+libdata/pkgconfig/wireplumber-0.5.pc
+%%DOXYGEN%%share/gir-1.0/Wp-0.5.gir
+%%NLS%%share/locale/af/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/as/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/be/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/bn_IN/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/da/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/de/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/de_CH/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/el/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/es/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/gu/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/he/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/hi/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/id/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/it/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/ka/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/kn/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/ml/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/mr/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/my/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/oc/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/or/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/si/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/ta/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/te/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/wireplumber.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/wireplumber.mo
+%%DATADIR%%/scripts/client/access-default.lua
+%%DATADIR%%/scripts/client/access-portal.lua
+%%DATADIR%%/scripts/client/access-snap.lua
+%%DATADIR%%/scripts/default-nodes/apply-default-node.lua
+%%DATADIR%%/scripts/default-nodes/find-best-default-node.lua
+%%DATADIR%%/scripts/default-nodes/find-selected-default-node.lua
+%%DATADIR%%/scripts/default-nodes/rescan.lua
+%%DATADIR%%/scripts/default-nodes/state-default-nodes.lua
+%%DATADIR%%/scripts/device/apply-profile.lua
+%%DATADIR%%/scripts/device/apply-routes.lua
+%%DATADIR%%/scripts/device/autoswitch-bluetooth-profile.lua
+%%DATADIR%%/scripts/device/find-best-profile.lua
+%%DATADIR%%/scripts/device/find-best-routes.lua
+%%DATADIR%%/scripts/device/find-preferred-profile.lua
+%%DATADIR%%/scripts/device/select-profile.lua
+%%DATADIR%%/scripts/device/select-routes.lua
+%%DATADIR%%/scripts/device/state-profile.lua
+%%DATADIR%%/scripts/device/state-routes.lua
+%%DATADIR%%/scripts/fallback-sink.lua
+%%DATADIR%%/scripts/intended-roles.lua
+%%DATADIR%%/scripts/lib/common-utils.lua
+%%DATADIR%%/scripts/lib/device-info-cache.lua
+%%DATADIR%%/scripts/lib/filter-utils.lua
+%%DATADIR%%/scripts/lib/linking-utils.lua
+%%DATADIR%%/scripts/lib/monitor-utils.lua
+%%DATADIR%%/scripts/linking/find-best-target.lua
+%%DATADIR%%/scripts/linking/find-default-target.lua
+%%DATADIR%%/scripts/linking/find-defined-target.lua
+%%DATADIR%%/scripts/linking/find-filter-target.lua
+%%DATADIR%%/scripts/linking/find-user-target.lua.example
+%%DATADIR%%/scripts/linking/find-virtual-target.lua
+%%DATADIR%%/scripts/linking/get-filter-from-target.lua
+%%DATADIR%%/scripts/linking/link-target.lua
+%%DATADIR%%/scripts/linking/prepare-link.lua
+%%DATADIR%%/scripts/linking/rescan-virtual-links.lua
+%%DATADIR%%/scripts/linking/rescan.lua
+%%DATADIR%%/scripts/metadata.lua
+%%DATADIR%%/scripts/monitors/alsa-midi.lua
+%%DATADIR%%/scripts/monitors/alsa.lua
+%%DATADIR%%/scripts/monitors/bluez-midi.lua
+%%DATADIR%%/scripts/monitors/bluez.lua
+%%DATADIR%%/scripts/monitors/libcamera/create-device.lua
+%%DATADIR%%/scripts/monitors/libcamera/create-node.lua
+%%DATADIR%%/scripts/monitors/libcamera/enumerate-device.lua
+%%DATADIR%%/scripts/monitors/libcamera/name-device.lua
+%%DATADIR%%/scripts/monitors/libcamera/name-node.lua
+%%DATADIR%%/scripts/monitors/v4l2/create-device.lua
+%%DATADIR%%/scripts/monitors/v4l2/create-node.lua
+%%DATADIR%%/scripts/monitors/v4l2/enumerate-device.lua
+%%DATADIR%%/scripts/monitors/v4l2/name-device.lua
+%%DATADIR%%/scripts/monitors/v4l2/name-node.lua
+%%DATADIR%%/scripts/node/create-item.lua
+%%DATADIR%%/scripts/node/create-virtual-item.lua
+%%DATADIR%%/scripts/node/filter-forward-format.lua
+%%DATADIR%%/scripts/node/state-stream.lua
+%%DATADIR%%/scripts/node/suspend-node.lua
+%%DATADIR%%/scripts/policy-dsp.lua
+%%DATADIR%%/scripts/sm-objects.lua
+%%DATADIR%%/wireplumber.conf
+%%DATADIR%%/wireplumber.conf.d/alsa-vm.conf
+share/zsh/site-functions/_wpctl