aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-05-13 04:00:19 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-05-13 04:00:19 +0000
commitdadae425e3168cb5e1d06777f81c33d5f856b19c (patch)
tree3c6c6d3ed36749c0c55bbbd716c330d5f768eac1 /multimedia
parent634bce6776525ea0412b67286c1e1080fa6959a6 (diff)
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ffmpeg-devel/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/multimedia/ffmpeg-devel/Makefile b/multimedia/ffmpeg-devel/Makefile
index d1b0d7fbd6f9..45eac17a5a34 100644
--- a/multimedia/ffmpeg-devel/Makefile
+++ b/multimedia/ffmpeg-devel/Makefile
@@ -18,6 +18,7 @@ HAS_CONFIGURE= yes
USE_LINUX= yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_GCC= 3.4
USE_REINPLACE= yes
WANT_SDL= yes
CONFIGURE_ARGS= --cc="${CC}" --prefix="${PREFIX}" \
@@ -73,6 +74,10 @@ LIB_FILES= libavcodec/libavcodec.a libavformat/libavformat.a
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= 'Does not compile on FreeBSD 4.x'
+.endif
+
.if (exists(${LOCALBASE}/lib/libavformat.so))
BROKEN= 'Please remove previous version of ${PORTNAME} to continue build'
.endif