aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2011-07-03 16:47:58 +0000
committerHiroki Sato <hrs@FreeBSD.org>2011-07-03 16:47:58 +0000
commit18774eff9a3aa03d67926ac77702062d179ec8e4 (patch)
tree56e025b3d2ebcd7ad412c90cf62ddb049424c650 /multimedia
parent9eae4374f556fa873eca1d79e5eb214a420ccb74 (diff)
downloadports-18774eff9a3aa03d67926ac77702062d179ec8e4.tar.gz
ports-18774eff9a3aa03d67926ac77702062d179ec8e4.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/ptx-kmod/Makefile52
-rw-r--r--multimedia/ptx-kmod/distinfo2
-rw-r--r--multimedia/ptx-kmod/files/patch-dev-ptx-Makefile11
-rw-r--r--multimedia/ptx-kmod/files/ptx.sh.in27
-rw-r--r--multimedia/ptx-kmod/pkg-descr5
6 files changed, 98 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index cf6e7af91a3f..9744f53aa246 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -260,6 +260,7 @@
SUBDIR += poe
SUBDIR += ppm2fli
SUBDIR += projectx
+ SUBDIR += ptx-kmod
SUBDIR += pvr250
SUBDIR += pvrxxx
SUBDIR += pwcbsd
diff --git a/multimedia/ptx-kmod/Makefile b/multimedia/ptx-kmod/Makefile
new file mode 100644
index 000000000000..02fe442fa38c
--- /dev/null
+++ b/multimedia/ptx-kmod/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: ptx-kmod
+# Date created: July 2 2011
+# Whom: hrs
+#
+# $FreeBSD$
+#
+
+PORTNAME= ptx
+PORTVERSION= 0.0.20110326
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= hrs
+PKGNAMESUFFIX= -kmod
+DISTNAME= ${PORTNAME}-${PORTVERSION:S,0.0.,,}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Device driver for PT1/PT2 ISDB-S/T tuner cards
+
+LICENSE= GPLv3
+ONLY_FOR_ARCHS= amd64 i386
+BUILD_WRKSRC= ${WRKSRC}/dev/ptx
+MAKE_ENV= KMODDIR=${PREFIX}/${KMODDIR} SYSDIR=${SYSDIR}
+PLIST_FILES= ${KMODDIR}/ptx.ko
+PLIST_DIRS= ${KMODDIR}
+SUB_LIST= KMODDIR=${KMODDIR}
+USE_RC_SUBR= ptx.sh
+PORTDOCS= README
+
+KMODDIR= libexec/${PORTNAME}
+SYSDIR?= ${SRC_BASE}/sys
+
+.include <bsd.port.pre.mk>
+KERNCONF?= GENERIC
+
+# Use the first component of ${KERNCONF}.
+.for K in ${KERNCONF}
+_KERNCONF?=$K
+.endfor
+
+.if !exists(${SRC_BASE}/sys/${ARCH}/conf/${_KERNCONF})
+IGNORE= requires kernel source to be installed
+.endif
+
+do-install:
+ @${MKDIR} ${PREFIX}/${KMODDIR}
+ ${INSTALL_KLD} ${BUILD_WRKSRC}/ptx.ko ${PREFIX}/${KMODDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/ptx-kmod/distinfo b/multimedia/ptx-kmod/distinfo
new file mode 100644
index 000000000000..61180c4e76c9
--- /dev/null
+++ b/multimedia/ptx-kmod/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ptx-20110326.tar.gz) = bf85973e77dd4c30a981f75c5d11f0da37a782d8784900bee1078132cb939178
+SIZE (ptx-20110326.tar.gz) = 22589
diff --git a/multimedia/ptx-kmod/files/patch-dev-ptx-Makefile b/multimedia/ptx-kmod/files/patch-dev-ptx-Makefile
new file mode 100644
index 000000000000..fb3d456b133b
--- /dev/null
+++ b/multimedia/ptx-kmod/files/patch-dev-ptx-Makefile
@@ -0,0 +1,11 @@
+--- dev/ptx/Makefile.orig 2011-07-03 14:54:06.000000000 +0900
++++ dev/ptx/Makefile 2011-07-03 14:54:14.000000000 +0900
+@@ -7,7 +7,7 @@
+ SRCS = ptx.c ptx_iic.c ptx_tuner.c ptx_dma.c ptx_proc.c ptx_sysctl.c
+ SRCS += bus_if.h device_if.h pci_if.h
+
+-KMODDIR = /boot/modules
++KMODDIR?= /boot/modules
+
+ #DEBUG_FLAGS = -g
+
diff --git a/multimedia/ptx-kmod/files/ptx.sh.in b/multimedia/ptx-kmod/files/ptx.sh.in
new file mode 100644
index 000000000000..37fbb6979b62
--- /dev/null
+++ b/multimedia/ptx-kmod/files/ptx.sh.in
@@ -0,0 +1,27 @@
+#!/bin/sh
+# $FreeBSD$
+
+# PROVIDE: ptx
+# REQUIRE: LOGIN abi
+# KEYWORD: nojail
+
+. /etc/rc.subr
+
+name="ptx"
+rcvar=`set_rcvar`
+start_cmd="ptx_start"
+stop_cmd="ptx_stop"
+
+ptx_start()
+{
+ load_kld %%PREFIX%%/%%KMODDIR%%/ptx.ko
+}
+ptx_stop()
+{
+# XXX: unloading is still unstable
+# /sbin/kldunload ptx
+}
+
+: ${ptx_enable="YES"}
+load_rc_config $name
+run_rc_command "$1"
diff --git a/multimedia/ptx-kmod/pkg-descr b/multimedia/ptx-kmod/pkg-descr
new file mode 100644
index 000000000000..b59060d4ac74
--- /dev/null
+++ b/multimedia/ptx-kmod/pkg-descr
@@ -0,0 +1,5 @@
+A device driver for PT1 and PT2, ISDB-S/ISDB-T tuner cards from Earth Soft.
+This version is written by bsdaemon based on recpt1 utility for Linux.
+
+WWW: http://earthsoft.jp/PT1_PT2/index.html
+WWW: http://d.hatena.ne.jp/bsdaemon/20100429/1272556078