aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-09-14 20:48:48 +0000
committerRene Ladan <rene@FreeBSD.org>2013-09-14 20:48:48 +0000
commite7f3d9d4ef78bab9391686a1a2e671e0f003d219 (patch)
tree5a54f24a15c65178192c25026703855e061fdc0f /multimedia
parent670d00edc032c0dee1a9b8221478e3dbe2221853 (diff)
downloadports-e7f3d9d4ef78bab9391686a1a2e671e0f003d219.tar.gz
ports-e7f3d9d4ef78bab9391686a1a2e671e0f003d219.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/spotify-websocket-api/Makefile2
-rw-r--r--multimedia/spotify-websocket-api/files/patch-clients__respotify__respotify.py26
2 files changed, 19 insertions, 9 deletions
diff --git a/multimedia/spotify-websocket-api/Makefile b/multimedia/spotify-websocket-api/Makefile
index ef2fffa75a5c..2a82036e2b47 100644
--- a/multimedia/spotify-websocket-api/Makefile
+++ b/multimedia/spotify-websocket-api/Makefile
@@ -3,7 +3,7 @@
PORTNAME= SpotifyWebsocketAPI
PORTVERSION= 0.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/multimedia/spotify-websocket-api/files/patch-clients__respotify__respotify.py b/multimedia/spotify-websocket-api/files/patch-clients__respotify__respotify.py
index ca888d2f9e74..67a1254b0292 100644
--- a/multimedia/spotify-websocket-api/files/patch-clients__respotify__respotify.py
+++ b/multimedia/spotify-websocket-api/files/patch-clients__respotify__respotify.py
@@ -1,5 +1,5 @@
--- ./clients/respotify/respotify.py.orig 2013-08-08 08:45:21.000000000 +0200
-+++ ./clients/respotify/respotify.py 2013-09-10 23:04:36.000000000 +0200
++++ ./clients/respotify/respotify.py 2013-09-14 22:32:17.000000000 +0200
@@ -88,8 +88,10 @@
print "Playlists\n"
index = 1
@@ -13,7 +13,7 @@
else:
try:
if len(rootlist) >= int(args[0][0]):
-@@ -115,7 +117,10 @@
+@@ -115,10 +117,14 @@
def command_album(*args):
@@ -21,11 +21,16 @@
+ if len(*args) == 0 or args[0][0] == "" or current_playlist is None:
+ return
+
-+ if type(args[0][0]) != int:
++ try:
++ index = int(args[0][0])-1
++ except:
return
- index = int(args[0][0])-1
-@@ -127,7 +132,10 @@
+- index = int(args[0][0])-1
+ if current_playlist.getNumTracks() < index:
+ return
+
+@@ -127,10 +133,14 @@
def command_artist(*args):
@@ -33,11 +38,16 @@
+ if len(*args) == 0 or args[0][0] == "" or current_playlist is None:
+ return
+
-+ if type(args[0][0]) != int:
++ try:
++ index = int(args[0][0])-1
++ except:
+ return
+
+- index = int(args[0][0])-1
+ if current_playlist.getNumTracks() < index:
return
- index = int(args[0][0])-1
-@@ -278,7 +286,7 @@
+@@ -278,7 +288,7 @@
if spotify.logged_in():
os.system("kill `pgrep -f respotify-helper` &> /dev/null")
uri_resolver = subprocess.Popen([sys.executable, "respotify-helper.py",