aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-24 09:01:40 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-24 09:01:40 +0000
commita449f365400dcd9125b0699687b8d4c284377923 (patch)
tree85f9fa7defe4b911faad737d955cd8694cd40eac /multimedia
parentb9dec8a5243ed0d824478abc525b35f7212e1f83 (diff)
downloadports-a449f365400dcd9125b0699687b8d4c284377923.tar.gz
ports-a449f365400dcd9125b0699687b8d4c284377923.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vdr-plugin-extrecmenu/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/multimedia/vdr-plugin-extrecmenu/Makefile b/multimedia/vdr-plugin-extrecmenu/Makefile
index c4531e4404de..fac86d671917 100644
--- a/multimedia/vdr-plugin-extrecmenu/Makefile
+++ b/multimedia/vdr-plugin-extrecmenu/Makefile
@@ -11,21 +11,28 @@ DISTNAME= vdr-${PLUGIN}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Video Disk Recorder - extended recordings menu
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= tar:tgz
PATCH_STRIP= -p1
-HAVE_CONFIGURE= yes
-PORTDOCS= COPYING README HISTORY
WRKSRC= ${WRKDIR}/${PLUGIN}-${PORTVERSION}
+PORTDOCS= README HISTORY
+
+OPTIONS_DEFINE= DOCS NLS
+
.include "${.CURDIR}/../vdr/Makefile.plugins"
post-patch: post-patch-plugin
pre-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/lib/vdr
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/vdr
post-install: post-install-pluginlocales
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>