aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-28 23:29:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-08-28 23:29:35 +0000
commit12656da068ebafba91597fc85f090a2b7cf7980d (patch)
tree4aa401ac50ec32205621febf575f894facc21932 /multimedia
parent47198320fcff9fb977f107cddac3f3cf5e07b317 (diff)
downloadports-12656da068ebafba91597fc85f090a2b7cf7980d.tar.gz
ports-12656da068ebafba91597fc85f090a2b7cf7980d.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/cclive/Makefile26
-rw-r--r--multimedia/cclive/distinfo6
-rw-r--r--multimedia/cclive/pkg-descr13
3 files changed, 18 insertions, 27 deletions
diff --git a/multimedia/cclive/Makefile b/multimedia/cclive/Makefile
index 41ffedc843d8..fa33f12c86f7 100644
--- a/multimedia/cclive/Makefile
+++ b/multimedia/cclive/Makefile
@@ -6,17 +6,15 @@
#
PORTNAME= cclive
-PORTVERSION= 0.4.7
+PORTVERSION= 0.5.0
CATEGORIES= multimedia net
MASTER_SITES= GOOGLE_CODE
MAINTAINER= legatvs@gmail.com
-COMMENT= Lightweight command line video extraction utility
+COMMENT= Lightweight command line video extraction tool
-LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
-
-OPTIONS= PERL "With Perl interpreter" off \
- SIGWINCH "With resizing progressbar" on
+LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl \
+ pcre.0:${PORTSDIR}/devel/pcre
MAN1= cclive.1
@@ -27,22 +25,12 @@ GNU_CONFIGURE= yes
USE_GCC= 4.2+
MAKE_JOBS_SAFE= yes
USE_GNOME= pkgconfig
+USE_ICONV= yes
.include <bsd.port.pre.mk>
-.if defined(WITH_PERL)
-CONFIGURE_ARGS+=--with-perl
-USE_PERL5= 5.8.2+
-BUILD_DEPENDS+= p5-HTML-Parser>=3.59:${PORTSDIR}/www/p5-HTML-Parser
-RUN_DEPENDS+= p5-HTML-Parser>=3.59:${PORTSDIR}/www/p5-HTML-Parser
-.else
-CONFIGURE_ARGS+=--without-perl
-.endif
-
-.if defined(WITH_SIGWINCH)
-CONFIGURE_ARGS+=--enable-sigwinch
-.else
-CONFIGURE_ARGS+=--disable-sigwinch
+.if ${OSVERSION} < 700000
+IGNORE= does not compiel
.endif
.include <bsd.port.post.mk>
diff --git a/multimedia/cclive/distinfo b/multimedia/cclive/distinfo
index 18828301c7ae..a3613d4b41de 100644
--- a/multimedia/cclive/distinfo
+++ b/multimedia/cclive/distinfo
@@ -1,3 +1,3 @@
-MD5 (cclive-0.4.7.tar.bz2) = ea7ea8143471690d8972bf9caf21660b
-SHA256 (cclive-0.4.7.tar.bz2) = 3d693e565931725659cac084a7a1fb9c06678dd1f8502cf0f6b4c53146ef4199
-SIZE (cclive-0.4.7.tar.bz2) = 142981
+MD5 (cclive-0.5.0.tar.bz2) = 081c631f7ed64f31e5802f294d2f60f9
+SHA256 (cclive-0.5.0.tar.bz2) = 09598335fa6b0915e16ef2d408e34f70ab9db962a37c01f417911f52adc20450
+SIZE (cclive-0.5.0.tar.bz2) = 164096
diff --git a/multimedia/cclive/pkg-descr b/multimedia/cclive/pkg-descr
index 292e41243b89..970031152bb4 100644
--- a/multimedia/cclive/pkg-descr
+++ b/multimedia/cclive/pkg-descr
@@ -1,6 +1,9 @@
-cclive is a command line video extraction utility similar to clive but
-with lower requirements. Its features are few and essential. cclive
-supports Youtube, GoogleVideo, Break, Liveleak, Sevenload, EvisorTV and
-Dailymotion.
+cclive is a lightweight command line video extraction tool for Youtube and
+other similar video websites. It is a rewrite of the clive software in C++
+with lower system footprint and fewer dependencies.
-WWW: http://code.google.com/p/cclive/
+cclive is primarily a "video download tool" but it can also be used along side
+with video player software, like "mplayer", for viewing streamed videos instead
+of the Adobe flash player.
+
+WWW: http://cclive.googlecode.com/