aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-03-09 00:55:48 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-03-09 00:55:48 +0000
commit4ac1397e9e6ce3f8a6ea7d461ece9db212fc9483 (patch)
tree9940a6f7cc2c390c9651e0ced0de687fa53b0764 /multimedia
parentcc4b09fcc1b7aa6d9ea7bf5c49c796475ca734a8 (diff)
downloadports-4ac1397e9e6ce3f8a6ea7d461ece9db212fc9483.tar.gz
ports-4ac1397e9e6ce3f8a6ea7d461ece9db212fc9483.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile2
-rw-r--r--multimedia/kdemultimedia4/distinfo6
-rw-r--r--multimedia/phonon-gstreamer/Makefile39
-rw-r--r--multimedia/phonon-gstreamer/distinfo3
-rw-r--r--multimedia/phonon-gstreamer/files/patch-CMakeLists.txt50
-rw-r--r--multimedia/phonon-gstreamer/files/patch-cmake__FindGObject.cmake (renamed from multimedia/phonon/files/patch-cmake_FindGObject.cmake)4
-rw-r--r--multimedia/phonon-gstreamer/files/patch-cmake__FindPhonon.cmake73
-rw-r--r--multimedia/phonon-gstreamer/files/patch-gstreamer__CMakeLists.txt14
-rw-r--r--multimedia/phonon-gstreamer/pkg-descr2
-rw-r--r--multimedia/phonon-gstreamer/pkg-plist4
-rw-r--r--multimedia/phonon-xine/Makefile35
-rw-r--r--multimedia/phonon-xine/distinfo3
-rw-r--r--multimedia/phonon-xine/files/patch-CMakeLists.txt51
-rw-r--r--multimedia/phonon-xine/files/patch-cmake__FindPhonon.cmake73
-rw-r--r--multimedia/phonon-xine/files/patch-xine__CMakeLists.txt19
-rw-r--r--multimedia/phonon-xine/pkg-descr2
-rw-r--r--multimedia/phonon-xine/pkg-plist11
-rw-r--r--multimedia/phonon/Makefile15
-rw-r--r--multimedia/phonon/distinfo6
-rw-r--r--multimedia/phonon/files/patch-CMakeLists.txt17
-rw-r--r--multimedia/phonon/files/pkg-message.in10
-rw-r--r--multimedia/phonon/pkg-descr2
-rw-r--r--multimedia/phonon/pkg-message2
-rw-r--r--multimedia/phonon/pkg-plist13
24 files changed, 413 insertions, 43 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 4d5883028480..920b3dc51132 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -206,6 +206,8 @@
SUBDIR += p5-Video-Info
SUBDIR += p5-Video-OpenQuicktime
SUBDIR += phonon
+ SUBDIR += phonon-gstreamer
+ SUBDIR += phonon-xine
SUBDIR += podcatcher
SUBDIR += poe
SUBDIR += ppm2fli
diff --git a/multimedia/kdemultimedia4/distinfo b/multimedia/kdemultimedia4/distinfo
index 3d2ef12280c7..5bc4f603bfa5 100644
--- a/multimedia/kdemultimedia4/distinfo
+++ b/multimedia/kdemultimedia4/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/kdemultimedia-4.2.0.tar.bz2) = 3e944c87888ac1ac5b11d3722dd31f88
-SHA256 (KDE/kdemultimedia-4.2.0.tar.bz2) = 632e920dfabda4600cbe9519aae75c8c47bd502fd013baa950db27926509ed36
-SIZE (KDE/kdemultimedia-4.2.0.tar.bz2) = 1550040
+MD5 (KDE/kdemultimedia-4.2.1.tar.bz2) = d3916cb7a0dd5cb4e230e5c19d99563b
+SHA256 (KDE/kdemultimedia-4.2.1.tar.bz2) = ca86127a2ce1e27faf0b9c934aa4a98533f78adb86f3717580f49c9a0d6fa3ce
+SIZE (KDE/kdemultimedia-4.2.1.tar.bz2) = 1550352
diff --git a/multimedia/phonon-gstreamer/Makefile b/multimedia/phonon-gstreamer/Makefile
new file mode 100644
index 000000000000..1258217ca9f1
--- /dev/null
+++ b/multimedia/phonon-gstreamer/Makefile
@@ -0,0 +1,39 @@
+# New ports collection Makefile for: phonon
+# Date created: 2008-01-30
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= phonon
+PORTVERSION= 4.3.1
+CATEGORIES= multimedia kde ipv6
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+PKGNAMESUFFIX= -gstreamer
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Phonon gstreamer backend
+
+LIB_DEPENDS= phonon.4:${PORTSDIR}/multimedia/phonon
+
+CONFLICTS= phonon-4.3.0*
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_KDE4= kdehier automoc4 kdeprefix
+USE_QT_VER= 4
+QT_COMPONENTS= gui dbus xml opengl \
+ qmake_build moc_build rcc_build uic_build
+USE_GSTREAMER= yes
+
+post-patch:
+#fix finding automoc when PREFIX is not matched KDE4_PREFIX
+ ${REINPLACE_CMD} -e 's|NO_DEFAULT_PATH|${KDE4_PREFIX} NO_DEFAULT_PATH|' \
+ ${WRKSRC}/cmake/FindAutomoc4.cmake
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|{QT_INCLUDES}|{QT_INCLUDES} ${LOCALBASE}/include|'\
+ ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/multimedia/phonon-gstreamer/distinfo b/multimedia/phonon-gstreamer/distinfo
new file mode 100644
index 000000000000..7c88843e413a
--- /dev/null
+++ b/multimedia/phonon-gstreamer/distinfo
@@ -0,0 +1,3 @@
+MD5 (KDE/phonon-4.3.1.tar.bz2) = 767cb68052c108e95f293f30acdef3fb
+SHA256 (KDE/phonon-4.3.1.tar.bz2) = 7fb6d9efad29d7ac390d539cd516177c26cc2f92ddb9b3a5d70f2c49fc15269a
+SIZE (KDE/phonon-4.3.1.tar.bz2) = 575856
diff --git a/multimedia/phonon-gstreamer/files/patch-CMakeLists.txt b/multimedia/phonon-gstreamer/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..8be2c7f30e28
--- /dev/null
+++ b/multimedia/phonon-gstreamer/files/patch-CMakeLists.txt
@@ -0,0 +1,50 @@
+--- ./CMakeLists.txt.orig 2009-01-22 11:20:44.000000000 +0300
++++ ./CMakeLists.txt 2009-02-21 01:22:42.000000000 +0300
+@@ -127,12 +127,12 @@
+
+ try_run(_run_result _compile_result ${CMAKE_BINARY_DIR} ${_source_file} CMAKE_FLAGS "${_include_dirs}")
+
+- if(NOT _compile_result)
+- message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
+- endif(NOT _compile_result)
+- if(_run_result)
+- message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
+- endif(_run_result)
++# if(NOT _compile_result)
++# message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
++# endif(NOT _compile_result)
++# if(_run_result)
++# message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
++# endif(_run_result)
+
+ if (GCC_IS_NEWER_THAN_4_2)
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")
+@@ -250,8 +250,8 @@
+
+
+ add_subdirectory(cmake)
+-add_subdirectory(phonon)
+-add_subdirectory(includes)
++# add_subdirectory(phonon)
++# add_subdirectory(includes)
+ if (Q_WS_MAC AND BUILD_PHONON_QT7)
+ add_subdirectory(qt7)
+ endif (Q_WS_MAC AND BUILD_PHONON_QT7)
+@@ -261,12 +261,12 @@
+
+ if (Q_WS_X11)
+ add_subdirectory(gstreamer)
+- add_subdirectory(xine)
++# add_subdirectory(xine)
+ endif (Q_WS_X11)
+
+-if(NOT WIN32) # pkgconfig file
+- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc @ONLY)
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
+-endif(NOT WIN32)
++# if(NOT WIN32) # pkgconfig file
++# configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc @ONLY)
++# install(FILES ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc DESTINATION ${LIB_INSTALL_DIR}/../libdata/../libdata/../libdata/../libdata/../libdata/pkgconfig)
++# endif(NOT WIN32)
+
+ macro_display_feature_log()
diff --git a/multimedia/phonon/files/patch-cmake_FindGObject.cmake b/multimedia/phonon-gstreamer/files/patch-cmake__FindGObject.cmake
index d201555741bb..bb9f7fccfe55 100644
--- a/multimedia/phonon/files/patch-cmake_FindGObject.cmake
+++ b/multimedia/phonon-gstreamer/files/patch-cmake__FindGObject.cmake
@@ -1,5 +1,5 @@
---- ../cmake/FindGObject.cmake.orig 2008-11-24 20:11:55.000000000 +0300
-+++ ../cmake/FindGObject.cmake 2008-12-11 14:36:14.000000000 +0300
+--- ./cmake/FindGObject.cmake.orig 2008-11-24 20:11:55.000000000 +0300
++++ ./cmake/FindGObject.cmake 2009-02-21 01:19:39.000000000 +0300
@@ -23,14 +23,16 @@
# in the FIND_PATH() and FIND_LIBRARY() calls
PKG_CHECK_MODULES(PKG_GOBJECT2 REQUIRED gobject-2.0)
diff --git a/multimedia/phonon-gstreamer/files/patch-cmake__FindPhonon.cmake b/multimedia/phonon-gstreamer/files/patch-cmake__FindPhonon.cmake
new file mode 100644
index 000000000000..44c470dd884b
--- /dev/null
+++ b/multimedia/phonon-gstreamer/files/patch-cmake__FindPhonon.cmake
@@ -0,0 +1,73 @@
+--- ./cmake/FindPhonon.cmake.orig 2009-02-21 01:19:39.000000000 +0300
++++ ./cmake/FindPhonon.cmake 2009-02-21 01:19:39.000000000 +0300
+@@ -0,0 +1,70 @@
++# Find libphonon
++# Once done this will define
++#
++# PHONON_FOUND - system has Phonon Library
++# PHONON_INCLUDES - the Phonon include directory
++# PHONON_LIBS - link these to use Phonon
++# PHONON_VERSION - the version of the Phonon Library
++
++# Copyright (c) 2008, Matthias Kretz <kretz@kde.org>
++#
++# Redistribution and use is allowed according to the terms of the BSD license.
++# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
++
++macro(_phonon_find_version)
++ file(READ "${PHONON_INCLUDE_DIR}/phonon/phononnamespace.h" _phonon_header LIMIT 5000 OFFSET 1000)
++ string(REGEX MATCH "define PHONON_VERSION_STR \"(4\\.[0-9]+\\.[0-9a-z]+)\"" _phonon_version_match "${_phonon_header}")
++ set(PHONON_VERSION "${CMAKE_MATCH_1}")
++ message(STATUS "Phonon Version: ${PHONON_VERSION}")
++endmacro(_phonon_find_version)
++
++find_package(PkgConfig)
++PKG_CHECK_MODULES(PKG_PHONON phonon)
++
++if(PHONON_FOUND)
++ # Already found, nothing more to do except figuring out the version
++ _phonon_find_version()
++else(PHONON_FOUND)
++ if(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++ set(PHONON_FIND_QUIETLY TRUE)
++ endif(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++
++ # As discussed on kde-buildsystem: first look at CMAKE_PREFIX_PATH, then at the suggested PATHS (kde4 install dir)
++ find_library(PHONON_LIBRARY NAMES phonon PATHS ${PKG_PHONON_LIBRARY_DIRS} ${KDE4_PREFIX}/lib ${KDE4_LIB_INSTALL_DIR} ${QT_LIBRARY_DIR} NO_SYSTEM_ENVIRONMENT_PATH NO_CMAKE_SYSTEM_PATH)
++ # then at the default system locations (CMAKE_SYSTEM_PREFIX_PATH, i.e. /usr etc.)
++ find_library(PHONON_LIBRARY NAMES phonon)
++
++ find_path(PHONON_INCLUDE_DIR NAMES phonon/phonon_export.h PATHS ${PKG_PHONON_INCLUDE_DIRS} ${KDE4_PREFIX}/include ${KDE4_INCLUDE_INSTALL_DIR} ${QT_INCLUDE_DIR} ${INCLUDE_INSTALL_DIR} NO_SYSTEM_ENVIRONMENT_PATH NO_CMAKE_SYSTEM_PATH)
++ find_path(PHONON_INCLUDE_DIR NAMES phonon/phonon_export.h)
++
++ if(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++ set(PHONON_LIBS ${phonon_LIB_DEPENDS} ${PHONON_LIBRARY})
++ set(PHONON_INCLUDES ${PHONON_INCLUDE_DIR}/KDE ${PHONON_INCLUDE_DIR}/phonon ${PHONON_INCLUDE_DIR})
++ set(PHONON_FOUND TRUE)
++ _phonon_find_version()
++ else(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++ set(PHONON_FOUND FALSE)
++ endif(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++
++ if(PHONON_FOUND)
++ if(NOT PHONON_FIND_QUIETLY)
++ message(STATUS "Found Phonon: ${PHONON_LIBRARY}")
++ message(STATUS "Found Phonon Includes: ${PHONON_INCLUDES}")
++ endif(NOT PHONON_FIND_QUIETLY)
++ else(PHONON_FOUND)
++ if(Phonon_FIND_REQUIRED)
++ if(NOT PHONON_INCLUDE_DIR)
++ message(STATUS "Phonon includes NOT found!")
++ endif(NOT PHONON_INCLUDE_DIR)
++ if(NOT PHONON_LIBRARY)
++ message(STATUS "Phonon library NOT found!")
++ endif(NOT PHONON_LIBRARY)
++ message(FATAL_ERROR "Phonon library or includes NOT found!")
++ else(Phonon_FIND_REQUIRED)
++ message(STATUS "Unable to find Phonon")
++ endif(Phonon_FIND_REQUIRED)
++ endif(PHONON_FOUND)
++
++
++ mark_as_advanced(PHONON_INCLUDE_DIR PHONON_LIBRARY PHONON_INCLUDES)
++endif(PHONON_FOUND)
diff --git a/multimedia/phonon-gstreamer/files/patch-gstreamer__CMakeLists.txt b/multimedia/phonon-gstreamer/files/patch-gstreamer__CMakeLists.txt
new file mode 100644
index 000000000000..3a39b9470bff
--- /dev/null
+++ b/multimedia/phonon-gstreamer/files/patch-gstreamer__CMakeLists.txt
@@ -0,0 +1,14 @@
+--- ./gstreamer/CMakeLists.txt.orig 2008-11-24 20:12:02.000000000 +0300
++++ ./gstreamer/CMakeLists.txt 2009-02-21 01:19:39.000000000 +0300
+@@ -16,8 +16,10 @@
+ project(phonon-gstreamer)
+ include(ConfigureChecks.cmake)
+
++find_package(Phonon)
++
+ if (BUILD_PHONON_GSTREAMER)
+- include_directories(${GSTREAMER_INCLUDE_DIR} ${GLIB2_INCLUDE_DIR}
++ include_directories(${PHONON_INCLUDES} ${GSTREAMER_INCLUDE_DIR} ${GLIB2_INCLUDE_DIR}
+ ${LIBXML2_INCLUDE_DIR})
+ add_definitions(-DPHONON_BACKEND_VERSION_4_2)
+
diff --git a/multimedia/phonon-gstreamer/pkg-descr b/multimedia/phonon-gstreamer/pkg-descr
new file mode 100644
index 000000000000..d7ff46153a69
--- /dev/null
+++ b/multimedia/phonon-gstreamer/pkg-descr
@@ -0,0 +1,2 @@
+Phonon is multimedia framework for KDE4.
+This port provides GStreamer backend.
diff --git a/multimedia/phonon-gstreamer/pkg-plist b/multimedia/phonon-gstreamer/pkg-plist
new file mode 100644
index 000000000000..38ecb9467baa
--- /dev/null
+++ b/multimedia/phonon-gstreamer/pkg-plist
@@ -0,0 +1,4 @@
+lib/kde4/plugins/phonon_backend/phonon_gstreamer.so
+share/kde4/services/phononbackends/gstreamer.desktop
+@dirrmtry share/kde4/services/phononbackends
+@dirrmtry lib/kde4/plugins/phonon_backend
diff --git a/multimedia/phonon-xine/Makefile b/multimedia/phonon-xine/Makefile
new file mode 100644
index 000000000000..44677ec3c5b5
--- /dev/null
+++ b/multimedia/phonon-xine/Makefile
@@ -0,0 +1,35 @@
+# New ports collection Makefile for: phonon
+# Date created: 2008-01-30
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= phonon
+PORTVERSION= 4.3.1
+CATEGORIES= multimedia kde ipv6
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+PKGNAMESUFFIX= -xine
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Phonon xine backend
+
+LIB_DEPENDS= phonon.4:${PORTSDIR}/multimedia/phonon \
+ xine.1:${PORTSDIR}/multimedia/libxine
+
+CONFLICTS= phonon-4.3.0*
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_KDE4= kdehier automoc4 kdeprefix
+USE_QT_VER= 4
+QT_COMPONENTS= gui dbus xml \
+ qmake_build moc_build rcc_build uic_build
+
+post-patch:
+#fix finding automoc when PREFIX is not matched KDE4_PREFIX
+ ${REINPLACE_CMD} -e 's|NO_DEFAULT_PATH|${KDE4_PREFIX} NO_DEFAULT_PATH|' \
+ ${WRKSRC}/cmake/FindAutomoc4.cmake
+
+.include <bsd.port.mk>
diff --git a/multimedia/phonon-xine/distinfo b/multimedia/phonon-xine/distinfo
new file mode 100644
index 000000000000..7c88843e413a
--- /dev/null
+++ b/multimedia/phonon-xine/distinfo
@@ -0,0 +1,3 @@
+MD5 (KDE/phonon-4.3.1.tar.bz2) = 767cb68052c108e95f293f30acdef3fb
+SHA256 (KDE/phonon-4.3.1.tar.bz2) = 7fb6d9efad29d7ac390d539cd516177c26cc2f92ddb9b3a5d70f2c49fc15269a
+SIZE (KDE/phonon-4.3.1.tar.bz2) = 575856
diff --git a/multimedia/phonon-xine/files/patch-CMakeLists.txt b/multimedia/phonon-xine/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a8327f774222
--- /dev/null
+++ b/multimedia/phonon-xine/files/patch-CMakeLists.txt
@@ -0,0 +1,51 @@
+--- ./CMakeLists.txt.orig 2009-01-22 11:20:44.000000000 +0300
++++ ./CMakeLists.txt 2009-02-21 01:22:02.000000000 +0300
+@@ -127,12 +127,12 @@
+
+ try_run(_run_result _compile_result ${CMAKE_BINARY_DIR} ${_source_file} CMAKE_FLAGS "${_include_dirs}")
+
+- if(NOT _compile_result)
+- message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
+- endif(NOT _compile_result)
+- if(_run_result)
+- message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
+- endif(_run_result)
++# if(NOT _compile_result)
++# message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
++# endif(NOT _compile_result)
++# if(_run_result)
++# message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
++# endif(_run_result)
+
+ if (GCC_IS_NEWER_THAN_4_2)
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")
+@@ -250,8 +250,8 @@
+
+
+ add_subdirectory(cmake)
+-add_subdirectory(phonon)
+-add_subdirectory(includes)
++# add_subdirectory(phonon)
++# add_subdirectory(includes)
+ if (Q_WS_MAC AND BUILD_PHONON_QT7)
+ add_subdirectory(qt7)
+ endif (Q_WS_MAC AND BUILD_PHONON_QT7)
+@@ -260,13 +260,13 @@
+ endif (Q_WS_WIN)
+
+ if (Q_WS_X11)
+- add_subdirectory(gstreamer)
++# add_subdirectory(gstreamer)
+ add_subdirectory(xine)
+ endif (Q_WS_X11)
+
+-if(NOT WIN32) # pkgconfig file
+- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc @ONLY)
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
+-endif(NOT WIN32)
++# if(NOT WIN32) # pkgconfig file
++# configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc @ONLY)
++# install(FILES ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc DESTINATION ${LIB_INSTALL_DIR}/../libdata/../libdata/../libdata/../libdata/../libdata/pkgconfig)
++# endif(NOT WIN32)
+
+ macro_display_feature_log()
diff --git a/multimedia/phonon-xine/files/patch-cmake__FindPhonon.cmake b/multimedia/phonon-xine/files/patch-cmake__FindPhonon.cmake
new file mode 100644
index 000000000000..44c470dd884b
--- /dev/null
+++ b/multimedia/phonon-xine/files/patch-cmake__FindPhonon.cmake
@@ -0,0 +1,73 @@
+--- ./cmake/FindPhonon.cmake.orig 2009-02-21 01:19:39.000000000 +0300
++++ ./cmake/FindPhonon.cmake 2009-02-21 01:19:39.000000000 +0300
+@@ -0,0 +1,70 @@
++# Find libphonon
++# Once done this will define
++#
++# PHONON_FOUND - system has Phonon Library
++# PHONON_INCLUDES - the Phonon include directory
++# PHONON_LIBS - link these to use Phonon
++# PHONON_VERSION - the version of the Phonon Library
++
++# Copyright (c) 2008, Matthias Kretz <kretz@kde.org>
++#
++# Redistribution and use is allowed according to the terms of the BSD license.
++# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
++
++macro(_phonon_find_version)
++ file(READ "${PHONON_INCLUDE_DIR}/phonon/phononnamespace.h" _phonon_header LIMIT 5000 OFFSET 1000)
++ string(REGEX MATCH "define PHONON_VERSION_STR \"(4\\.[0-9]+\\.[0-9a-z]+)\"" _phonon_version_match "${_phonon_header}")
++ set(PHONON_VERSION "${CMAKE_MATCH_1}")
++ message(STATUS "Phonon Version: ${PHONON_VERSION}")
++endmacro(_phonon_find_version)
++
++find_package(PkgConfig)
++PKG_CHECK_MODULES(PKG_PHONON phonon)
++
++if(PHONON_FOUND)
++ # Already found, nothing more to do except figuring out the version
++ _phonon_find_version()
++else(PHONON_FOUND)
++ if(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++ set(PHONON_FIND_QUIETLY TRUE)
++ endif(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++
++ # As discussed on kde-buildsystem: first look at CMAKE_PREFIX_PATH, then at the suggested PATHS (kde4 install dir)
++ find_library(PHONON_LIBRARY NAMES phonon PATHS ${PKG_PHONON_LIBRARY_DIRS} ${KDE4_PREFIX}/lib ${KDE4_LIB_INSTALL_DIR} ${QT_LIBRARY_DIR} NO_SYSTEM_ENVIRONMENT_PATH NO_CMAKE_SYSTEM_PATH)
++ # then at the default system locations (CMAKE_SYSTEM_PREFIX_PATH, i.e. /usr etc.)
++ find_library(PHONON_LIBRARY NAMES phonon)
++
++ find_path(PHONON_INCLUDE_DIR NAMES phonon/phonon_export.h PATHS ${PKG_PHONON_INCLUDE_DIRS} ${KDE4_PREFIX}/include ${KDE4_INCLUDE_INSTALL_DIR} ${QT_INCLUDE_DIR} ${INCLUDE_INSTALL_DIR} NO_SYSTEM_ENVIRONMENT_PATH NO_CMAKE_SYSTEM_PATH)
++ find_path(PHONON_INCLUDE_DIR NAMES phonon/phonon_export.h)
++
++ if(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++ set(PHONON_LIBS ${phonon_LIB_DEPENDS} ${PHONON_LIBRARY})
++ set(PHONON_INCLUDES ${PHONON_INCLUDE_DIR}/KDE ${PHONON_INCLUDE_DIR}/phonon ${PHONON_INCLUDE_DIR})
++ set(PHONON_FOUND TRUE)
++ _phonon_find_version()
++ else(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++ set(PHONON_FOUND FALSE)
++ endif(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++
++ if(PHONON_FOUND)
++ if(NOT PHONON_FIND_QUIETLY)
++ message(STATUS "Found Phonon: ${PHONON_LIBRARY}")
++ message(STATUS "Found Phonon Includes: ${PHONON_INCLUDES}")
++ endif(NOT PHONON_FIND_QUIETLY)
++ else(PHONON_FOUND)
++ if(Phonon_FIND_REQUIRED)
++ if(NOT PHONON_INCLUDE_DIR)
++ message(STATUS "Phonon includes NOT found!")
++ endif(NOT PHONON_INCLUDE_DIR)
++ if(NOT PHONON_LIBRARY)
++ message(STATUS "Phonon library NOT found!")
++ endif(NOT PHONON_LIBRARY)
++ message(FATAL_ERROR "Phonon library or includes NOT found!")
++ else(Phonon_FIND_REQUIRED)
++ message(STATUS "Unable to find Phonon")
++ endif(Phonon_FIND_REQUIRED)
++ endif(PHONON_FOUND)
++
++
++ mark_as_advanced(PHONON_INCLUDE_DIR PHONON_LIBRARY PHONON_INCLUDES)
++endif(PHONON_FOUND)
diff --git a/multimedia/phonon-xine/files/patch-xine__CMakeLists.txt b/multimedia/phonon-xine/files/patch-xine__CMakeLists.txt
new file mode 100644
index 000000000000..a36be59bb980
--- /dev/null
+++ b/multimedia/phonon-xine/files/patch-xine__CMakeLists.txt
@@ -0,0 +1,19 @@
+--- ./xine/CMakeLists.txt.orig 2009-01-08 17:47:18.000000000 +0300
++++ ./xine/CMakeLists.txt 2009-02-21 01:19:39.000000000 +0300
+@@ -27,6 +27,7 @@
+ endif (NOT _OFFT_IS_64BIT)
+ endif (UNIX)
+
++find_package(Phonon)
+ macro_optional_find_package(Xine)
+ macro_optional_find_package(XCB)
+
+@@ -97,7 +98,7 @@
+
+
+ if(XINE_FOUND)
+- include_directories(${XINE_INCLUDE_DIR})
++ include_directories(${PHONON_INCLUDES} ${XINE_INCLUDE_DIR})
+
+ configure_file(config-xine-widget.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-xine-widget.h )
+
diff --git a/multimedia/phonon-xine/pkg-descr b/multimedia/phonon-xine/pkg-descr
new file mode 100644
index 000000000000..e3459ceb600e
--- /dev/null
+++ b/multimedia/phonon-xine/pkg-descr
@@ -0,0 +1,2 @@
+Phonon is multimedia framework for KDE4.
+This port provides xine backend.
diff --git a/multimedia/phonon-xine/pkg-plist b/multimedia/phonon-xine/pkg-plist
new file mode 100644
index 000000000000..2fce39cc3232
--- /dev/null
+++ b/multimedia/phonon-xine/pkg-plist
@@ -0,0 +1,11 @@
+lib/kde4/plugins/phonon_backend/phonon_xine.so
+share/icons/oxygen/128x128/apps/phonon-xine.png
+share/icons/oxygen/16x16/apps/phonon-xine.png
+share/icons/oxygen/22x22/apps/phonon-xine.png
+share/icons/oxygen/32x32/apps/phonon-xine.png
+share/icons/oxygen/48x48/apps/phonon-xine.png
+share/icons/oxygen/64x64/apps/phonon-xine.png
+share/icons/oxygen/scalable/apps/phonon-xine.svgz
+share/kde4/services/phononbackends/xine.desktop
+@dirrmtry share/kde4/services/phononbackends
+@dirrmtry lib/kde4/plugins/phonon_backend
diff --git a/multimedia/phonon/Makefile b/multimedia/phonon/Makefile
index 3c3280bde3f8..a6ff37cca42c 100644
--- a/multimedia/phonon/Makefile
+++ b/multimedia/phonon/Makefile
@@ -5,17 +5,14 @@
# $FreeBSD$
PORTNAME= phonon
-PORTVERSION= 4.3.0
-PORTREVISION= 1
+PORTVERSION= 4.3.1
CATEGORIES= multimedia kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTNAME}/${PORTVERSION}/
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
-COMMENT= KDE4 phonon applications
-
-LIB_DEPENDS= xine.1:${PORTSDIR}/multimedia/libxine
+COMMENT= Multimedia framework for KDE4
CONFLICTS= qt4-phonon-4* kdebase-runtime-4.1.[0-4]*
@@ -23,9 +20,8 @@ USE_BZIP2= yes
USE_KDE4= kdehier automoc4 kdeprefix
KDE4_BUILDENV= yes
USE_QT_VER= 4
-QT_COMPONENTS= corelib opengl dbus qt3support designer network svg qtestlib \
+QT_COMPONENTS= gui dbus xml qtestlib \
qmake_build moc_build rcc_build uic_build
-USE_GSTREAMER= yes
.include <bsd.port.pre.mk>
@@ -46,4 +42,7 @@ pre-configure:
-e 's|{QT_INCLUDES}|{QT_INCLUDES} ${LOCALBASE}/include|'\
${WRKSRC}/../CMakeLists.txt
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.post.mk>
diff --git a/multimedia/phonon/distinfo b/multimedia/phonon/distinfo
index 3e854c308d09..7c88843e413a 100644
--- a/multimedia/phonon/distinfo
+++ b/multimedia/phonon/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/phonon-4.3.0.tar.bz2) = f851219ec1fb4eadc7904f053b6b498d
-SHA256 (KDE/phonon-4.3.0.tar.bz2) = cb4c55e353ca9e547c94670990d58b6873937b3498045563b5c50988fb2ded22
-SIZE (KDE/phonon-4.3.0.tar.bz2) = 565443
+MD5 (KDE/phonon-4.3.1.tar.bz2) = 767cb68052c108e95f293f30acdef3fb
+SHA256 (KDE/phonon-4.3.1.tar.bz2) = 7fb6d9efad29d7ac390d539cd516177c26cc2f92ddb9b3a5d70f2c49fc15269a
+SIZE (KDE/phonon-4.3.1.tar.bz2) = 575856
diff --git a/multimedia/phonon/files/patch-CMakeLists.txt b/multimedia/phonon/files/patch-CMakeLists.txt
index 41f604aaad52..098a9b7d48e2 100644
--- a/multimedia/phonon/files/patch-CMakeLists.txt
+++ b/multimedia/phonon/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- ../CMakeLists.txt.orgi 2008-07-25 14:58:35.000000000 +0200
-+++ ../CMakeLists.txt 2008-07-25 14:59:12.000000000 +0200
-@@ -120,12 +120,12 @@
+--- ../CMakeLists.txt.orig 2009-01-22 11:20:44.000000000 +0300
++++ ../CMakeLists.txt 2009-02-21 01:36:17.000000000 +0300
+@@ -127,12 +127,12 @@
try_run(_run_result _compile_result ${CMAKE_BINARY_DIR} ${_source_file} CMAKE_FLAGS "${_include_dirs}")
@@ -19,3 +19,14 @@
if (GCC_IS_NEWER_THAN_4_2)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")
+@@ -260,8 +260,8 @@
+ endif (Q_WS_WIN)
+
+ if (Q_WS_X11)
+- add_subdirectory(gstreamer)
+- add_subdirectory(xine)
++# add_subdirectory(gstreamer)
++# add_subdirectory(xine)
+ endif (Q_WS_X11)
+
+ if(NOT WIN32) # pkgconfig file
diff --git a/multimedia/phonon/files/pkg-message.in b/multimedia/phonon/files/pkg-message.in
deleted file mode 100644
index 34b19b396c20..000000000000
--- a/multimedia/phonon/files/pkg-message.in
+++ /dev/null
@@ -1,10 +0,0 @@
-Should you not hear any sound at first KDE4 startup, do the following:
-
-create $HOME/.kde4/share/config/phonon_platform_kde
-
-and add the following lines to phonon_platform_kde:
-
-[Settings]
-showOssDevices=true
-
-And then start kde4 new. \ No newline at end of file
diff --git a/multimedia/phonon/pkg-descr b/multimedia/phonon/pkg-descr
index 8c87bc653013..558e852027aa 100644
--- a/multimedia/phonon/pkg-descr
+++ b/multimedia/phonon/pkg-descr
@@ -1 +1 @@
-phonon tools for KDE4.
+Phonon is multimedia framework for KDE4.
diff --git a/multimedia/phonon/pkg-message b/multimedia/phonon/pkg-message
new file mode 100644
index 000000000000..ebb37d8c4058
--- /dev/null
+++ b/multimedia/phonon/pkg-message
@@ -0,0 +1,2 @@
+Please consider to install xine backend for phonon (multimedia/phonon-xine)
+or/and Gstreamer backend (multimedia/phonon-gstreamer).
diff --git a/multimedia/phonon/pkg-plist b/multimedia/phonon/pkg-plist
index 985ffb9d45d2..489b28c032d2 100644
--- a/multimedia/phonon/pkg-plist
+++ b/multimedia/phonon/pkg-plist
@@ -96,8 +96,6 @@ include/phonon/videowidgetinterface.h
include/phonon/volumefadereffect.h
include/phonon/volumefaderinterface.h
include/phonon/volumeslider.h
-lib/kde4/plugins/phonon_backend/phonon_gstreamer.so
-lib/kde4/plugins/phonon_backend/phonon_xine.so
lib/libphonon.so
lib/libphonon.so.4
lib/libphonon.so.4.3.0
@@ -106,17 +104,6 @@ lib/libphononexperimental.so.4
lib/libphononexperimental.so.4.3.0
libdata/pkgconfig/phonon.pc
share/dbus-1/interfaces/org.kde.Phonon.AudioOutput.xml
-share/icons/oxygen/128x128/apps/phonon-xine.png
-share/icons/oxygen/16x16/apps/phonon-xine.png
-share/icons/oxygen/22x22/apps/phonon-xine.png
-share/icons/oxygen/32x32/apps/phonon-xine.png
-share/icons/oxygen/48x48/apps/phonon-xine.png
-share/icons/oxygen/64x64/apps/phonon-xine.png
-share/icons/oxygen/scalable/apps/phonon-xine.svgz
-share/kde4/services/phononbackends/gstreamer.desktop
-share/kde4/services/phononbackends/xine.desktop
-@dirrm share/kde4/services/phononbackends
-@dirrm lib/kde4/plugins/phonon_backend
@dirrm include/phonon/experimental
@dirrm include/phonon
@dirrm include/KDE/Phonon/Experimental