aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-10-09 01:41:40 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-10-09 01:41:40 +0000
commit9b3f9ce1c223f6354586790bb52a62c05be43bdf (patch)
tree38b32f54da180041ce6b6929cd0f319b7d6c07c4 /multimedia
parentcb8dde050c9b192d1b93a1d24fad4a85fee4d200 (diff)
downloadports-9b3f9ce1c223f6354586790bb52a62c05be43bdf.tar.gz
ports-9b3f9ce1c223f6354586790bb52a62c05be43bdf.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/helixplayer/Makefile46
-rw-r--r--multimedia/helixplayer/files/extrapatch-noplugin58
-rw-r--r--multimedia/helixplayer/files/msg.withplugin.in (renamed from multimedia/helixplayer/files/pkg-message.in)0
-rw-r--r--multimedia/helixplayer/files/patch-plugin18
-rw-r--r--multimedia/helixplayer/pkg-plist8
5 files changed, 105 insertions, 25 deletions
diff --git a/multimedia/helixplayer/Makefile b/multimedia/helixplayer/Makefile
index 3696ca7c9845..4788bec16ebe 100644
--- a/multimedia/helixplayer/Makefile
+++ b/multimedia/helixplayer/Makefile
@@ -8,7 +8,9 @@
PORTNAME= hxplay
PORTVERSION= 1.0.7
CATEGORIES= multimedia
-MASTER_SITES= https://helixcommunity.org/download.php/1950/
+MASTER_SITES= https://helixcommunity.org/frs/download.php/1950/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= shaun
MAINTAINER= shaun@FreeBSD.org
COMMENT= The Helix Community's open source media player
@@ -24,10 +26,10 @@ USE_PYTHON= yes
USE_GETTEXT= yes
USE_GNOME= gtk20
USE_DOS2UNIX= player/app/plugin/unix.pcf
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
LDCONFIG_DIRS= %%PREFIX%%/HelixPlayer/lib
-SUB_FILES= pkg-message
+SUB_FILES= msg.withplugin
CF2FIX= gcc.cf freebsd.cf freebsd-5.0-i586.cf freebsd-4.0-i386.cf \
freebsd-4.0-i586.cf freebsd-6.0-i586.cf freebsd-7.0-i586.cf
@@ -38,6 +40,28 @@ EXCLUDE= common/import datatype/image/jpg/import \
build/BIF/build.bif
EXTRACT_AFTER_ARGS=| ${TAR} -xf - ${EXCLUDE:S,^,--exclude ${DISTNAME}/,}
+OPTIONS= PLUGIN "Build with Gecko browser plug-in" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PLUGIN)
+USE_GECKO= firefox mozilla firefox-devel seamonkey
+PLIST_SUB+= PLUGIN=""
+PKGMESSAGE= ${WRKDIR}/msg.withplugin
+.else
+EXTRA_PATCHES+= ${FILESDIR}/extrapatch-noplugin
+PLIST_SUB+= PLUGIN="@comment "
+.endif
+
+.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
+
+.if defined(PACKAGE_BUILDING)
+FAIL_ACTION= ${CAT} "${WRKSRC}/build.out"; \
+ ${ECHO_MSG} ==================================================
+.else
+FAIL_ACTION= ${TRUE}
+.endif
+
pre-patch:
${LN} ${WRKSRC}/build/umakecf/freebsd-6.0-i586.cf \
${WRKSRC}/build/umakecf/freebsd-7.0-i586.cf
@@ -65,6 +89,11 @@ pre-configure:
> ${WRKSRC}/buildrc
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" \
${WRKSRC}/player/app/gtk/hxplay
+.if defined(WITH_PLUGIN)
+ ${REINPLACE_CMD} -e 's|%%GECKO%%|${GECKO}|g' \
+ -e 's|"%%GECKO_PREFIX%%/include\(.*\)"|"${LOCALBASE}/include\1", "${X11BASE}/include\1"|' \
+ ${WRKSRC}/player/app/plugin/unix.pcf
+.endif
post-build:
@if ! ${TAIL} "${WRKSRC}/build.out" | ${GREP} -qF ', 0 of' ; \
@@ -73,6 +102,7 @@ post-build:
${ECHO_MSG} Something failed, please examine the log file; \
${ECHO_MSG} ${WRKSRC}/build.out; \
${ECHO_MSG} ==================================================; \
+ ${FAIL_ACTION}; \
${FALSE}; \
fi
@@ -92,16 +122,8 @@ do-install:
${LN} -sf ${PREFIX}/HelixPlayer/share/hxplay.desktop ${DESKTOPDIR}
post-install:
+.if defined (WITH_PLUGIN)
@${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.pre.mk>
-
-BROKEN= fails to install
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2006-12-01
-
-.if ${ARCH}==ia64
-BROKEN= does not compile on ${ARCH} due to coredump
.endif
.include <bsd.port.post.mk>
diff --git a/multimedia/helixplayer/files/extrapatch-noplugin b/multimedia/helixplayer/files/extrapatch-noplugin
new file mode 100644
index 000000000000..4e6ff12d89af
--- /dev/null
+++ b/multimedia/helixplayer/files/extrapatch-noplugin
@@ -0,0 +1,58 @@
+--- build/build/BIF/build.bif Sun Oct 8 21:25:57 2006
++++ build/build/BIF/build.bif Mon Oct 9 00:11:25 2006
+@@ -5458,7 +5458,7 @@
+ HELIX_FEATURE_AUDIO_VORBIS=1
+ </defines>
+ <dependlist>
+- player player_plugin player_app_doc player_installer_postinst player_installer_common
++ player player_app_doc player_installer_postinst player_installer_common
+ installer
+ </dependlist>
+ </module>
+@@ -5644,7 +5644,7 @@
+ </module>
+
+ <!-- PLAYER_PLUGIN -->
+- <module id="player_plugin" name="player/app/plugin" group="player">
++ <!--<module id="player_plugin" name="player/app/plugin" group="player">
+ <location file="/home/build/build/bif-cvs/helix/2006%2f04%2f12%2012%253a50%253a16/client/build/BIF/realplay_gtk_release.bif" line="0"/>
+ <cvstag id="bingo_release_10_0_3" type="tag"/>
+
+@@ -5661,7 +5661,7 @@
+ <source_dependlist>
+ client_include player_widget
+ </source_dependlist>
+- </module>
++ </module>-->
+
+ <!-- PLAYER_WIDGET -->
+ <module id="player_widget" name="player/common/gtk" group="player">
+--- player/installer/archive/make_tempdir Wed Feb 2 00:59:08 2005
++++ player/installer/archive/make_tempdir Mon Oct 9 00:42:02 2006
+@@ -69,7 +69,6 @@
+ "share",
+ "doc",
+ "lib",
+- "mozilla",
+ "postinst")
+
+
+@@ -99,12 +98,12 @@
+ # widget lib
+ inst.CopyModuleDlls(("player/common/gtk", "libgtkhx", "lib/libgtkhx"))
+
+-# mozilla plugin
+-inst.CopyModuleDlls(
+- ("filesystem/memory", "memfsys", "plugins/memfsys"),
+- ("player/app/plugin", "nphelix", "mozilla/nphelix"))
+-inst.CopyFiles(
+- ("../../../player/app/plugin/nphelix.xpt", "mozilla/nphelix.xpt"))
++## mozilla plugin
++#inst.CopyModuleDlls(
++# ("filesystem/memory", "memfsys", "plugins/memfsys"))
++# ("player/app/plugin", "nphelix", "mozilla/nphelix"))
++#inst.CopyFiles(
++# ("../../../player/app/plugin/nphelix.xpt", "mozilla/nphelix.xpt"))
+
+ # client core
+ inst.CopyModuleDlls(
diff --git a/multimedia/helixplayer/files/pkg-message.in b/multimedia/helixplayer/files/msg.withplugin.in
index d749736860d1..d749736860d1 100644
--- a/multimedia/helixplayer/files/pkg-message.in
+++ b/multimedia/helixplayer/files/msg.withplugin.in
diff --git a/multimedia/helixplayer/files/patch-plugin b/multimedia/helixplayer/files/patch-plugin
index 5d4d7d185f73..8e2d99352051 100644
--- a/multimedia/helixplayer/files/patch-plugin
+++ b/multimedia/helixplayer/files/patch-plugin
@@ -21,15 +21,15 @@ The latter is not safe on 64-bit systems...
- "common/import/gecko-sdk/dom/include"
-)
+project.includes.append(
-+ "/usr/local/include/nspr",
-+ "/usr/local/include/firefox",
-+ "/usr/local/include/firefox/java",
-+ "/usr/local/include/firefox/xpcom",
-+ "/usr/local/include/firefox/plugin",
-+ "/usr/local/include/firefox/windowwatcher",
-+ "/usr/local/include/firefox/string",
-+ "/usr/local/include/firefox/uconv",
-+ "/usr/local/include/firefox/dom"
++ "%%GECKO_PREFIX%%/include/nspr",
++ "%%GECKO_PREFIX%%/include/%%GECKO%%",
++ "%%GECKO_PREFIX%%/include/%%GECKO%%/java",
++ "%%GECKO_PREFIX%%/include/%%GECKO%%/xpcom",
++ "%%GECKO_PREFIX%%/include/%%GECKO%%/plugin",
++ "%%GECKO_PREFIX%%/include/%%GECKO%%/windowwatcher",
++ "%%GECKO_PREFIX%%/include/%%GECKO%%/string",
++ "%%GECKO_PREFIX%%/include/%%GECKO%%/uconv",
++ "%%GECKO_PREFIX%%/include/%%GECKO%%/dom"
+)
--- player/app/plugin/hxbackend.h Mon Nov 22 19:24:25 2004
diff --git a/multimedia/helixplayer/pkg-plist b/multimedia/helixplayer/pkg-plist
index 5f7802bc9b49..1dadb7ef065c 100644
--- a/multimedia/helixplayer/pkg-plist
+++ b/multimedia/helixplayer/pkg-plist
@@ -8,8 +8,8 @@ HelixPlayer/hxplay
HelixPlayer/hxplay.bin
HelixPlayer/lib/libgtkhx.so
HelixPlayer/lib/libgtkhx.so.0
-HelixPlayer/mozilla/nphelix.so
-HelixPlayer/mozilla/nphelix.xpt
+%%PLUGIN%%HelixPlayer/mozilla/nphelix.so
+%%PLUGIN%%HelixPlayer/mozilla/nphelix.xpt
HelixPlayer/plugins/audplin.so
HelixPlayer/plugins/aufformat.so
HelixPlayer/plugins/authmgr.so
@@ -22,7 +22,7 @@ HelixPlayer/plugins/hxsdp.so
HelixPlayer/plugins/hxxml.so
HelixPlayer/plugins/jpgfformat.so
HelixPlayer/plugins/jpgrender.so
-HelixPlayer/plugins/memfsys.so
+%%PLUGIN%%HelixPlayer/plugins/memfsys.so
HelixPlayer/plugins/oggfformat.so
HelixPlayer/plugins/pcmrend.so
HelixPlayer/plugins/pngfformat.so
@@ -184,7 +184,7 @@ share/applications/hxplay.desktop
@dirrm HelixPlayer/share
@dirrm HelixPlayer/postinst
@dirrm HelixPlayer/plugins
-@dirrm HelixPlayer/mozilla
+%%PLUGIN%%@dirrm HelixPlayer/mozilla
@dirrm HelixPlayer/lib
@dirrm HelixPlayer/doc
@dirrm HelixPlayer/common