aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-03-12 10:15:27 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-03-12 10:15:27 +0000
commitb5196a4a4841cb87cd2989f0cfc77d78603efa3d (patch)
treede21437fad008659d9fdbb6720c0667d3f3731ad /multimedia
parentfd299125d26e7b8426b0b77b85fc3413206cca77 (diff)
downloadports-b5196a4a4841cb87cd2989f0cfc77d78603efa3d.tar.gz
ports-b5196a4a4841cb87cd2989f0cfc77d78603efa3d.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/phonon-xine/Makefile4
-rw-r--r--multimedia/phonon-xine/files/patch-xine__CMakeLists.txt13
-rw-r--r--multimedia/phonon-xine/files/patch-xine__kequalizer_plugin.cpp21
-rw-r--r--multimedia/phonon-xine/files/patch-xine__mediaobject.cpp11
4 files changed, 44 insertions, 5 deletions
diff --git a/multimedia/phonon-xine/Makefile b/multimedia/phonon-xine/Makefile
index 778705324aee..641f11ff8661 100644
--- a/multimedia/phonon-xine/Makefile
+++ b/multimedia/phonon-xine/Makefile
@@ -6,7 +6,7 @@
PORTNAME= phonon
PORTVERSION= 4.4.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${PHONON_BRANCH}/${PORTNAME}/${PORTNAME}-backend${PKGNAMESUFFIX}/${PORTVERSION}/src
@@ -31,8 +31,6 @@ QT_COMPONENTS= gui dbus xml phonon \
PLIST_SUB+= QT_PREFIX=${QT_PREFIX}
-BROKEN= deprecated upstream; refuses to build with libxine 1.2.x
-
pre-su-install:
${MKDIR} ${QT_PLUGINDIR}/phonon_backend
diff --git a/multimedia/phonon-xine/files/patch-xine__CMakeLists.txt b/multimedia/phonon-xine/files/patch-xine__CMakeLists.txt
index 7d0b44f9f3a7..d4f7ddb3ec8d 100644
--- a/multimedia/phonon-xine/files/patch-xine__CMakeLists.txt
+++ b/multimedia/phonon-xine/files/patch-xine__CMakeLists.txt
@@ -1,5 +1,14 @@
---- ./xine/CMakeLists.txt.orig 2009-01-08 17:47:18.000000000 +0300
-+++ ./xine/CMakeLists.txt 2009-02-21 01:19:39.000000000 +0300
+--- ./xine/CMakeLists.txt.orig 2011-01-19 20:20:53.000000000 +0100
++++ ./xine/CMakeLists.txt 2012-03-12 11:12:12.244132405 +0100
+@@ -42,7 +42,7 @@
+ endif(XINE_BUGFIX_VERSION LESS 9)
+ endif(XINE_BUGFIX_VERSION LESS 7)
+ else(XINE_MINOR_VERSION LESS 2 AND XINE_BUGFIX_VERSION LESS 90)
+- message(FATAL_ERROR "xine-lib v${XINE_VERSION} was found on your system. This version contains major changes compared to 1.1.x and has not been tested properly for use with this backend. Consider downgrading to version 1.1.9." "http://sourceforge.net/project/showfiles.php?group_id=9655&package_id=9732")
++# message(FATAL_ERROR "xine-lib v${XINE_VERSION} was found on your system. This version contains major changes compared to 1.1.x and has not been tested properly for use with this backend. Consider downgrading to version 1.1.9." "http://sourceforge.net/project/showfiles.php?group_id=9655&package_id=9732")
+ endif(XINE_MINOR_VERSION LESS 2 AND XINE_BUGFIX_VERSION LESS 90)
+
+ set(phonon_xine_SRCS
@@ -88,9 +88,7 @@
SET(XINEWIDGET_FOUND FALSE)
endif(XCB_FOUND)
diff --git a/multimedia/phonon-xine/files/patch-xine__kequalizer_plugin.cpp b/multimedia/phonon-xine/files/patch-xine__kequalizer_plugin.cpp
new file mode 100644
index 000000000000..c3694c87c3a4
--- /dev/null
+++ b/multimedia/phonon-xine/files/patch-xine__kequalizer_plugin.cpp
@@ -0,0 +1,21 @@
+--- ./xine/kequalizer_plugin.cpp.orig 2011-01-19 20:20:53.000000000 +0100
++++ ./xine/kequalizer_plugin.cpp 2012-03-12 11:12:12.244132405 +0100
+@@ -48,6 +48,9 @@
+ #include <xine/xineutils.h>
+ #undef this
+
++#include <libavutil/mem.h>
++
++
+ #define KEQUALIZER_MAX_GAIN 12.0
+ #define KEQUALIZER_L 2 // Storage for filter taps
+ #define KEQUALIZER_KM 10 // Max number of bands
+@@ -281,7 +284,7 @@
+ Q_UNUSED(video_target);
+ kequalizer_plugin_t *that;
+ //deprecated: kequalizer_plugin_t *that = static_cast<kequalizer_plugin_t *>(xine_xmalloc(sizeof(kequalizer_plugin_t)));
+- xine_xmalloc_aligned(2,sizeof(kequalizer_plugin_t),(void**)(&that));
++ that = (kequalizer_plugin_t *)av_mallocz(sizeof(kequalizer_plugin_t));
+ post_in_t *input;
+ post_out_t *output;
+ xine_post_in_t *input_api;
diff --git a/multimedia/phonon-xine/files/patch-xine__mediaobject.cpp b/multimedia/phonon-xine/files/patch-xine__mediaobject.cpp
new file mode 100644
index 000000000000..02395ea8ec70
--- /dev/null
+++ b/multimedia/phonon-xine/files/patch-xine__mediaobject.cpp
@@ -0,0 +1,11 @@
+--- ./xine/mediaobject.cpp.orig 2011-01-19 20:20:53.000000000 +0100
++++ ./xine/mediaobject.cpp 2012-03-12 11:12:12.254129363 +0100
+@@ -443,7 +443,7 @@
+ const int lastSize = m_titles.size();
+ m_titles.clear();
+ int num = 0;
+- char **mrls = xine_get_autoplay_mrls(m_stream->xine(), plugin, &num);
++ const char * const *mrls = xine_get_autoplay_mrls(m_stream->xine(), plugin, &num);
+ for (int i = 0; i < num; ++i) {
+ if (mrls[i]) {
+ debug() << Q_FUNC_INFO << mrls[i];