aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-08 14:31:36 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-08 14:31:36 +0000
commitbfc87f8f4fd8ea2c88794fe6b47fd0c245442deb (patch)
tree3ebbbe33f6e516f69911431e9fac3965d50865e5 /multimedia
parent48320035775440378dcfeabae22fc6b94e94b2d3 (diff)
downloadports-bfc87f8f4fd8ea2c88794fe6b47fd0c245442deb.tar.gz
ports-bfc87f8f4fd8ea2c88794fe6b47fd0c245442deb.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/xtheater/Makefile33
-rw-r--r--multimedia/xtheater/distinfo1
-rw-r--r--multimedia/xtheater/files/patch-smpeg::Makefile.in11
-rw-r--r--multimedia/xtheater/pkg-comment1
-rw-r--r--multimedia/xtheater/pkg-descr6
-rw-r--r--multimedia/xtheater/pkg-plist13
6 files changed, 65 insertions, 0 deletions
diff --git a/multimedia/xtheater/Makefile b/multimedia/xtheater/Makefile
new file mode 100644
index 000000000000..4e66a2e738cf
--- /dev/null
+++ b/multimedia/xtheater/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: xtheater
+# Date created: Jun 7, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xtheater
+PORTVERSION= 1.0.0p1
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= Xtheater-${PORTVERSION:S/p/-pre/}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12 \
+ smpeg:${PORTSDIR}/graphics/smpeg \
+ aviplay:${PORTSDIR}/graphics/avifile
+
+USE_BZIP2= yes
+USE_XLIB= yes
+USE_GTK= yes
+USE_MESA= yes
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
+ CPPFLAGS="${CXXFLAGS} -I${LOCALBASE} ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE} ${PTHREAD_LIBS}"
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/multimedia/xtheater/distinfo b/multimedia/xtheater/distinfo
new file mode 100644
index 000000000000..47565926b2e2
--- /dev/null
+++ b/multimedia/xtheater/distinfo
@@ -0,0 +1 @@
+MD5 (Xtheater-1.0.0-pre1.tar.bz2) = b44c7eb4d33d9672296cf8ce3fa1275a
diff --git a/multimedia/xtheater/files/patch-smpeg::Makefile.in b/multimedia/xtheater/files/patch-smpeg::Makefile.in
new file mode 100644
index 000000000000..18c27a29bce0
--- /dev/null
+++ b/multimedia/xtheater/files/patch-smpeg::Makefile.in
@@ -0,0 +1,11 @@
+--- plugins/player/smpeg/Makefile.in.orig Sat Jun 8 02:47:41 2002
++++ plugins/player/smpeg/Makefile.in Sat Jun 8 02:47:57 2002
+@@ -94,7 +94,7 @@
+ @USE_GL_TRUE@GL_LIBS = -lGL -lGLU
+ @USE_GL_FALSE@GL_LIBS =
+ LIBS = $(SMPEG_LIBS) $(GL_LIBS)
+-INCLUDES = -I.. $(SMPEG_CFLAGS) $(GLIB_CFLAGS)
++INCLUDES = -I.. $(SMPEG_CFLAGS) $(GLIB_CFLAGS) -I${X11BASE}/include
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../../../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/multimedia/xtheater/pkg-comment b/multimedia/xtheater/pkg-comment
new file mode 100644
index 000000000000..37c9b0d73aeb
--- /dev/null
+++ b/multimedia/xtheater/pkg-comment
@@ -0,0 +1 @@
+MPEG-1 player in GTK+ capable of playing MPEG-1 format streams
diff --git a/multimedia/xtheater/pkg-descr b/multimedia/xtheater/pkg-descr
new file mode 100644
index 000000000000..dcdd995b2fb1
--- /dev/null
+++ b/multimedia/xtheater/pkg-descr
@@ -0,0 +1,6 @@
+Xtheater is a Media Player for linux capable of playing MPEG video and audio
+files, network streams, and VCDs, as well as AVI and ASF files. It tries to
+keep things simple and straightforward to provide the simplest, most stable
+behavior as possilbe, while at the same time offering a nice featureset.
+
+WWW: http://xtheater.sourceforge.net/
diff --git a/multimedia/xtheater/pkg-plist b/multimedia/xtheater/pkg-plist
new file mode 100644
index 000000000000..537163bc4163
--- /dev/null
+++ b/multimedia/xtheater/pkg-plist
@@ -0,0 +1,13 @@
+bin/xtheater
+Xtheater/player/libsmpeg-1.0.0-pre1.so
+Xtheater/player/libsmpeg.a
+Xtheater/player/libsmpeg.la
+Xtheater/player/libsmpeg.so
+Xtheater/ui/libgtkui-1.0.0-pre1.so
+Xtheater/ui/libgtkui.a
+Xtheater/ui/libgtkui.la
+Xtheater/ui/libgtkui.so
+Xtheater/config
+@dirrm Xtheater/player
+@dirrm Xtheater/ui
+@dirrm Xtheater