aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /multimedia
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/audacious-plugins/Makefile3
-rw-r--r--multimedia/gnome-mplayer/Makefile4
-rw-r--r--multimedia/ogmrip/Makefile3
-rw-r--r--multimedia/ogmrip/files/patch-src_ogmrip-progress-dialog.c13
-rw-r--r--multimedia/vlc/Makefile5
-rw-r--r--multimedia/xfce4-parole/Makefile4
6 files changed, 24 insertions, 8 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index a5ab41560c9c..2f230acbe538 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -7,6 +7,7 @@
PORTNAME= audacious-plugins
PORTVERSION= 2.5.4
+PORTREVISION= 1
CATEGORIES= multimedia audio
MASTER_SITES= http://distfiles.atheme.org/
@@ -80,7 +81,7 @@ CONFIGURE_ARGS+=--disable-sdlout
.endif
.if defined(WITH_NOTIFY) || exists(${LOCALBASE}/lib/libnotify.so.1)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--enable-notify
PLIST_SUB+= NOTIFY=""
.else
diff --git a/multimedia/gnome-mplayer/Makefile b/multimedia/gnome-mplayer/Makefile
index 07ed73a7145b..58c5b639076f 100644
--- a/multimedia/gnome-mplayer/Makefile
+++ b/multimedia/gnome-mplayer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnome-mplayer
PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia gnome
MASTER_SITES= GOOGLE_CODE
@@ -56,7 +56,7 @@ CONFIGURE_ARGS+= --without-gconf --disable-schemas-install
.endif
.if defined(WITH_NOTIFY)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
RUN_DEPENDS+= ${LOCALBASE}/libexec/notification-daemon:${PORTSDIR}/deskutils/notification-daemon
CONFIGURE_ARGS+= --with-libnotify
.else
diff --git a/multimedia/ogmrip/Makefile b/multimedia/ogmrip/Makefile
index 64ccd40df14c..ad3b4af9a107 100644
--- a/multimedia/ogmrip/Makefile
+++ b/multimedia/ogmrip/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ogmrip
PORTVERSION= 0.13.6
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}
@@ -57,7 +58,7 @@ PLIST_SUB+= GUI_SUPPORT="@comment "
CONFIGURE_ARGS+= --enable-gtk-support --enable-dbus-support \
--enable-libnotify-support
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
USE_GNOME+= gconf2 libglade2
GCONF_SCHEMAS= ogmrip.schemas
PLIST_SUB+= GUI_SUPPORT=""
diff --git a/multimedia/ogmrip/files/patch-src_ogmrip-progress-dialog.c b/multimedia/ogmrip/files/patch-src_ogmrip-progress-dialog.c
new file mode 100644
index 000000000000..263b4226554d
--- /dev/null
+++ b/multimedia/ogmrip/files/patch-src_ogmrip-progress-dialog.c
@@ -0,0 +1,13 @@
+--- src/ogmrip-progress-dialog.c.orig 2011-08-12 13:44:15.000000000 +0200
++++ src/ogmrip-progress-dialog.c 2011-08-12 14:16:35.000000000 +0200
+@@ -418,8 +418,8 @@ ogmrip_progress_dialog_init (OGMRipProgr
+ g_signal_connect_swapped (dialog->priv->status_icon, "popup_menu",
+ G_CALLBACK (ogmrip_progress_dialog_status_icon_popup_menu), dialog);
+
+- dialog->priv->notification = notify_notification_new_with_status_icon ("Dummy", "Dummy",
+- OGMRIP_DATA_DIR G_DIR_SEPARATOR_S OGMRIP_ICON_FILE, dialog->priv->status_icon);
++ dialog->priv->notification = notify_notification_new ("Dummy", "Dummy",
++ OGMRIP_DATA_DIR G_DIR_SEPARATOR_S OGMRIP_ICON_FILE);
+ g_signal_connect (dialog, "window-state-event",
+ G_CALLBACK (ogmrip_progress_dialog_state_changed), NULL);
+
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 7820c0d053a0..85bb802ce561 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vlc
DISTVERSION= 1.1.11
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION}/ \
@@ -21,7 +22,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
gcrypt.18:${PORTSDIR}/security/libgcrypt \
- proxy.0:${PORTSDIR}/net/libproxy
+ proxy.1:${PORTSDIR}/net/libproxy
OPTIONS= A52 "A52 DVD audio decoder" On \
AALIB "Aalib Console Graphics Support" Off \
@@ -454,7 +455,7 @@ USE_GETTEXT= yes
.if defined(WITH_NOTIFY)
CONFIGURE_ARGS+=--enable-notify
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
.else
CONFIGURE_ARGS+=--disable-notify
.endif
diff --git a/multimedia/xfce4-parole/Makefile b/multimedia/xfce4-parole/Makefile
index d6dabf9258a9..4458a4a599aa 100644
--- a/multimedia/xfce4-parole/Makefile
+++ b/multimedia/xfce4-parole/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfce4-parole
PORTVERSION= 0.2.0.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=/src/apps/parole/0.2
@@ -20,7 +20,7 @@ COMMENT= Lightweight media player for Xfce4 based on the gstreamer engine
DATADIR= ${PREFIX}/share/${PORTNAME:S/xfce4-//}
LIB_DEPENDS= tag.1:${PORTSDIR}/audio/taglib \
- notify.1:${PORTSDIR}/devel/libnotify \
+ notify.4:${PORTSDIR}/devel/libnotify \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
USE_AUTOTOOLS= libtool