aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-04-24 18:10:30 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-04-24 18:10:30 +0000
commite1598249298974c6e8c61c34d927acabee345542 (patch)
tree5883afe298a5f232e854b104fc944ca19c4f7e7f /multimedia
parent422e3bda8bd3eb5d0b4737e335fd434883fbc44f (diff)
downloadports-e1598249298974c6e8c61c34d927acabee345542.tar.gz
ports-e1598249298974c6e8c61c34d927acabee345542.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/arista/Makefile2
-rw-r--r--multimedia/audacious-plugins/Makefile2
-rw-r--r--multimedia/audacious/Makefile2
-rw-r--r--multimedia/banshee/Makefile2
-rw-r--r--multimedia/bmp-extra-plugins/Makefile2
-rw-r--r--multimedia/cheese/Makefile2
-rw-r--r--multimedia/dvdrip/Makefile2
-rw-r--r--multimedia/freevo/Makefile2
-rw-r--r--multimedia/gaupol/Makefile2
-rw-r--r--multimedia/gnome-mplayer/Makefile2
-rw-r--r--multimedia/gnome-subtitles/Makefile2
-rw-r--r--multimedia/gopchop/Makefile2
-rw-r--r--multimedia/gpodder/Makefile2
-rw-r--r--multimedia/gtk-recordmydesktop/Makefile2
-rw-r--r--multimedia/gxmms/Makefile2
-rw-r--r--multimedia/k9copy/Makefile2
-rw-r--r--multimedia/kplayer/Makefile2
-rw-r--r--multimedia/miro/Makefile2
-rw-r--r--multimedia/openshot/Makefile2
-rw-r--r--multimedia/photofilmstrip/Makefile2
-rw-r--r--multimedia/pyjama/Makefile2
-rw-r--r--multimedia/quodlibet/Makefile2
-rw-r--r--multimedia/swfdec-gnome/Makefile2
-rw-r--r--multimedia/transkode/Makefile2
-rw-r--r--multimedia/w_scan/Makefile2
-rw-r--r--multimedia/xfce4-xmms-plugin/Makefile2
-rw-r--r--multimedia/xine/Makefile4
-rw-r--r--multimedia/xmms/Makefile2
28 files changed, 29 insertions, 29 deletions
diff --git a/multimedia/arista/Makefile b/multimedia/arista/Makefile
index f74eeea1175b..65ab065022ce 100644
--- a/multimedia/arista/Makefile
+++ b/multimedia/arista/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= http://programmer-art.org/media/releases/arista-transcoder/ \
MAINTAINER= swills@FreeBSD.org
COMMENT= An easy to use multimedia transcoder for the GNOME Desktop
-USE_GETTEXT= yes
+USES= gettext
USE_GSTREAMER= faac x264 lame mpeg2enc
USE_GNOME= pygnomedesktop
USE_PYTHON= yes
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index 5d401ebdf8c7..1621a3ae71bd 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -324,7 +324,7 @@ PLIST_SUB+= GIOPLUGIN="@comment "
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
.else
diff --git a/multimedia/audacious/Makefile b/multimedia/audacious/Makefile
index 0cbd93f562c1..d3ebe94d93e8 100644
--- a/multimedia/audacious/Makefile
+++ b/multimedia/audacious/Makefile
@@ -57,7 +57,7 @@ USE_ICONV= yes
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
.else
diff --git a/multimedia/banshee/Makefile b/multimedia/banshee/Makefile
index 991699aee1a5..48300951105f 100644
--- a/multimedia/banshee/Makefile
+++ b/multimedia/banshee/Makefile
@@ -53,7 +53,7 @@ CONFIGURE_ARGS= --with-vendor-build-id=FreeBSD\ BSD\#\ Project --disable-gio-har
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/multimedia/bmp-extra-plugins/Makefile b/multimedia/bmp-extra-plugins/Makefile
index aa9d6704bbbb..1bf745650734 100644
--- a/multimedia/bmp-extra-plugins/Makefile
+++ b/multimedia/bmp-extra-plugins/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= beep.2:${PORTSDIR}/multimedia/beep-media-player \
artsc.0:${PORTSDIR}/audio/arts
USE_GNOME= libglade2 esound
-USE_GETTEXT= yes
+USES= gettext
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/multimedia/cheese/Makefile b/multimedia/cheese/Makefile
index 42a98f3e04a1..ac0fb81a40a2 100644
--- a/multimedia/cheese/Makefile
+++ b/multimedia/cheese/Makefile
@@ -25,7 +25,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix intlhack evolutiondataserver librsvg2 \
gnomedocutils gnomedesktop
-USE_GETTEXT= yes
+USES= gettext
USE_GSTREAMER= gconf good ogg theora v4l2 vorbis
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
diff --git a/multimedia/dvdrip/Makefile b/multimedia/dvdrip/Makefile
index 15e3006008a4..abf8d26e5e91 100644
--- a/multimedia/dvdrip/Makefile
+++ b/multimedia/dvdrip/Makefile
@@ -35,7 +35,7 @@ SUBTITLE_DESC= Enable support for getting subtitles
PERL_CONFIGURE= yes
CONFIGURE_ENV= SKIP_UNPACK_REQUIRED_MODULES=1
USE_CDRTOOLS= yes
-USE_GETTEXT= yes
+USES= gettext
MAKE_JOBS_UNSAFE= yes
MAN1= dvdrip.1 dvdrip-progress.1 dvdrip-splitpipe.1
diff --git a/multimedia/freevo/Makefile b/multimedia/freevo/Makefile
index 3833fd0a79c1..8892a14c1816 100644
--- a/multimedia/freevo/Makefile
+++ b/multimedia/freevo/Makefile
@@ -57,7 +57,7 @@ DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
.if defined(WITHOUT_NLS)
PLIST_SUB+= NLS="@comment "
.else
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.endif
diff --git a/multimedia/gaupol/Makefile b/multimedia/gaupol/Makefile
index c186c5d58331..986ecb69aea3 100644
--- a/multimedia/gaupol/Makefile
+++ b/multimedia/gaupol/Makefile
@@ -29,7 +29,7 @@ INSTALLS_ICONS= yes
MAN1= ${PORTNAME}.1
.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
diff --git a/multimedia/gnome-mplayer/Makefile b/multimedia/gnome-mplayer/Makefile
index c8a7e2cb4679..1046bf5be8d9 100644
--- a/multimedia/gnome-mplayer/Makefile
+++ b/multimedia/gnome-mplayer/Makefile
@@ -83,7 +83,7 @@ CONFIGURE_ARGS+= --enable-nautilus=no
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
.else
diff --git a/multimedia/gnome-subtitles/Makefile b/multimedia/gnome-subtitles/Makefile
index 6c238be7b327..8c34efcf9521 100644
--- a/multimedia/gnome-subtitles/Makefile
+++ b/multimedia/gnome-subtitles/Makefile
@@ -36,7 +36,7 @@ USE_LDCONFIG= ${PREFIX}/lib/gnome-subtitles
MAN1= gnome-subtitles.1
.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/multimedia/gopchop/Makefile b/multimedia/gopchop/Makefile
index 2077253b37f8..ac9c24391ad5 100644
--- a/multimedia/gopchop/Makefile
+++ b/multimedia/gopchop/Makefile
@@ -32,7 +32,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.else
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.endif
diff --git a/multimedia/gpodder/Makefile b/multimedia/gpodder/Makefile
index ae4f7488aee8..d7991949e408 100644
--- a/multimedia/gpodder/Makefile
+++ b/multimedia/gpodder/Makefile
@@ -28,7 +28,7 @@ OPTIONS_EXCLUDE=NLS
ALL_TARGET= messages
MAKE_ENV= GPODDER_MANPATH_NO_SHARE="yes"
MAKEFILE= makefile
-USE_GETTEXT= yes
+USES= gettext
USE_GMAKE= yes
USE_PYTHON= -2.7
WANT_GNOME= yes
diff --git a/multimedia/gtk-recordmydesktop/Makefile b/multimedia/gtk-recordmydesktop/Makefile
index 277190760fad..d6713b7edb25 100644
--- a/multimedia/gtk-recordmydesktop/Makefile
+++ b/multimedia/gtk-recordmydesktop/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/recordmydesktop:${PORTSDIR}/multimedia/recordmydes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_PYTHON= -2.7
diff --git a/multimedia/gxmms/Makefile b/multimedia/gxmms/Makefile
index 22b5aff170f2..96f0ba97fdb2 100644
--- a/multimedia/gxmms/Makefile
+++ b/multimedia/gxmms/Makefile
@@ -12,7 +12,7 @@ COMMENT= Simple GNOME panel applet for controlling XMMS
USE_GMAKE= yes
USE_GNOME= gnomehack gnomepanel gnomeprefix intlhack libgnomeui
-USE_GETTEXT= yes
+USES= gettext
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="`pkg-config --libs libgnomeui-2.0`"
CPPFLAGS+= -I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`
diff --git a/multimedia/k9copy/Makefile b/multimedia/k9copy/Makefile
index 2410eb97042a..5e09f0e2db4b 100644
--- a/multimedia/k9copy/Makefile
+++ b/multimedia/k9copy/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools \
USE_KDELIBS_VER=3
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-USE_GETTEXT= yes
+USES= gettext
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
diff --git a/multimedia/kplayer/Makefile b/multimedia/kplayer/Makefile
index ed4803525626..627153133880 100644
--- a/multimedia/kplayer/Makefile
+++ b/multimedia/kplayer/Makefile
@@ -24,7 +24,7 @@ EXPIRATION_DATE= 2013-07-01
USE_BZIP2= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
-USE_GETTEXT= yes
+USES= gettext
USE_PERL5_BUILD=yes
USE_AUTOTOOLS= automake:env autoconf:env libtool
diff --git a/multimedia/miro/Makefile b/multimedia/miro/Makefile
index 696155ecfa07..458ecd8d77bd 100644
--- a/multimedia/miro/Makefile
+++ b/multimedia/miro/Makefile
@@ -35,7 +35,7 @@ INSTALL_WRKSRC= ${WRKSRC}/linux
USE_GMAKE= yes
USE_GNOME= gconf2 gtk20
USE_GSTREAMER= python gconf
-USE_GETTEXT= yes
+USES= gettext
USE_PYTHON= 2.5+
USE_PYDISTUTILS= yes
USE_LDCONFIG= yes
diff --git a/multimedia/openshot/Makefile b/multimedia/openshot/Makefile
index 48633747d767..92adec7e65e4 100644
--- a/multimedia/openshot/Makefile
+++ b/multimedia/openshot/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= ffmpeg:${PORTSDIR}/multimedia/ffmpeg \
USE_GNOME= pygtk2 desktopfileutils
USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
-USE_GETTEXT= yes
+USES= gettext
INSTALLS_OMF= yes
MAN1= ${PORTNAME}.1 \
diff --git a/multimedia/photofilmstrip/Makefile b/multimedia/photofilmstrip/Makefile
index b6f2ef4f189e..bf82a50858a1 100644
--- a/multimedia/photofilmstrip/Makefile
+++ b/multimedia/photofilmstrip/Makefile
@@ -24,7 +24,7 @@ USE_PYTHON= yes
USE_WX= 2.8+
WX_COMPS= python:lib
WX_UNICODE= yes
-USE_GETTEXT= yes
+USES= gettext
ALL_TARGET= compile
PFSDIR= ${PYTHONPREFIX_SITELIBDIR}/${PORTNAME}
diff --git a/multimedia/pyjama/Makefile b/multimedia/pyjama/Makefile
index 19ce86f6abb0..2cf378c9dacb 100644
--- a/multimedia/pyjama/Makefile
+++ b/multimedia/pyjama/Makefile
@@ -21,7 +21,7 @@ NO_BUILD= yes
USE_PYTHON= 2.5+
USE_GSTREAMER= core good bad gnomevfs
USE_GNOME= pygtk2
-USE_GETTEXT= yes
+USES= gettext
LOCALES= bg ca da de en_GB es fr it pl
INSTDIR= ${PYTHON_SITELIBDIR}/${PORTNAME}
diff --git a/multimedia/quodlibet/Makefile b/multimedia/quodlibet/Makefile
index 5afac7be4c23..7cb87affd4f4 100644
--- a/multimedia/quodlibet/Makefile
+++ b/multimedia/quodlibet/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mutagen/__init__.py:${PORTSDIR}/audio/py-mutag
USE_PYTHON= 2.5+
USE_GNOME= pygtk2
-USE_GETTEXT= yes
+USES= gettext
USE_PYDISTUTILS= yes
USE_DISPLAY= yes
USE_GSTREAMER= gconf good python
diff --git a/multimedia/swfdec-gnome/Makefile b/multimedia/swfdec-gnome/Makefile
index bdca88a95368..c27ad3ce4eb4 100644
--- a/multimedia/swfdec-gnome/Makefile
+++ b/multimedia/swfdec-gnome/Makefile
@@ -22,7 +22,7 @@ USE_GNOME= gnomehack gnomeprefix gtk20 intlhack gconf2
USE_BZIP2= yes
INSTALLS_ICONS= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/multimedia/transkode/Makefile b/multimedia/transkode/Makefile
index 526258a7d5f2..f48fb7aa33d7 100644
--- a/multimedia/transkode/Makefile
+++ b/multimedia/transkode/Makefile
@@ -26,7 +26,7 @@ USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5= yes
-USE_GETTEXT= yes
+USES= gettext
USE_AUTOTOOLS= libtool
INSTALLS_ICONS= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/multimedia/w_scan/Makefile b/multimedia/w_scan/Makefile
index ceaad1aa13b2..08596bd246d8 100644
--- a/multimedia/w_scan/Makefile
+++ b/multimedia/w_scan/Makefile
@@ -23,7 +23,7 @@ LINUX_DESC= Install Linux binary too (linux-w_scan)
USE_BZIP2= yes
GNU_CONFIGURE= yes
PATCH_STRIP= -lp1
-USE_GETTEXT= yes
+USES+= gettext
CPPFLAGS+= -I"${LOCALBASE}/include"
LDFLAGS+= -L"${LOCALBASE}/lib\ -liconv"
PORTDOCS= COPYING ChangeLog README
diff --git a/multimedia/xfce4-xmms-plugin/Makefile b/multimedia/xfce4-xmms-plugin/Makefile
index 4896624fcbbe..ac67b5b6eb95 100644
--- a/multimedia/xfce4-xmms-plugin/Makefile
+++ b/multimedia/xfce4-xmms-plugin/Makefile
@@ -14,7 +14,7 @@ COMMENT= Xfce4 XMMS control plugin for xfce4-panel
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
+USES= gettext
USE_GMAKE= yes
USE_GNOME= gtk20 intltool intlhack pango pkgconfig
USE_XFCE= configenv libgui libutil panel
diff --git a/multimedia/xine/Makefile b/multimedia/xine/Makefile
index 3806dd523563..73640aea6953 100644
--- a/multimedia/xine/Makefile
+++ b/multimedia/xine/Makefile
@@ -34,7 +34,7 @@ WIN32_CODECS_DESC= Enable win32 codecs
USE_XZ= yes
USE_XORG= x11 xext xinerama xscrnsaver xt xtst xv xxf86vm
-USE_GETTEXT= yes
+USES= gettext
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-vdr-keys \
@@ -66,7 +66,7 @@ CODEC_DETECTION_FILE!= ${MAKE} -f ${CODEC_PORT}/Makefile -V CODEC_DETECTION_FILE
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/multimedia/xmms/Makefile b/multimedia/xmms/Makefile
index e712e7300f04..05864728f556 100644
--- a/multimedia/xmms/Makefile
+++ b/multimedia/xmms/Makefile
@@ -17,7 +17,7 @@ USE_BZIP2= yes
USE_GL= gl
USE_GNOME= desktopfileutils gtk12 gnomehack
USE_GMAKE= yes
-USE_GETTEXT= yes
+USES= gettext
USE_ICONV= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= automake autoconf libtool