aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2008-10-27 12:37:18 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2008-10-27 12:37:18 +0000
commite1cd55d7700015a4b55d55374ec427d0b250645a (patch)
tree39e276cb08e09baea867db09cb6a66313a1a36e7 /multimedia
parent2c9117b75eee181909a0dca21cfa020381694a57 (diff)
downloadports-e1cd55d7700015a4b55d55374ec427d0b250645a.tar.gz
ports-e1cd55d7700015a4b55d55374ec427d0b250645a.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/banshee/Makefile7
-rw-r--r--multimedia/banshee/distinfo6
-rw-r--r--multimedia/banshee/files/patch-src_Core_Banshee.Core_Banshee.Collection_TrackInfo.cs29
-rw-r--r--multimedia/banshee/files/patch-svn-432134
-rw-r--r--multimedia/banshee/pkg-plist16
5 files changed, 18 insertions, 74 deletions
diff --git a/multimedia/banshee/Makefile b/multimedia/banshee/Makefile
index 2c22753bfc3f..c54aa62a9fdd 100644
--- a/multimedia/banshee/Makefile
+++ b/multimedia/banshee/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= banshee
-PORTVERSION= 1.2.1
-PORTREVISION= 2
+PORTVERSION= 1.3.3
CATEGORIES= multimedia audio
MASTER_SITES= http://download.banshee-project.org/banshee/
DISTNAME= ${PORTNAME}-1-${PORTVERSION}
@@ -63,13 +62,13 @@ PLIST_SUB+= OPT_MTP="@comment "
post-patch:
@${REINPLACE_CMD} 's|#!/bin/bash|#!/bin/sh|' \
- ${WRKSRC}/src/Clients/banshee-1.in \
+ ${WRKSRC}/src/Clients/Booter/banshee-1.in \
${WRKSRC}/build/icon-theme-installer \
${WRKSRC}/build/private-icon-theme-installer
@${REINPLACE_CMD} 's|\[\[|\[|g;s|\]\]|\]|g;s|==|=|g;s/||/-o/g' \
${WRKSRC}/build/private-icon-theme-installer
@${REINPLACE_CMD} 's|-a banshee-1||' \
- ${WRKSRC}/src/Clients/banshee-1.in
+ ${WRKSRC}/src/Clients/Booter/banshee-1.in
@${REINPLACE_CMD} 's|sed -r|sed -E|' \
${WRKSRC}/data/icon-theme-hicolor/Makefile.in
# ${WRKSRC}/configure \
diff --git a/multimedia/banshee/distinfo b/multimedia/banshee/distinfo
index e6a3fa93e92b..703508493678 100644
--- a/multimedia/banshee/distinfo
+++ b/multimedia/banshee/distinfo
@@ -1,3 +1,3 @@
-MD5 (banshee-1-1.2.1.tar.bz2) = 4537d105352b465049953f72da34d3d8
-SHA256 (banshee-1-1.2.1.tar.bz2) = b8380b52a8660b499605fbdee86d00e309a88c3bc822ba30b5b7521e16bec9c0
-SIZE (banshee-1-1.2.1.tar.bz2) = 2115306
+MD5 (banshee-1-1.3.3.tar.bz2) = bc7ce33597b5a1d1dd9529053522ee7d
+SHA256 (banshee-1-1.3.3.tar.bz2) = 7865850cd633caf780b55334c555f04ba7bfa4e8e014c1041783078d11bfa4a6
+SIZE (banshee-1-1.3.3.tar.bz2) = 2367812
diff --git a/multimedia/banshee/files/patch-src_Core_Banshee.Core_Banshee.Collection_TrackInfo.cs b/multimedia/banshee/files/patch-src_Core_Banshee.Core_Banshee.Collection_TrackInfo.cs
deleted file mode 100644
index ce82cc721c61..000000000000
--- a/multimedia/banshee/files/patch-src_Core_Banshee.Core_Banshee.Collection_TrackInfo.cs
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/Core/Banshee.Core/Banshee.Collection/TrackInfo.cs.orig 2008-09-11 09:01:14.000000000 +0800
-+++ src/Core/Banshee.Core/Banshee.Collection/TrackInfo.cs 2008-09-11 09:14:56.000000000 +0800
-@@ -356,17 +356,17 @@
-
- // Properties specified by the XMMS2 player spec
- dict.Add ("URI", Uri == null ? String.Empty : Uri.AbsoluteUri);
-- dict.Add ("length", Duration.TotalSeconds);
-- dict.Add ("name", TrackTitle);
-- dict.Add ("artist", ArtistName);
-- dict.Add ("album", AlbumTitle);
-+ dict.Add ("length", Duration == null ? 0 : Duration.TotalSeconds);
-+ dict.Add ("name", TrackTitle == null ? String.Empty : TrackTitle);
-+ dict.Add ("artist", ArtistName == null ? String.Empty : ArtistName);
-+ dict.Add ("album", AlbumTitle == null ? String.Empty : AlbumTitle);
-
- // Our own
-- dict.Add ("track-number", TrackNumber);
-- dict.Add ("track-count", TrackCount);
-- dict.Add ("disc", Disc);
-- dict.Add ("year", year);
-- dict.Add ("rating", rating);
-+ dict.Add ("track-number", TrackNumber == null ? 0 : TrackNumber);
-+ dict.Add ("track-count", TrackCount == null ? 0 : TrackCount);
-+ dict.Add ("disc", Disc == null ? 0 : Disc);
-+ dict.Add ("year", year == null ? 0 : year);
-+ dict.Add ("rating", rating == null ? 0 : rating);
-
- return dict;
- }
diff --git a/multimedia/banshee/files/patch-svn-4321 b/multimedia/banshee/files/patch-svn-4321
deleted file mode 100644
index 4f449e5bdee6..000000000000
--- a/multimedia/banshee/files/patch-svn-4321
+++ /dev/null
@@ -1,34 +0,0 @@
-Index: src/Extensions/Banshee.Lastfm/Banshee.Lastfm.Recommendations/RecommendationService.cs
-===================================================================
---- src/Extensions/Banshee.Lastfm/Banshee.Lastfm.Recommendations/RecommendationService.cs (revision 4321)
-+++ src/Extensions/Banshee.Lastfm/Banshee.Lastfm.Recommendations/RecommendationService.cs (working copy)
-@@ -110,7 +110,7 @@
-
- private void UpdateVisibility ()
- {
-- bool source_is_playback_source = (ServiceManager.SourceManager.ActiveSource == ServiceManager.PlaybackController.Source);
-+ bool source_is_playback_source = (ServiceManager.SourceManager.ActiveSource as Banshee.Sources.ITrackModelSource) == ServiceManager.PlaybackController.Source;
- pane.ShowWhenReady = ShowSchema.Get () && source_is_playback_source;
- if (!source_is_playback_source) {
- pane.HideWithTimeout ();
-Index: src/Libraries/Hyena/Hyena.Collections/QueuePipelineElement.cs
-===================================================================
---- src/Libraries/Hyena/Hyena.Collections/QueuePipelineElement.cs (revision 4321)
-+++ src/Libraries/Hyena/Hyena.Collections/QueuePipelineElement.cs (working copy)
-@@ -32,12 +32,12 @@
-
- namespace Hyena.Collections
- {
-+ internal class ElementProcessCanceledException : ApplicationException
-+ {
-+ }
-+
- public abstract class QueuePipelineElement<T> where T : class
- {
-- private class ElementProcessCanceledException : ApplicationException
-- {
-- }
--
- private Queue<T> queue = new Queue<T> ();
- private object monitor = new object ();
- private AutoResetEvent thread_wait;
diff --git a/multimedia/banshee/pkg-plist b/multimedia/banshee/pkg-plist
index 539ed146f437..3828959fe846 100644
--- a/multimedia/banshee/pkg-plist
+++ b/multimedia/banshee/pkg-plist
@@ -12,7 +12,10 @@ lib/banshee-1/Backends/Banshee.Unix.dll.mdb
lib/banshee-1/Backends/libbnpx11.a
lib/banshee-1/Backends/libbnpx11.la
lib/banshee-1/Backends/libbnpx11.so
+lib/banshee-1/Banshee.CollectionIndexer.dll
+lib/banshee-1/Banshee.CollectionIndexer.dll.mdb
lib/banshee-1/Banshee.Core.dll
+lib/banshee-1/Banshee.Core.dll.config
lib/banshee-1/Banshee.Core.dll.mdb
lib/banshee-1/Banshee.Services.addins
lib/banshee-1/Banshee.Services.dll
@@ -22,6 +25,10 @@ lib/banshee-1/Banshee.ThickClient.dll.mdb
lib/banshee-1/Banshee.Widgets.dll
lib/banshee-1/Banshee.Widgets.dll.config
lib/banshee-1/Banshee.Widgets.dll.mdb
+lib/banshee-1/Banshee.exe
+lib/banshee-1/Banshee.exe.mdb
+lib/banshee-1/Beroe.exe
+lib/banshee-1/Beroe.exe.mdb
lib/banshee-1/Extensions/Banshee.AudioCd.dll
lib/banshee-1/Extensions/Banshee.AudioCd.dll.mdb
lib/banshee-1/Extensions/Banshee.Bookmarks.dll
@@ -73,6 +80,8 @@ lib/banshee-1/Mono.Media.dll.mdb
%%OPT_MTP%%lib/banshee-1/Mtp.dll
%%OPT_MTP%%lib/banshee-1/Mtp.dll.config
%%OPT_MTP%%lib/banshee-1/Mtp.dll.mdb
+lib/banshee-1/Muinshee.exe
+lib/banshee-1/Muinshee.exe.mdb
lib/banshee-1/MusicBrainz.dll
lib/banshee-1/MusicBrainz.dll.mdb
lib/banshee-1/Nereid.exe
@@ -90,6 +99,7 @@ lib/banshee-1/libbanshee.so
%%PORTDOCS%%lib/monodoc/sources/hyena-docs.source
%%PORTDOCS%%lib/monodoc/sources/hyena-docs.tree
%%PORTDOCS%%lib/monodoc/sources/hyena-docs.zip
+libdata/pkgconfig/banshee-1-collection-indexer.pc
libdata/pkgconfig/banshee-1-core.pc
libdata/pkgconfig/banshee-1-hyena-gui.pc
libdata/pkgconfig/banshee-1-hyena.pc
@@ -108,7 +118,6 @@ share/banshee-1/audio-profiles/vorbis.xml
share/banshee-1/audio-profiles/wav.xml
share/banshee-1/audio-profiles/wavpack.xml
share/banshee-1/audio-profiles/wma.xml
-share/banshee-1/icons/hicolor/16x16/actions
share/banshee-1/icons/hicolor/16x16/actions/media-import-audio-cd.png
share/banshee-1/icons/hicolor/16x16/actions/media-repeat-all.png
share/banshee-1/icons/hicolor/16x16/actions/media-repeat-none.png
@@ -117,9 +126,7 @@ share/banshee-1/icons/hicolor/16x16/actions/media-write-cd.png
share/banshee-1/icons/hicolor/16x16/categories/podcast.png
share/banshee-1/icons/hicolor/16x16/categories/source-playlist.png
share/banshee-1/icons/hicolor/16x16/categories/source-smart-playlist.png
-share/banshee-1/icons/hicolor/16x16/status
share/banshee-1/icons/hicolor/16x16/status/podcast-new.png
-share/banshee-1/icons/hicolor/22x22/actions
share/banshee-1/icons/hicolor/22x22/actions/encode.png
share/banshee-1/icons/hicolor/22x22/actions/media-import-audio-cd.png
share/banshee-1/icons/hicolor/22x22/actions/media-write-cd.png
@@ -133,12 +140,12 @@ share/banshee-1/icons/hicolor/22x22/categories/radio.png
share/banshee-1/icons/hicolor/22x22/categories/source-playlist.png
share/banshee-1/icons/hicolor/22x22/categories/source-smart-playlist.png
share/banshee-1/icons/hicolor/32x32/actions/media-write-cd.png
-share/banshee-1/icons/hicolor/48x48/actions
share/banshee-1/icons/hicolor/48x48/actions/media-write-cd.png
share/banshee-1/icons/hicolor/48x48/categories/podcast.png
share/banshee-1/icons/hicolor/48x48/categories/radio.png
share/banshee-1/icons/hicolor/scalable/categories/radio.svg
share/dbus-1/services/org.bansheeproject.Banshee.service
+share/dbus-1/services/org.bansheeproject.CollectionIndexer.service
share/icons/hicolor/16x16/apps/media-player-banshee.png
share/icons/hicolor/192x192/apps/media-player-banshee.png
share/icons/hicolor/22x22/apps/media-player-banshee.png
@@ -159,6 +166,7 @@ share/locale/es/LC_MESSAGES/banshee-1.mo
share/locale/fi/LC_MESSAGES/banshee-1.mo
share/locale/fr/LC_MESSAGES/banshee-1.mo
share/locale/gl/LC_MESSAGES/banshee-1.mo
+share/locale/gu/LC_MESSAGES/banshee-1.mo
share/locale/he/LC_MESSAGES/banshee-1.mo
share/locale/hu/LC_MESSAGES/banshee-1.mo
share/locale/it/LC_MESSAGES/banshee-1.mo