aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-03-24 18:44:22 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-03-24 18:44:22 +0000
commit1f694edf29a3f2b16c4347fe4bc8fb6fe93cbd17 (patch)
tree849a95d9f13bac6d3ae051469c6fd673b6ddc99c /multimedia
parent5e1d93aa78bbd48edd9cad17158303ae7252fa84 (diff)
downloadports-1f694edf29a3f2b16c4347fe4bc8fb6fe93cbd17.tar.gz
ports-1f694edf29a3f2b16c4347fe4bc8fb6fe93cbd17.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ffmpeg-devel/Makefile3
-rw-r--r--multimedia/ffmpeg/Makefile3
-rw-r--r--multimedia/gmerlin-avdecoder/Makefile4
-rw-r--r--multimedia/schroedinger/Makefile47
-rw-r--r--multimedia/schroedinger/distinfo6
-rw-r--r--multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.c19
-rw-r--r--multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.h13
-rw-r--r--multimedia/schroedinger/pkg-descr.gstreamer3
-rw-r--r--multimedia/schroedinger/pkg-plist3
-rw-r--r--multimedia/vlc/Makefile2
10 files changed, 13 insertions, 90 deletions
diff --git a/multimedia/ffmpeg-devel/Makefile b/multimedia/ffmpeg-devel/Makefile
index 5b136f137369..cb4e656ceef2 100644
--- a/multimedia/ffmpeg-devel/Makefile
+++ b/multimedia/ffmpeg-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ffmpeg
DISTVERSION= 2009-08-12
+PORTREVISION= 1
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= http://people.freebsd.org/~mm/distfiles/
PKGNAMESUFFIX= -devel
@@ -226,7 +227,7 @@ CONFIGURE_ARGS+= --disable-libopenjpeg
# schroedinger
.ifndef(WITHOUT_SCHROEDINGER)
-LIB_DEPENDS+= schroedinger-1.0.2:${PORTSDIR}/multimedia/schroedinger
+LIB_DEPENDS+= schroedinger-1.0.3:${PORTSDIR}/multimedia/schroedinger
CONFIGURE_ARGS+= --enable-libschroedinger
.else
CONFIGURE_ARGS+= --disable-libschroedinger
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 19f532f13e9c..54c7cf87bc52 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -8,6 +8,7 @@
PORTNAME= ffmpeg
PORTVERSION= 0.5.1
PORTEPOCH= 1
+PORTREVISION= 1
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= http://ffmpeg.org/releases/
@@ -235,7 +236,7 @@ CONFIGURE_ARGS+= --disable-libopenjpeg
# schroedinger
.ifndef(WITHOUT_SCHROEDINGER)
-LIB_DEPENDS+= schroedinger-1.0.2:${PORTSDIR}/multimedia/schroedinger
+LIB_DEPENDS+= schroedinger-1.0.3:${PORTSDIR}/multimedia/schroedinger
CONFIGURE_ARGS+= --enable-libschroedinger
.else
CONFIGURE_ARGS+= --disable-libschroedinger
diff --git a/multimedia/gmerlin-avdecoder/Makefile b/multimedia/gmerlin-avdecoder/Makefile
index 556acc03b5d5..36ddf0d069ab 100644
--- a/multimedia/gmerlin-avdecoder/Makefile
+++ b/multimedia/gmerlin-avdecoder/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gmerlin-avdecoder
PORTVERSION= 1.0.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia
MASTER_SITES= SF/gmerlin/${PORTNAME}/${PORTVERSION}
@@ -184,7 +184,7 @@ CONFIGURE_ARGS+=--disable-openjpeg
.endif
.if !defined(WITHOUT_SCHROEDINGER)
-LIB_DEPENDS+= schroedinger-1.0.2:${PORTSDIR}/multimedia/schroedinger
+LIB_DEPENDS+= schroedinger-1.0.3:${PORTSDIR}/multimedia/schroedinger
.else
CONFIGURE_ARGS+=--disable-schroedinger
.endif
diff --git a/multimedia/schroedinger/Makefile b/multimedia/schroedinger/Makefile
index f3a48d7aff0b..39a209502a6c 100644
--- a/multimedia/schroedinger/Makefile
+++ b/multimedia/schroedinger/Makefile
@@ -5,67 +5,24 @@
# $FreeBSD$
#
-.if !defined(_BUILDING_GSTREAMER_PLUGIN)
PORTNAME= schroedinger
-.else
-PORTNAME= gstreamer
-.endif
-PORTVERSION= 1.0.7
-PORTREVISION= 2
+PORTVERSION= 1.0.9
CATEGORIES= multimedia
MASTER_SITES= http://diracvideo.org/download/schroedinger/
MASTER_SITE_SUBDIR= ${PORTNAME}
-.if defined(_BUILDING_GSTREAMER_PLUGIN)
-PKGNAMESUFFIX= -schroedinger
-DISTNAME= schroedinger-${PORTVERSION}
-.endif
MAINTAINER= mm@FreeBSD.org
-.if !defined(_BUILDING_GSTREAMER_PLUGIN)
COMMENT= High-speed Dirac codec
-.else
-COMMENT= GStreamer dirac plugin using Schroedinger library
-.endif
-LIB_DEPENDS= oil:${PORTSDIR}/devel/liboil
-.if defined(_BUILDING_GSTREAMER_PLUGIN)
-LIB_DEPENDS+= schroedinger-1.0.2:${PORTSDIR}/multimedia/schroedinger
-.endif
+LIB_DEPENDS= orc-0.4:${PORTSDIR}/devel/orc
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-.if defined(_BUILDING_GSTREAMER_PLUGIN)
-WANT_GSTREAMER= yes
-USE_GSTREAMER= yes
-BUILD_WRKSRC= ${WRKDIR}/${DISTNAME}/gst
-INSTALL_WRKSRC= ${BUILD_WRKSRC}
-PLIST= ${WRKSRC}/PLIST
-DESCR= ${MASTERDIR}/pkg-descr.gstreamer
-.else
-CONFIGURE_ARGS+= --disable-gstreamer
-.endif
-
.include <bsd.port.pre.mk>
-.if defined(_BUILDING_GSTREAMER_PLUGIN)
-PLIST_FILES+= lib/gstreamer-${GST_VERSION}/libgstschro.a \
- lib/gstreamer-${GST_VERSION}/libgstschro.la \
- lib/gstreamer-${GST_VERSION}/libgstschro.so
-.endif
-
post-patch:
${REINPLACE_CMD} -e 's|^pkgconfigdir=.*|pkgconfigdir="\\$$(prefix)/libdata/pkgconfig"|' ${WRKSRC}/configure
-.if defined(_BUILDING_GSTREAMER_PLUGIN)
-post-configure:
- ${REINPLACE_CMD} -e "s|\$$(top_builddir)/schroedinger/libschroedinger-1.0.la|${LOCALBASE}/lib/libschroedinger-1.0.la|g" \
- ${WRKSRC}/gst/Makefile
-
-pre-build:
- @cd ${WRKSRC}/gst-libs/gst/video && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} ${ALL_TARGET}
-
-.endif
-
.include <bsd.port.post.mk>
diff --git a/multimedia/schroedinger/distinfo b/multimedia/schroedinger/distinfo
index b25b2b3a3e8b..1c153253a9e3 100644
--- a/multimedia/schroedinger/distinfo
+++ b/multimedia/schroedinger/distinfo
@@ -1,3 +1,3 @@
-MD5 (schroedinger-1.0.7.tar.gz) = 9a1132c54a58a6a040514f754b53ee44
-SHA256 (schroedinger-1.0.7.tar.gz) = a1be06dbd7e996ea6034560fe8af5cd30ffdc4a1892d1f79a4262feee1c46b00
-SIZE (schroedinger-1.0.7.tar.gz) = 877696
+MD5 (schroedinger-1.0.9.tar.gz) = d67ec48b7c506db8c8b49156bf409e60
+SHA256 (schroedinger-1.0.9.tar.gz) = 345abcaa72ff0f2e9c1075e22f7141475ee4e6eea23a7f568b69ffc13cc1c723
+SIZE (schroedinger-1.0.9.tar.gz) = 937748
diff --git a/multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.c b/multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.c
deleted file mode 100644
index a0dd2a15164a..000000000000
--- a/multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- gst-libs/gst/video/gstbasevideoutils.c.orig 2009-08-08 11:53:34.000000000 +0200
-+++ gst-libs/gst/video/gstbasevideoutils.c 2009-08-08 11:53:58.000000000 +0200
-@@ -229,7 +229,7 @@ scan_slow (GstAdapter *adapter, GSList *
- return ((GST_READ_UINT32_BE (tmp) & mask) == pattern);
- }
-
--
-+/*
- int
- gst_adapter_masked_scan_uint32 (GstAdapter *adapter,
- guint32 pattern, guint32 mask, int offset, int n)
-@@ -271,6 +271,7 @@ gst_adapter_masked_scan_uint32 (GstAdapt
-
- return n;
- }
-+*/
-
- GstBuffer *
- gst_adapter_get_buffer (GstAdapter *adapter)
diff --git a/multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.h b/multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.h
deleted file mode 100644
index 79828d557c56..000000000000
--- a/multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- gst-libs/gst/video/gstbasevideoutils.h.orig 2009-08-08 11:53:39.000000000 +0200
-+++ gst-libs/gst/video/gstbasevideoutils.h 2009-08-08 11:54:07.000000000 +0200
-@@ -84,8 +84,10 @@ gboolean gst_base_video_state_from_caps
- GstClockTime gst_video_state_get_timestamp (const GstVideoState *state,
- int frame_number);
-
-+/*
- int gst_adapter_masked_scan_uint32 (GstAdapter *adapter,
- guint32 pattern, guint32 mask, int offset, int n);
-+*/
- GstBuffer *gst_adapter_get_buffer (GstAdapter *adapter);
-
- G_END_DECLS
diff --git a/multimedia/schroedinger/pkg-descr.gstreamer b/multimedia/schroedinger/pkg-descr.gstreamer
deleted file mode 100644
index bfcc45e5aa1e..000000000000
--- a/multimedia/schroedinger/pkg-descr.gstreamer
+++ /dev/null
@@ -1,3 +0,0 @@
-Dirac plugin for GStreamer using the Schroedinger library
-
-WWW: http://www.diracvideo.org/
diff --git a/multimedia/schroedinger/pkg-plist b/multimedia/schroedinger/pkg-plist
index 4d9dd0a298d5..ac440e61de2c 100644
--- a/multimedia/schroedinger/pkg-plist
+++ b/multimedia/schroedinger/pkg-plist
@@ -6,7 +6,6 @@ include/schroedinger-1.0/schroedinger/schroasync.h
include/schroedinger-1.0/schroedinger/schrobitstream.h
include/schroedinger-1.0/schroedinger/schrobuffer.h
include/schroedinger-1.0/schroedinger/schrobufferlist.h
-include/schroedinger-1.0/schroedinger/schrocog.h
include/schroedinger-1.0/schroedinger/schrodebug.h
include/schroedinger-1.0/schroedinger/schrodecoder.h
include/schroedinger-1.0/schroedinger/schrodomain.h
@@ -37,7 +36,7 @@ include/schroedinger-1.0/schroedinger/schrowavelet.h
lib/libschroedinger-1.0.a
lib/libschroedinger-1.0.la
lib/libschroedinger-1.0.so
-lib/libschroedinger-1.0.so.2
+lib/libschroedinger-1.0.so.3
libdata/pkgconfig/schroedinger-1.0.pc
share/gtk-doc/html/schroedinger/home.png
share/gtk-doc/html/schroedinger/index.html
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index b42f767e9798..9792b3e652aa 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -343,7 +343,7 @@ CONFIGURE_ARGS+=--disable-dirac
.endif
.if defined(WITH_SCHROEDINGER) && !defined(WITHOUT_SCHROEDINGER)
-LIB_DEPENDS+= schroedinger-1.0.2:${PORTSDIR}/multimedia/schroedinger
+LIB_DEPENDS+= schroedinger-1.0.3:${PORTSDIR}/multimedia/schroedinger
CONFIGURE_ARGS+=--enable-schroedinger
.else
CONFIGURE_ARGS+=--disable-schroedinger