aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-05-19 06:03:13 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-05-19 06:03:13 +0000
commit4273c62fcdba68c55cd5dde12083862e133c52ca (patch)
tree5c47c7048137facc07db04fb5e078f59111ff91a /multimedia
parent10c88cb46d18788b7a95489dfcb89575d882ba26 (diff)
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/subtitlecomposer-kde4/Makefile34
-rw-r--r--multimedia/subtitlecomposer/Makefile34
2 files changed, 56 insertions, 12 deletions
diff --git a/multimedia/subtitlecomposer-kde4/Makefile b/multimedia/subtitlecomposer-kde4/Makefile
index fbc449c7c4eb..561138afd2f2 100644
--- a/multimedia/subtitlecomposer-kde4/Makefile
+++ b/multimedia/subtitlecomposer-kde4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= subtitlecomposer
PORTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= SF
MASTER_SITE_SUBDIR=subcomposer
@@ -14,23 +15,44 @@ MASTER_SITE_SUBDIR=subcomposer
MAINTAINER= makc@issp.ac.ru
COMMENT= Subtitle editor for KDE
-RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
-
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
USE_KDELIBS_VER=3
+USE_XORG= xext
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-gstreamer
+WANT_GSTREAMER= yes
INSTALLS_ICONS= yes
-OPTIONS= XINE "Enable Xine backend" off
+OPTIONS= MPLAYER "Enable MPlayer backend (recommended)" on \
+ XINE "Enable Xine backend" off \
+ GSTREAMER "Enable GStreamer backend" off
.include <bsd.port.pre.mk>
+.if defined(WITH_MPLAYER)
+RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
+.endif
+
.if defined(WITH_XINE)
-LIB_DEPENDS+= xine.1:${PORTSDIR}/multimedia/libxine
+
+. if exists(${LOCALBASE}/bin/xine-config)
+XINE_PLUGINDIR!= ${LOCALBASE}/bin/xine-config --plugindir
+. endif
+
+. if defined(XINE_PLUGINDIR) && !exists(${XINE_PLUGINDIR}/xineplug_vo_out_xcbxv.so)
+IGNORE= needs XCB support in libxine
+. endif
+
+LIB_DEPENDS+= xine.1:${PORTSDIR}/multimedia/libxine \
+ xcb.1:${PORTSDIR}/x11/libxcb
.else
-CONFIGURE_ARGS+=--without-xine
+CONFIGURE_ARGS+=--without-xine --without-xcb
+.endif
+
+.if defined(WITH_GSTREAMER)
+USE_GSTREAMER+= yes
+.else
+CONFIGURE_ARGS= --without-gstreamer
.endif
.include <bsd.port.post.mk>
diff --git a/multimedia/subtitlecomposer/Makefile b/multimedia/subtitlecomposer/Makefile
index fbc449c7c4eb..561138afd2f2 100644
--- a/multimedia/subtitlecomposer/Makefile
+++ b/multimedia/subtitlecomposer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= subtitlecomposer
PORTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= SF
MASTER_SITE_SUBDIR=subcomposer
@@ -14,23 +15,44 @@ MASTER_SITE_SUBDIR=subcomposer
MAINTAINER= makc@issp.ac.ru
COMMENT= Subtitle editor for KDE
-RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
-
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
USE_KDELIBS_VER=3
+USE_XORG= xext
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-gstreamer
+WANT_GSTREAMER= yes
INSTALLS_ICONS= yes
-OPTIONS= XINE "Enable Xine backend" off
+OPTIONS= MPLAYER "Enable MPlayer backend (recommended)" on \
+ XINE "Enable Xine backend" off \
+ GSTREAMER "Enable GStreamer backend" off
.include <bsd.port.pre.mk>
+.if defined(WITH_MPLAYER)
+RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
+.endif
+
.if defined(WITH_XINE)
-LIB_DEPENDS+= xine.1:${PORTSDIR}/multimedia/libxine
+
+. if exists(${LOCALBASE}/bin/xine-config)
+XINE_PLUGINDIR!= ${LOCALBASE}/bin/xine-config --plugindir
+. endif
+
+. if defined(XINE_PLUGINDIR) && !exists(${XINE_PLUGINDIR}/xineplug_vo_out_xcbxv.so)
+IGNORE= needs XCB support in libxine
+. endif
+
+LIB_DEPENDS+= xine.1:${PORTSDIR}/multimedia/libxine \
+ xcb.1:${PORTSDIR}/x11/libxcb
.else
-CONFIGURE_ARGS+=--without-xine
+CONFIGURE_ARGS+=--without-xine --without-xcb
+.endif
+
+.if defined(WITH_GSTREAMER)
+USE_GSTREAMER+= yes
+.else
+CONFIGURE_ARGS= --without-gstreamer
.endif
.include <bsd.port.post.mk>