aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2011-04-30 19:08:36 +0000
committerJuergen Lock <nox@FreeBSD.org>2011-04-30 19:08:36 +0000
commit551fea4ca8232638928ed49d03c90d4007cf53ab (patch)
tree1a82b707ad6095122b1171d85313f54e4e69e2b6 /multimedia
parent68e3769cbc43a03eb868841257a30e079cf2fd22 (diff)
This plugin reads the <vdr-conf-path>/sources.conf and parses the coresponding transponderlist (.tpl file), then it scans this sat and updates/appends all found channels to the current channel list. WWW: http://www.reel-multimedia.com
Notes
Notes: svn path=/head/; revision=273378
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/vdr-plugin-reelchannelscan/Makefile38
-rw-r--r--multimedia/vdr-plugin-reelchannelscan/distinfo4
-rw-r--r--multimedia/vdr-plugin-reelchannelscan/files/patch-Makefile8
-rw-r--r--multimedia/vdr-plugin-reelchannelscan/files/patch-scan.c26
-rw-r--r--multimedia/vdr-plugin-reelchannelscan/pkg-descr8
-rw-r--r--multimedia/vdr-plugin-reelchannelscan/pkg-plist82
7 files changed, 167 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 737a16af7b11..64fcbddd22b1 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -343,6 +343,7 @@
SUBDIR += vdr-plugin-markad
SUBDIR += vdr-plugin-osdpip
SUBDIR += vdr-plugin-osdteletext
+ SUBDIR += vdr-plugin-reelchannelscan
SUBDIR += vdr-plugin-remote
SUBDIR += vdr-plugin-skinenigmang
SUBDIR += vdr-plugin-softdevice
diff --git a/multimedia/vdr-plugin-reelchannelscan/Makefile b/multimedia/vdr-plugin-reelchannelscan/Makefile
new file mode 100644
index 000000000000..4300aafeeb49
--- /dev/null
+++ b/multimedia/vdr-plugin-reelchannelscan/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: vdr-plugin-reelchannelscan
+# Date created: Fri Apr 29 17:44:18 CEST 2011
+# Whom: Juergen Lock <nox@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vdr-plugin-reelchannelscan
+PORTVERSION= 0.6.1b1.7.15
+CATEGORIES= multimedia
+MASTER_SITES= LOCAL/nox \
+ http://ppa.launchpad.net/yavdr/stable-vdr/ubuntu/pool/main/v/vdr-plugin-reelchannelscan/
+DISTFILES+= ${PORTNAME}_${DISTVERSIONPREFIX}${DISTVERSION:S/b/+beta/}${DISTVERSIONSUFFIX}.orig${EXTRACT_SUFX} \
+ ${PORTNAME}_${DISTVERSIONPREFIX}${DISTVERSION:S/b/+beta/}${DISTVERSIONSUFFIX}-27yavdr1.debian${EXTRACT_SUFX}
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= Video Disk Recorder - Reelchannelscan plugin
+
+PATCH_STRIP= -p1
+HAVE_CONFIGURE= yes
+PORTDOCS= COPYING README
+MAKE_JOBS_SAFE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:S/b1.7.15//}
+
+.include "${.CURDIR}/../vdr/Makefile.plugins"
+
+post-patch: post-patch-plugin
+
+post-install: post-install-pluginlocales
+ ${MKDIR} ${PREFIX}/etc/vdr/plugins/transponders
+ ${INSTALL_DATA} ${WRKDIR}/debian/transponders/*.tpl \
+ ${PREFIX}/etc/vdr/plugins/transponders
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/vdr-plugin-reelchannelscan/distinfo b/multimedia/vdr-plugin-reelchannelscan/distinfo
new file mode 100644
index 000000000000..1ab9e78a3886
--- /dev/null
+++ b/multimedia/vdr-plugin-reelchannelscan/distinfo
@@ -0,0 +1,4 @@
+SHA256 (vdr/vdr-plugin-reelchannelscan_0.6.1+beta1.7.15.orig.tar.gz) = 680a71e35674e3dd9408cec75edf2307e83fdf4615a9fdeabae4827087264da5
+SIZE (vdr/vdr-plugin-reelchannelscan_0.6.1+beta1.7.15.orig.tar.gz) = 82747
+SHA256 (vdr/vdr-plugin-reelchannelscan_0.6.1+beta1.7.15-27yavdr1.debian.tar.gz) = 881c928fa4aac4fe696a884210da52c3ab598f75d09564953565025322753e40
+SIZE (vdr/vdr-plugin-reelchannelscan_0.6.1+beta1.7.15-27yavdr1.debian.tar.gz) = 11972
diff --git a/multimedia/vdr-plugin-reelchannelscan/files/patch-Makefile b/multimedia/vdr-plugin-reelchannelscan/files/patch-Makefile
new file mode 100644
index 000000000000..0ccec398a86f
--- /dev/null
+++ b/multimedia/vdr-plugin-reelchannelscan/files/patch-Makefile
@@ -0,0 +1,8 @@
+--- a/Makefile
++++ b/Makefile
+@@ -141,3 +141,5 @@ clean:
+ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
+
++install:
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
diff --git a/multimedia/vdr-plugin-reelchannelscan/files/patch-scan.c b/multimedia/vdr-plugin-reelchannelscan/files/patch-scan.c
new file mode 100644
index 000000000000..70f6d1566ad0
--- /dev/null
+++ b/multimedia/vdr-plugin-reelchannelscan/files/patch-scan.c
@@ -0,0 +1,26 @@
+--- a/scan.c
++++ b/scan.c
+@@ -197,7 +197,7 @@ bool cScan::StartScanning(cScanParameter
+
+ #ifndef DEVICE_ATTRIBUTES
+ char buffer[265];
+- snprintf(buffer, sizeof(buffer), "/dev/dvb/adapter%d/frontend0", cardnr);
++ snprintf(buffer, sizeof(buffer), "/dev/dvb/adapter%d/frontend0", cDevice::GetDevice(cardnr)->CardIndex());
+
+ fd_frontend = open(buffer, O_RDONLY | O_NONBLOCK);
+ if (fd_frontend <= 0) {
+@@ -932,12 +932,12 @@ void cScan::Action()
+ char *strDate;
+ asprintf(&strDate,"%s", asctime(localtime(&tt)));
+ strDate[strlen(strDate)-1] = 0;
+- fprintf(fp,"\n\n%s tp=%4d, %6d(%d) TV:%4d Radio:%4d in %3d sec",strDate,i , frequency, !alreadyScanned, tvChannelNames.size()-ntv, radioChannelNames.size()-nradio, (int)difftime(t_out,t_in) );
++ fprintf(fp,"\n\n%s tp=%4d, %6d(%d) TV:%4ld Radio:%4ld in %3d sec",strDate,i , frequency, !alreadyScanned, tvChannelNames.size()-ntv, radioChannelNames.size()-nradio, (int)difftime(t_out,t_in) );
+ fclose(fp);
+
+ fp = fopen("/tmp/tScan.log","a");
+ //fprintf(fp,"\n\n%s tp=%4d, %6d/%2d/%5d TV:%4d Radio:%4d in %3dsec",strDate,i , frequency,(*tp)->Modulation(), (*tp)->Symbolrate(), tvChannelNames.size()-ntv, radioChannelNames.size()-nradio, (int)difftime(t_out,t_in) );
+- fprintf(fp,"\n\ntp=%4d, %6d/%2d/%5d TV:%4d Radio:%4d in %3dsec new:%3d",i , frequency,(*tp)->Modulation(), (*tp)->Symbolrate(), tvChannelNames.size()-ntv, radioChannelNames.size()-nradio, (int)difftime(t_out,t_in),tvChannelNames.size()-ntv+ radioChannelNames.size()-nradio );
++ fprintf(fp,"\n\ntp=%4d, %6d/%2d/%5d TV:%4ld Radio:%4ld in %3dsec new:%3ld",i , frequency,(*tp)->Modulation(), (*tp)->Symbolrate(), tvChannelNames.size()-ntv, radioChannelNames.size()-nradio, (int)difftime(t_out,t_in),tvChannelNames.size()-ntv+ radioChannelNames.size()-nradio );
+ fclose(fp);
+
+ free(strDate);
diff --git a/multimedia/vdr-plugin-reelchannelscan/pkg-descr b/multimedia/vdr-plugin-reelchannelscan/pkg-descr
new file mode 100644
index 000000000000..c7898bbc1e2d
--- /dev/null
+++ b/multimedia/vdr-plugin-reelchannelscan/pkg-descr
@@ -0,0 +1,8 @@
+http://www.vdr-wiki.de/wiki/index.php/Reelchannelscan-plugin
+
+This plugin reads the <vdr-conf-path>/sources.conf and
+parses the coresponding transponderlist (.tpl file),
+then it scans this sat and updates/appends all found channels to
+the current channel list.
+
+WWW: http://www.reel-multimedia.com
diff --git a/multimedia/vdr-plugin-reelchannelscan/pkg-plist b/multimedia/vdr-plugin-reelchannelscan/pkg-plist
new file mode 100644
index 000000000000..af6e8322e392
--- /dev/null
+++ b/multimedia/vdr-plugin-reelchannelscan/pkg-plist
@@ -0,0 +1,82 @@
+lib/vdr/libvdr-reelchannelscan.so.1.7.18
+etc/vdr/plugins/transponders/S0.8W.tpl
+etc/vdr/plugins/transponders/S10.0E.tpl
+etc/vdr/plugins/transponders/S100.5E.tpl
+etc/vdr/plugins/transponders/S105.5E.tpl
+etc/vdr/plugins/transponders/S108.0E.tpl
+etc/vdr/plugins/transponders/S12.5W.tpl
+etc/vdr/plugins/transponders/S13.0E.tpl
+etc/vdr/plugins/transponders/S14.0W.tpl
+etc/vdr/plugins/transponders/S140.0E.tpl
+etc/vdr/plugins/transponders/S15.0W.tpl
+etc/vdr/plugins/transponders/S16.0E.tpl
+etc/vdr/plugins/transponders/S18.0W.tpl
+etc/vdr/plugins/transponders/S19.2E.tpl
+etc/vdr/plugins/transponders/S21.6E.tpl
+etc/vdr/plugins/transponders/S22.0W.tpl
+etc/vdr/plugins/transponders/S23.5E.tpl
+etc/vdr/plugins/transponders/S24.5W.tpl
+etc/vdr/plugins/transponders/S25.5E.tpl
+etc/vdr/plugins/transponders/S26.0E.tpl
+etc/vdr/plugins/transponders/S27.5W.tpl
+etc/vdr/plugins/transponders/S28.2E.tpl
+etc/vdr/plugins/transponders/S30.0W.tpl
+etc/vdr/plugins/transponders/S32.9E.tpl
+etc/vdr/plugins/transponders/S33.0E.tpl
+etc/vdr/plugins/transponders/S35.9E.tpl
+etc/vdr/plugins/transponders/S36.0E.tpl
+etc/vdr/plugins/transponders/S39.0E.tpl
+etc/vdr/plugins/transponders/S4.0W.tpl
+etc/vdr/plugins/transponders/S4.8E.tpl
+etc/vdr/plugins/transponders/S40.0E.tpl
+etc/vdr/plugins/transponders/S41.9E.tpl
+etc/vdr/plugins/transponders/S42.0E.tpl
+etc/vdr/plugins/transponders/S45.0E.tpl
+etc/vdr/plugins/transponders/S5.0W.tpl
+etc/vdr/plugins/transponders/S53.0E.tpl
+etc/vdr/plugins/transponders/S56.0E.tpl
+etc/vdr/plugins/transponders/S57.0E.tpl
+etc/vdr/plugins/transponders/S60.0E.tpl
+etc/vdr/plugins/transponders/S62.0E.tpl
+etc/vdr/plugins/transponders/S66.0E.tpl
+etc/vdr/plugins/transponders/S68.5E.tpl
+etc/vdr/plugins/transponders/S7.0E.tpl
+etc/vdr/plugins/transponders/S7.0W.tpl
+etc/vdr/plugins/transponders/S70.5E.tpl
+etc/vdr/plugins/transponders/S72.0E.tpl
+etc/vdr/plugins/transponders/S75.0E.tpl
+etc/vdr/plugins/transponders/S76.5E.tpl
+etc/vdr/plugins/transponders/S78.5E.tpl
+etc/vdr/plugins/transponders/S8.0W.tpl
+etc/vdr/plugins/transponders/S80.0E.tpl
+etc/vdr/plugins/transponders/S83.0E.tpl
+etc/vdr/plugins/transponders/S88.0E.tpl
+etc/vdr/plugins/transponders/S9.0E.tpl
+etc/vdr/plugins/transponders/S90.0E.tpl
+etc/vdr/plugins/transponders/S91.5E.tpl
+etc/vdr/plugins/transponders/S93.5E.tpl
+etc/vdr/plugins/transponders/S95.0E.tpl
+etc/vdr/plugins/transponders/S96.5E.tpl
+@dirrm etc/vdr/plugins/transponders
+@dirrmtry etc/vdr/plugins
+%%NLS%%share/locale/de_DE/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/sl_SI/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/ro_RO/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/fr_FR/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/hu_HU/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/cs_CZ/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/sv_SE/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/el_GR/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/nn_NO/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/it_IT/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/es_ES/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/fi_FI/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/da_DK/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/hr_HR/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/tr_TR/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/ca_ES/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/et_EE/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/ru_RU/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/nl_NL/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/pl_PL/LC_MESSAGES/vdr-reelchannelscan.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/vdr-reelchannelscan.mo