aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2014-04-27 18:20:50 +0000
committerJuergen Lock <nox@FreeBSD.org>2014-04-27 18:20:50 +0000
commitb17d903e24e566d6000019629e30526b92dbeb4e (patch)
treeff216d6b45ff3e16b82801bad1728d70e427d2e1 /multimedia
parent6a0247ab11e63766014bab2827679288f4613993 (diff)
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vlc/Makefile1
-rw-r--r--multimedia/vlc/files/patch-c1622c2c6e0e15a38fef723086ca8bf75a75b46b-2.1.437
2 files changed, 38 insertions, 0 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index dab3e714341b..f580d7e2f572 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= vlc
DISTVERSION= 2.1.4
+PORTREVISION= 1
PORTEPOCH= 4
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/a$//}/ \
diff --git a/multimedia/vlc/files/patch-c1622c2c6e0e15a38fef723086ca8bf75a75b46b-2.1.4 b/multimedia/vlc/files/patch-c1622c2c6e0e15a38fef723086ca8bf75a75b46b-2.1.4
new file mode 100644
index 000000000000..0a3c04c7ad82
--- /dev/null
+++ b/multimedia/vlc/files/patch-c1622c2c6e0e15a38fef723086ca8bf75a75b46b-2.1.4
@@ -0,0 +1,37 @@
+Backported from:
+
+ http://git.videolan.org/gitweb.cgi/vlc.git/?a=commit;h=c1622c2c6e0e15a38fef723086ca8bf75a75b46b
+
+--- modules/audio_output/oss.c.orig
++++ modules/audio_output/oss.c
+@@ -37,6 +37,7 @@
+ #else
+ # include <sys/soundcard.h>
+ #endif
++#include <errno.h>
+
+ #ifndef SNDCTL_DSP_HALT
+ # define SNDCTL_DSP_HALT SNDCTL_DSP_RESET
+@@ -210,6 +211,22 @@ static int Start (audio_output_t *aout,
+ }
+ aout_FormatPrepare (fmt);
+
++ /* Select timing */
++ unsigned bytes;
++ char buf[1024];
++
++ if (spdif)
++ bytes = AOUT_SPDIF_SIZE;
++ else
++ bytes = fmt->i_rate / (CLOCK_FREQ / AOUT_MIN_PREPARE_TIME)
++ * fmt->i_bytes_per_frame;
++
++ int frag = (AOUT_MAX_ADVANCE_TIME / AOUT_MIN_PREPARE_TIME) << 16
++ | (32 - clz32(bytes - 1));
++ if (ioctl (fd, SNDCTL_DSP_SETFRAGMENT, &frag) < 0)
++ msg_Err (aout, "cannot set 0x%08x fragment: %s", frag,
++ strerror_r(errno, buf, sizeof(buf) - 1));
++
+ VolumeSync (aout);
+ sys->starting = true;
+ sys->format = *fmt;