aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-24 12:34:35 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-24 12:34:35 +0000
commitee0a1935bf34c10a2bef2a5bf8e4f6319f2fb0a0 (patch)
tree4788cd365342608a99663271ef7559aa8c597d85 /multimedia
parent84854faa7c1d24bc6e4de7bea9ebcc4f22e5e694 (diff)
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/multicat/Makefile39
-rw-r--r--multimedia/multicat/distinfo3
-rw-r--r--multimedia/multicat/pkg-descr16
4 files changed, 59 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 1abc6ddf94b7..c99c8ae287a5 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -267,6 +267,7 @@
SUBDIR += msdl
SUBDIR += msopenh264
SUBDIR += msx264
+ SUBDIR += multicat
SUBDIR += mxflib
SUBDIR += mythtv
SUBDIR += mythtv-frontend
diff --git a/multimedia/multicat/Makefile b/multimedia/multicat/Makefile
new file mode 100644
index 000000000000..ae7b98689388
--- /dev/null
+++ b/multimedia/multicat/Makefile
@@ -0,0 +1,39 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= multicat
+PORTVERSION= git20161007
+CATEGORIES= net multimedia
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Simple and efficient multicast and transport stream manipulation
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${LOCALBASE}/include/bitstream/mpeg/ts.h:multimedia/bitstream
+
+USE_GITHUB= yes # XXX: FreeBSD fixes not upstreamed yet
+GH_ACCOUNT= AMDmi3
+GH_TAGNAME= b551ed4
+
+USES= localbase
+ALL_TARGET= ${PORTNAME}
+
+PORTDOCS= AUTHORS Changelog NEWS README
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/multimedia/multicat/distinfo b/multimedia/multicat/distinfo
new file mode 100644
index 000000000000..94974f93c802
--- /dev/null
+++ b/multimedia/multicat/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475850828
+SHA256 (AMDmi3-multicat-git20161007-b551ed4_GH0.tar.gz) = 41a501a654490f6ec3c860ef28d882196bacf485fe04a4da162605c9329e41b3
+SIZE (AMDmi3-multicat-git20161007-b551ed4_GH0.tar.gz) = 42902
diff --git a/multimedia/multicat/pkg-descr b/multimedia/multicat/pkg-descr
new file mode 100644
index 000000000000..f5207753d3c8
--- /dev/null
+++ b/multimedia/multicat/pkg-descr
@@ -0,0 +1,16 @@
+multicat is a 1 input/1 output application. Inputs and outputs can
+be network streams (unicast and multicast), files, directories,
+character devices or FIFOs. It is thought to be a multicast equivalent
+of the popular netcat tool. Typical applications are recording live
+transport streams, or playing out TS files without modification.
+Also it is able to record a continuous stream into a directory,
+rotate the files periodically, and make seamless extracts from it.
+
+Multicat tries to rebuild the internal clock of the input stream;
+but it wants to remain agnostic of what is transported, so in case
+of files the said clock is stored to an auxiliary file (example.aux
+accompanies example.ts) while recording. Other inputs are considered
+"live", and the input clock is simply derived from the reception
+time of the packets.
+
+WWW: http://www.videolan.org/projects/multicat.html