aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-04-11 16:18:19 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-04-11 16:18:19 +0000
commit0de8d1407fc5a29d478f956d3e8366904d4ae1fd (patch)
tree6b550eddf78f49d5b9ec99a7c3899628482d808c /multimedia
parent3996c2c926c1cf4e1d147d3d5843e33d10f07b1a (diff)
downloadports-0de8d1407fc5a29d478f956d3e8366904d4ae1fd.tar.gz
ports-0de8d1407fc5a29d478f956d3e8366904d4ae1fd.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mpeg4ip/files/patch-fix_with_new_ffmpeg22
-rw-r--r--multimedia/transcode/Makefile8
2 files changed, 27 insertions, 3 deletions
diff --git a/multimedia/mpeg4ip/files/patch-fix_with_new_ffmpeg b/multimedia/mpeg4ip/files/patch-fix_with_new_ffmpeg
new file mode 100644
index 000000000000..4e420df790f9
--- /dev/null
+++ b/multimedia/mpeg4ip/files/patch-fix_with_new_ffmpeg
@@ -0,0 +1,22 @@
+--- player/plugin/audio/ffmpeg/ffmpeg.cpp.orig Sun Apr 8 16:21:30 2007
++++ player/plugin/audio/ffmpeg/ffmpeg.cpp Sun Apr 8 16:22:05 2007
+@@ -166,7 +166,7 @@
+ break;
+ }
+ if (userdata) {
+- ffmpeg->m_c->extradata = (void *)userdata;
++ ffmpeg->m_c->extradata = (uint8_t *)userdata;
+ ffmpeg->m_c->extradata_size = ud_size;
+ }
+ if (avcodec_open(ffmpeg->m_c, ffmpeg->m_codec) < 0) {
+--- player/plugin/video/ffmpeg/ffmpeg.cpp.orig Sun Apr 8 16:22:49 2007
++++ player/plugin/video/ffmpeg/ffmpeg.cpp Sun Apr 8 16:23:20 2007
+@@ -255,7 +255,7 @@
+ }
+ break;
+ case CODEC_ID_SVQ3:
+- ffmpeg->m_c->extradata = (void *)userdata;
++ ffmpeg->m_c->extradata = (uint8_t *)userdata;
+ ffmpeg->m_c->extradata_size = ud_size;
+ if (vinfo != NULL) {
+ ffmpeg->m_c->width = vinfo->width;
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index 1558f9dd1933..1bf6bcf9bb23 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -35,7 +35,8 @@ CPPFLAGS= -I${X11BASE}/include -I${LOCALBASE}/include
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
SDL_CONFIG="${SDL_CONFIG}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS+= --with-ffmpeg_libs-prefix=${LOCALBASE} \
+CONFIGURE_ARGS+= --with-libavcodec-includes=${LOCALBASE}/include/ffmpeg \
+ --with-libavcodec-libs=${LOCALBASE}/lib \
--with-libdvdread-prefix=${LOCALBASE} \
--with-libiconv-prefix=${LOCALBASE} \
--enable-oss
@@ -396,8 +397,9 @@ post-patch:
@${REINPLACE_CMD} -E -e 's|(seek)64|\1|' ${WRKSRC}/avilib/avidump.c
@${REINPLACE_CMD} -E -e 's|<SDL/|<|' ${WRKSRC}/filter/preview/display.h
- @${REINPLACE_CMD} -E -e 's|(-la52)|\1 ${LIBA52_DEP_LIBS}|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -E -e 's|(-la52)|\1 ${LIBA52_DEP_LIBS}|g ; \
+ s|FFMPEG_VERSION|LIBAVCODEC_IDENT|g' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
pre-configure:
@${REINPLACE_CMD} -E -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure