aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-09-05 20:37:05 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-09-05 20:37:05 +0000
commit4faf948d7620ac6b10510941f3b793cc47a44816 (patch)
treebb5fb7fe28f135c9c8906d0b23aa222a77190eb7 /multimedia
parentd2ec6995ec37125ba1678b9bccceba92bdbe7593 (diff)
downloadports-4faf948d7620ac6b10510941f3b793cc47a44816.tar.gz
ports-4faf948d7620ac6b10510941f3b793cc47a44816.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vlc/Makefile2
-rw-r--r--multimedia/vlc/files/patch-include-vlc_common.h11
-rw-r--r--multimedia/vlc/files/patch-src-network-udp.c11
3 files changed, 23 insertions, 1 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 43cf2fa6097d..165435a7548f 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vlc
DISTVERSION= 2.0.3
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 3
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/p/-pre/}/ \
diff --git a/multimedia/vlc/files/patch-include-vlc_common.h b/multimedia/vlc/files/patch-include-vlc_common.h
new file mode 100644
index 000000000000..b5b6a19907a6
--- /dev/null
+++ b/multimedia/vlc/files/patch-include-vlc_common.h
@@ -0,0 +1,11 @@
+--- include/vlc_common.h.orig
++++ include/vlc_common.h
+@@ -642,7 +642,7 @@ static inline unsigned popcount (unsigne
+ #endif
+ }
+
+-#ifdef __OS2__
++#if defined(__OS2__) || defined(__FreeBSD__)
+ # undef bswap16
+ # undef bswap32
+ # undef bswap64
diff --git a/multimedia/vlc/files/patch-src-network-udp.c b/multimedia/vlc/files/patch-src-network-udp.c
new file mode 100644
index 000000000000..fdd940b5fe0c
--- /dev/null
+++ b/multimedia/vlc/files/patch-src-network-udp.c
@@ -0,0 +1,11 @@
+--- src/network/udp.c.orig
++++ src/network/udp.c
+@@ -383,7 +383,7 @@ int net_Subscribe (vlc_object_t *obj, in
+ {
+ /* MCAST_JOIN_GROUP was introduced to OS X in v10.7, but it doesn't work,
+ * so ignore it to use the same code as on 10.5 or 10.6 */
+-#if defined (MCAST_JOIN_GROUP) && !defined (__APPLE__)
++#if defined (MCAST_JOIN_GROUP) && !defined (__APPLE__) && !defined (__FreeBSD__)
+ /* Agnostic SSM multicast join */
+ int level;
+ struct group_req gr;