aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-06-17 08:59:33 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-06-17 08:59:33 +0000
commit80fb99f09a396f4b6ba6685345c22ee5804cfbca (patch)
tree9a21ffe1e289706dc6e5c8abbc072184e100efc5 /multimedia
parent8f5b0d0149b8a4e9f787c90fdd3a5d38fbbe1df5 (diff)
downloadports-80fb99f09a396f4b6ba6685345c22ee5804cfbca.tar.gz
ports-80fb99f09a396f4b6ba6685345c22ee5804cfbca.zip
multimedia/ffmpeg: switch to upstream svt-vp9 fix
Notes
Notes: svn path=/head/; revision=539409
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ffmpeg/Makefile2
-rw-r--r--multimedia/ffmpeg/distinfo4
-rw-r--r--multimedia/ffmpeg/files/patch-libavcodec_libsvt__vp9.c14
3 files changed, 3 insertions, 17 deletions
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 4ce2caf9f4ac..2a51822bad71 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -488,7 +488,7 @@ SVTHEVC_LDFLAGS= -fuse-ld=lld
# svt-vp9
SVTVP9_LIB_DEPENDS= libSvtVp9Enc.so:multimedia/svt-vp9
SVTVP9_CONFIGURE_ENABLE= libsvtvp9
-SVTVP9_PATCH_SITES_= https://github.com/OpenVisualCloud/SVT-VP9/raw/v0.2.0-2-gefe9c5a/ffmpeg_plugin/:svtvp9
+SVTVP9_PATCH_SITES_= https://github.com/OpenVisualCloud/SVT-VP9/raw/v0.2.0-5-g1b4277c/ffmpeg_plugin/:svtvp9
SVTVP9_PATCHFILES_= master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9-with-hevc-av1.patch:-p1:svtvp9
.if exists(/usr/bin/ld.lld) && (${/usr/bin/ld:L:tA} != /usr/bin/ld.lld)
SVTVP9_LDFLAGS= -fuse-ld=lld
diff --git a/multimedia/ffmpeg/distinfo b/multimedia/ffmpeg/distinfo
index 3792a40ebf5d..2d0d5be1a1cf 100644
--- a/multimedia/ffmpeg/distinfo
+++ b/multimedia/ffmpeg/distinfo
@@ -7,5 +7,5 @@ SHA256 (0002-doc-Add-libsvt_hevc-encoder-docs.patch) = 1499e419dda72b1604dc5e395
SIZE (0002-doc-Add-libsvt_hevc-encoder-docs.patch) = 5332
SHA256 (0001-Add-ability-for-ffmpeg-to-run-svt-av1-with-svt-hevc.patch) = 69e0456b56429a422977d24a914e7e167a38397b2ab40aec575eee332b0e739c
SIZE (0001-Add-ability-for-ffmpeg-to-run-svt-av1-with-svt-hevc.patch) = 23728
-SHA256 (master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9-with-hevc-av1.patch) = 526f3eba71ff1a2d74e537d8ef777370d9b305a1458799121114b60f7e5a48df
-SIZE (master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9-with-hevc-av1.patch) = 34177
+SHA256 (master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9-with-hevc-av1.patch) = 9d9021dfdf523da60218b2aec58633f969c69107965780794768521314ded807
+SIZE (master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9-with-hevc-av1.patch) = 34077
diff --git a/multimedia/ffmpeg/files/patch-libavcodec_libsvt__vp9.c b/multimedia/ffmpeg/files/patch-libavcodec_libsvt__vp9.c
deleted file mode 100644
index cb79b38ee4de..000000000000
--- a/multimedia/ffmpeg/files/patch-libavcodec_libsvt__vp9.c
+++ /dev/null
@@ -1,14 +0,0 @@
-https://github.com/OpenVisualCloud/SVT-VP9/issues/116
-
---- libavcodec/libsvt_vp9.c.orig 2020-06-15 18:54:23 UTC
-+++ libavcodec/libsvt_vp9.c
-@@ -188,9 +188,6 @@ static int config_enc_params(EbSvtVp9EncConfiguration
- param->min_qp_allowed = avctx->qmin;
- }
-
-- param->intra_refresh_type =
-- !!(avctx->flags & AV_CODEC_FLAG_CLOSED_GOP) + 1;
--
- if (ten_bits) {
- param->encoder_bit_depth = 10;
- }